summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2008-02-23 00:09:24 +0000
committerKeri Harris <keri@gentoo.org>2008-02-23 00:09:24 +0000
commit1a5d908291e313c48fb0d01922116650e1a1a20a (patch)
tree0edb076e0c978ccb9474720d711b97ab32210756 /dev-lang/mozart-stdlib
parentInstall binaries into Mozart bin dir. Closes #210987. (diff)
downloadgentoo-2-1a5d908291e313c48fb0d01922116650e1a1a20a.tar.gz
gentoo-2-1a5d908291e313c48fb0d01922116650e1a1a20a.tar.bz2
gentoo-2-1a5d908291e313c48fb0d01922116650e1a1a20a.zip
Install binaries into Mozart bin dir.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/mozart-stdlib')
-rw-r--r--dev-lang/mozart-stdlib/ChangeLog11
-rw-r--r--dev-lang/mozart-stdlib/files/mozart-stdlib-1.3.2-r1-ozmake.patch78
-rw-r--r--dev-lang/mozart-stdlib/mozart-stdlib-1.3.2-r1.ebuild50
3 files changed, 137 insertions, 2 deletions
diff --git a/dev-lang/mozart-stdlib/ChangeLog b/dev-lang/mozart-stdlib/ChangeLog
index 1a3070490ff3..a9210091d3a4 100644
--- a/dev-lang/mozart-stdlib/ChangeLog
+++ b/dev-lang/mozart-stdlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/mozart-stdlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart-stdlib/ChangeLog,v 1.7 2007/11/16 19:50:38 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart-stdlib/ChangeLog,v 1.8 2008/02/23 00:09:23 keri Exp $
+
+*mozart-stdlib-1.3.2-r1 (23 Feb 2008)
+
+ 23 Feb 2008; keri <keri@gentoo.org>
+ +files/mozart-stdlib-1.3.2-r1-ozmake.patch,
+ +mozart-stdlib-1.3.2-r1.ebuild:
+ Install binaries into Mozart bin dir.
16 Nov 2007; nixnut <nixnut@gentoo.org> mozart-stdlib-1.3.2.ebuild:
Stable on ppc wrt bug 199091
diff --git a/dev-lang/mozart-stdlib/files/mozart-stdlib-1.3.2-r1-ozmake.patch b/dev-lang/mozart-stdlib/files/mozart-stdlib-1.3.2-r1-ozmake.patch
new file mode 100644
index 000000000000..12a621390ebd
--- /dev/null
+++ b/dev-lang/mozart-stdlib/files/mozart-stdlib-1.3.2-r1-ozmake.patch
@@ -0,0 +1,78 @@
+diff -ur mozart-1.3.2.20060615-std.orig/Makefile.in mozart-1.3.2.20060615-std/Makefile.in
+--- mozart-1.3.2.20060615-std.orig/Makefile.in 2004-05-19 02:22:05.000000000 +1200
++++ mozart-1.3.2.20060615-std/Makefile.in 2007-02-17 11:12:09.000000000 +1300
+@@ -12,6 +12,7 @@
+ NOTDIRSRCDIR = $(notdir $(SRCDIR))
+ BUILDDATE = $(shell date '+%Y%m%d')
+ VERSION = $(shell $(OZTOOL) version)
++BINDIR = $(PREFIX)/bin
+
+ ifeq ($(PLATFORM),win32-i486)
+ OZEMULATOR = $(shell $(CYGPATH) $(PREFIX)/platform/win32-i486/emulator.dll)
+@@ -22,11 +23,14 @@
+ $(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR)
+
+ build.ozmake:
+- cd ozmake && $(MAKE) ozmake.ozf
++ cd ozmake && $(MAKE) ozmake
+
+ install: all
+ $(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR) --install --nosavedb
+ $(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR)/ozmake --builddir=$(CYG_BUILDDIR_OZMAKE) --install --nosavedb
++ mkdir -p $(BINDIR)
++ cp ozmake/ozmake $(BINDIR)
++ chmod +x $(BINDIR)/ozmake
+
+ export CLEANDIR
+
+diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Attribs.oz mozart-1.3.2.20060615-std/ozmake/Attribs.oz
+--- mozart-1.3.2.20060615-std.orig/ozmake/Attribs.oz 2004-05-15 03:21:43.000000000 +1200
++++ mozart-1.3.2.20060615-std/ozmake/Attribs.oz 2007-02-17 09:29:47.000000000 +1300
+@@ -458,7 +458,7 @@
+ end
+
+ meth get_oz_home($) {Path.expand {Property.get 'oz.home'}} end
+- meth get_oz_bindir($) {Path.resolve Attribs,get_oz_home($) 'bin'} end
++ meth get_oz_bindir($) {Path.resolve '/usr/lib/mozart' 'bin'} end
+ meth get_oz_engine($)
+ if @OzEngine==unit then
+ P={Path.resolveAtom Attribs,get_oz_bindir($) 'ozengine.exe'}
+diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Makefile.in mozart-1.3.2.20060615-std/ozmake/Makefile.in
+--- mozart-1.3.2.20060615-std.orig/ozmake/Makefile.in 2004-04-01 00:52:55.000000000 +1200
++++ mozart-1.3.2.20060615-std/ozmake/Makefile.in 2007-02-17 10:55:26.000000000 +1300
+@@ -37,8 +37,8 @@
+
+ # these additional 2 lines makes it possible to build in a directory
+ # different from the source directory
+-OZLOAD = prefix=$(CYGSRCDIR)=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGSRCDIR)$(OZLOADSEP)cache=~/.oz/cache$(OZLOADSEP)cache=$(OZHOME)/cache
+-export OZLOAD
++# OZLOAD = prefix=$(CYGSRCDIR)=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGSRCDIR)$(OZLOADSEP)cache=~/.oz/cache$(OZLOADSEP)cache=$(OZHOME)/cache
++# export OZLOAD
+
+ XSLTPROC = @VAR_XSLTPROC@
+ LYNX = @VAR_LYNX@
+diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Makefile.vars mozart-1.3.2.20060615-std/ozmake/Makefile.vars
+--- mozart-1.3.2.20060615-std.orig/ozmake/Makefile.vars 2005-06-05 01:47:45.000000000 +1200
++++ mozart-1.3.2.20060615-std/ozmake/Makefile.vars 2007-02-17 08:42:20.000000000 +1300
+@@ -13,6 +13,6 @@
+ MakeGUI.oz Fixes.oz DatabaseLib.oz CHANGES Config.oz Mogul.oz \
+ Pickler.oz ExecutorFast.oz Depends.oz Requires.oz
+ PKG_INSTALLS = ozmake.ozf
+-PKG_INSTALLS_BIN= ozmake ozmake.win
++PKG_INSTALLS_BIN= ozmake
+ PKG_UPDATE = tgz tarz
+ PKG_INSTALLS_DOC= index.html CHANGES
+diff -ur mozart-1.3.2.20060615-std.orig/ozmake/makefile.oz mozart-1.3.2.20060615-std/ozmake/makefile.oz
+--- mozart-1.3.2.20060615-std.orig/ozmake/makefile.oz 2004-05-22 09:37:24.000000000 +1200
++++ mozart-1.3.2.20060615-std/ozmake/makefile.oz 2007-02-17 12:15:46.000000000 +1300
+@@ -4,8 +4,8 @@
+ mogul : 'mogul:/mozart/ozmake'
+ author: 'mogul:/duchier/denys'
+ lib : ['ozmake.ozf']
+- bin : ['ozmake.exe']
+- doc : ['index.html' 'CHANGES']
++% bin : ['ozmake.exe']
++% doc : ['index.html' 'CHANGES']
+ rules :
+ o(
+ 'ozmake.ozf' : ozl('Main.ozf')
diff --git a/dev-lang/mozart-stdlib/mozart-stdlib-1.3.2-r1.ebuild b/dev-lang/mozart-stdlib/mozart-stdlib-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..c1372b45fe84
--- /dev/null
+++ b/dev-lang/mozart-stdlib/mozart-stdlib-1.3.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart-stdlib/mozart-stdlib-1.3.2-r1.ebuild,v 1.1 2008/02/23 00:09:23 keri Exp $
+
+inherit eutils
+
+MY_P="mozart-${PV}.20060615-std"
+
+DESCRIPTION="The Mozart Standard Library"
+HOMEPAGE="http://www.mozart-oz.org/"
+SRC_URI="http://www.mozart-oz.org/download/mozart-ftp/store/1.3.2-2006-06-15-tar/mozart-1.3.2.20060615-std.tar.gz"
+LICENSE="Mozart"
+
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/mozart"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}-ozmake.patch
+ epatch "${FILESDIR}"/${P}-doc.patch
+}
+
+src_compile() {
+ cd "${S}"
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}"/usr/lib/mozart \
+ install || die "emake install failed"
+
+ dosym /usr/lib/mozart/bin/ozmake /usr/bin/ozmake
+
+ if use doc ; then
+ dohtml -r *
+ fi
+
+ doman ozmake/ozmake.1
+ dodoc ozmake/{CHANGES,DESIGN,NOTES,README}
+}