summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2006-09-20 11:57:34 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2006-09-20 11:57:34 +0000
commitf55bda3014a294a647961762dd5053dd74a4a1a8 (patch)
tree0141bb507ff6d020b71df84e2a3541f7358a0233 /dev-lang/ocaml
parentVersion bump. (diff)
downloadgentoo-2-f55bda3014a294a647961762dd5053dd74a4a1a8.tar.gz
gentoo-2-f55bda3014a294a647961762dd5053dd74a4a1a8.tar.bz2
gentoo-2-f55bda3014a294a647961762dd5053dd74a4a1a8.zip
fix for ppc32/64 (bug #135641).
(Portage version: 2.1.1)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.09.3.ebuild5
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 7357aee238f6..2aaf5f61f15d 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.84 2006/09/14 16:13:56 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.85 2006/09/20 11:57:34 nattfodd Exp $
+
+ 20 Sep 2006; Alexandre Buisse <nattfodd@gentoo.org> ocaml-3.09.3.ebuild:
+ Add fix for finding correct arch in cases where kernel_arch != system_arch
+ (bug #135641).
14 Sep 2006; Matthieu Sozeau <mattam@gentoo.org> files/ocaml-rebuild.sh:
Add a test for slots
diff --git a/dev-lang/ocaml/ocaml-3.09.3.ebuild b/dev-lang/ocaml/ocaml-3.09.3.ebuild
index 066744aa18fc..4637cd186835 100644
--- a/dev-lang/ocaml/ocaml-3.09.3.ebuild
+++ b/dev-lang/ocaml/ocaml-3.09.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3.ebuild,v 1.1 2006/09/16 19:37:13 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3.ebuild,v 1.2 2006/09/20 11:57:34 nattfodd Exp $
inherit flag-o-matic eutils multilib
@@ -32,6 +32,9 @@ src_compile() {
local myconf
use tcltk || myconf="-no-tk"
+ # Fix for kernel_arch != system_ach (bug #135641)
+ myconf=${myconf} "-host ${CHOST}"
+
# Fix for bug #46703
export LC_ALL=C