summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-08 20:33:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-08 20:33:23 +0000
commitd546202d71b55bdc31a08838a147f8b4aa7f2d95 (patch)
tree1fd727c59939faba6fa97c56bf7d2916bf9b35ca /dev-lang/parrot
parentRemoving duplicate docs. Fix bug #297967 (diff)
downloadgentoo-2-d546202d71b55bdc31a08838a147f8b4aa7f2d95.tar.gz
gentoo-2-d546202d71b55bdc31a08838a147f8b4aa7f2d95.tar.bz2
gentoo-2-d546202d71b55bdc31a08838a147f8b4aa7f2d95.zip
Bump to 1.9.0. Tests finally pass.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/parrot-1.9.0.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index e2280baf5b8b..e0ec1e9bdbdb 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.27 2009/11/02 18:49:36 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.28 2010/01/08 20:33:23 patrick Exp $
+
+*parrot-1.9.0 (08 Jan 2010)
+
+ 08 Jan 2010; Patrick Lauer <patrick@gentoo.org> +parrot-1.9.0.ebuild:
+ Bump to 1.9.0. Tests finally pass.
*parrot-1.7.0 (02 Nov 2009)
diff --git a/dev-lang/parrot/parrot-1.9.0.ebuild b/dev-lang/parrot/parrot-1.9.0.ebuild
new file mode 100644
index 000000000000..7639db72e1db
--- /dev/null
+++ b/dev-lang/parrot/parrot-1.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-1.9.0.ebuild,v 1.1 2010/01/08 20:33:23 patrick Exp $
+
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="Parrot is a virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl nls doc examples gdbm gmp ssl unicode pcre"
+
+RDEPEND="opengl? ( virtual/glut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:/lib/:/$(get_libdir)/:" -i "${S}/tools/dev/install_files.pl"
+}
+
+src_configure() {
+ myconf=""
+ use unicode || myconf="$myconf --without-icu"
+ use ssl || myconf="$myconf --without-crypto"
+ use gdbm || myconf="$myconf --without-gdbm"
+ use nls || myconf="$myconf --without-gettext"
+ use gmp || myconf="$myconf --without-gmp"
+ use opengl || myconf="$myconf --without-opengl"
+ use pcre || myconf="$myconf --without-pcre"
+
+ perl Configure.pl --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --sysconfdir=/etc \
+ --sharedstatedir=/var/lib/parrot \
+ $myconf
+}
+
+src_compile() {
+ emake || die
+ use doc && make html
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="/usr/share/doc/${P}" || die
+}