summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
commit500c03b1a177d64c30246fae46d7bc8e0d89475c (patch)
tree62833a55b666dc22cf4c51cc77ac36adb22896e8 /dev-lang/python/python-2.3.4_rc1.ebuild
parentglibc ----------------------------> libc ! (Manifest recommit) (diff)
downloadgentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.tar.gz
gentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.tar.bz2
gentoo-2-500c03b1a177d64c30246fae46d7bc8e0d89475c.zip
QA - fix use invocation and a bug in the 2.3.4 ebuilds: [ -z "use X" -o -z "use tcltk" ] doesn't do what you meant it to do
Diffstat (limited to 'dev-lang/python/python-2.3.4_rc1.ebuild')
-rw-r--r--dev-lang/python/python-2.3.4_rc1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.3.4_rc1.ebuild b/dev-lang/python/python-2.3.4_rc1.ebuild
index 2074aefc34e5..af90097e6f11 100644
--- a/dev-lang/python/python-2.3.4_rc1.ebuild
+++ b/dev-lang/python/python-2.3.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.7 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.8 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -72,7 +72,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "use X" -o -z "use tcltk" ] \
+ ( use !X || use !tcltk ) \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
@@ -94,7 +94,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi