summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-24 01:52:15 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-24 01:52:15 +0000
commit7ff4f262e0d2c2c4ecd86dc510494db55b16ea80 (patch)
tree8a52e067d47ced469839f6e2e3785ba6995ac535 /dev-lang/python
parentcleanup and stable bump (Manifest recommit) (diff)
downloadgentoo-2-7ff4f262e0d2c2c4ecd86dc510494db55b16ea80.tar.gz
gentoo-2-7ff4f262e0d2c2c4ecd86dc510494db55b16ea80.tar.bz2
gentoo-2-7ff4f262e0d2c2c4ecd86dc510494db55b16ea80.zip
stable bump for python-2.3, remember to run /usr/sbin/python-updater if you are upgrading from 2.2
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/files/digest-python-2.2.31
-rw-r--r--dev-lang/python/files/digest-python-2.2.3-r11
-rw-r--r--dev-lang/python/python-2.2.3-r1.ebuild110
-rw-r--r--dev-lang/python/python-2.2.3.ebuild98
-rw-r--r--dev-lang/python/python-2.3.3.ebuild4
5 files changed, 2 insertions, 212 deletions
diff --git a/dev-lang/python/files/digest-python-2.2.3 b/dev-lang/python/files/digest-python-2.2.3
deleted file mode 100644
index 283c3d783859..000000000000
--- a/dev-lang/python/files/digest-python-2.2.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 169f89f318e252dac0c54dd1b165d229 Python-2.2.3.tgz 6709556
diff --git a/dev-lang/python/files/digest-python-2.2.3-r1 b/dev-lang/python/files/digest-python-2.2.3-r1
deleted file mode 100644
index 283c3d783859..000000000000
--- a/dev-lang/python/files/digest-python-2.2.3-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 169f89f318e252dac0c54dd1b165d229 Python-2.2.3.tgz 6709556
diff --git a/dev-lang/python/python-2.2.3-r1.ebuild b/dev-lang/python/python-2.2.3-r1.ebuild
deleted file mode 100644
index 4d78e714ba61..000000000000
--- a/dev-lang/python/python-2.2.3-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r1.ebuild,v 1.11 2003/10/09 12:11:47 tuxus Exp $
-
-IUSE="readline tcltk berkdb bootstrap build doc"
-
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
-PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
-
-S="${WORKDIR}/Python-${PV}"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tgz"
-
-HOMEPAGE="http://www.python.org"
-LICENSE="PSF-2.2"
-KEYWORDS="~amd64 x86 ppc ~sparc ~alpha mips hppa ~arm ia64"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- doc? ( =dev-python/python-docs-${PV}* )
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )
- || ( dev-libs/expat
- ( !build? ( dev-libs/expat ) )
- ( !bootstrap? ( dev-libs/expat ) )
- )"
-# This is a hairy one. Basically depend on dev-libs/expat
-# if "build" or "bootstrap" not in USE.
-
-RDEPEND="${DEPEND} dev-python/python-fchksum"
-
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
-
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-inherit flag-o-matic eutils
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/${P}-db4.patch
-}
-
-src_compile() {
- filter-flags -malign-double
-
- # during building, ./python -E segfaults with propolice
- filter-flags -fstack-protector
-
- [ "${ARCH}" = "hppa" ] && append-flags -fPIC
- [ "${ARCH}" = "alpha" ] && append-flags -fPIC
- export OPT="${CFLAGS}"
-
- # adjust makefile to install pydoc into ${D} correctly
- t="${S}/Makefile.pre.in"
- cp ${t} ${t}.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' ${t}.orig > ${t}
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
-
- # build python with threads support
- myopts="${myopts} --with-threads"
-
- econf --with-fpectl \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- ${myopts} || die
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
-
- rm -f ${D}/usr/bin/python
- dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
- dosym python${PYVER_MAJOR} /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PYVER} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # While we're working on the config stuff... Let's fix the OPT var
- # so that it doesn't have any opts listed in it. Prevents the problem
- # with compiling things with conflicting opts later.
- dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' /usr/lib/python${PYVER}/config/Makefile
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- dodir /usr/lib/python${PYVER}/tools
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
-
diff --git a/dev-lang/python/python-2.2.3.ebuild b/dev-lang/python/python-2.2.3.ebuild
deleted file mode 100644
index bf10659eef01..000000000000
--- a/dev-lang/python/python-2.2.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3.ebuild,v 1.7 2003/09/06 22:27:51 msterret Exp $
-
-IUSE="readline tcltk berkdb bootstrap"
-
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
-PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
-
-S="${WORKDIR}/Python-${PV}"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tgz"
-
-HOMEPAGE="http://www.python.org"
-LICENSE="PSF-2.2"
-KEYWORDS="amd64 x86 ppc sparc ~alpha mips ~hppa ~arm"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )
- || ( dev-libs/expat
- ( !build? ( dev-libs/expat ) )
- ( !bootstrap? ( dev-libs/expat ) )
- )"
-# This is a hairy one. Basically depend on dev-libs/expat
-# if "build" or "bootstrap" not in USE.
-
-RDEPEND="${DEPEND} dev-python/python-fchksum"
-
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
-
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-inherit flag-o-matic
-
-src_compile() {
- filter-flags -malign-double
-
- [ "${ARCH}" = "hppa" ] && append-flags -fPIC
- [ "${ARCH}" = "alpha" ] && append-flags -fPIC
- export OPT="${CFLAGS}"
-
- # adjust makefile to install pydoc into ${D} correctly
- t="${S}/Makefile.pre.in"
- cp ${t} ${t}.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' ${t}.orig > ${t}
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
-
- econf --with-fpectl \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- ${myopts} || die
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
-
- rm -f ${D}/usr/bin/python
- dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
- dosym python${PYVER_MAJOR} /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PYVER} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # While we're working on the config stuff... Let's fix the OPT var
- # so that it doesn't have any opts listed in it. Prevents the problem
- # with compiling things with conflicting opts later.
- dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' /usr/lib/python${PYVER}/config/Makefile
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- dodir /usr/lib/python${PYVER}/tools
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
-
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index 0d88d023460f..b94d73ad4942 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.4 2004/01/22 01:46:48 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.5 2004/01/24 01:52:15 liquidx Exp $
inherit flag-o-matic python
@@ -18,7 +18,7 @@ IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2"
LICENSE="PSF-2.2"
SLOT="2.3"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
# "~ppc ~sparc ~alpha ~mips ~hppa ~arm"
DEPEND="virtual/glibc