summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-30 21:57:26 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-30 21:57:26 +0000
commit99af4252506b526bd611f53cda04c648a0855d86 (patch)
treeed8e0c78e34769920642f88f18c71d58736cdb1a /dev-lang/python
parentDrop old (diff)
downloadgentoo-2-99af4252506b526bd611f53cda04c648a0855d86.tar.gz
gentoo-2-99af4252506b526bd611f53cda04c648a0855d86.tar.bz2
gentoo-2-99af4252506b526bd611f53cda04c648a0855d86.zip
Don't die on broken sem_open if threads flag is disabled.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.6.8-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.6.9.ebuild4
-rw-r--r--dev-lang/python/python-2.7.5-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.7.5-r4.ebuild4
-rw-r--r--dev-lang/python/python-2.7.6.ebuild4
-rw-r--r--dev-lang/python/python-3.2.5-r3.ebuild4
-rw-r--r--dev-lang/python/python-3.3.2-r2.ebuild4
-rw-r--r--dev-lang/python/python-3.3.3.ebuild4
9 files changed, 23 insertions, 17 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 85b4b07a59c3..6f5440841d1b 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.724 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.725 2013/12/30 21:57:26 floppym Exp $
+
+ 30 Dec 2013; Mike Gilbert <floppym@gentoo.org> python-2.6.8-r3.ebuild,
+ python-2.6.9.ebuild, python-2.7.5-r3.ebuild, python-2.7.5-r4.ebuild,
+ python-2.7.6.ebuild, python-3.2.5-r3.ebuild, python-3.3.2-r2.ebuild,
+ python-3.3.3.ebuild:
+ Don't die on broken sem_open if threads flag is disabled.
30 Dec 2013; Mike Gilbert <floppym@gentoo.org> python-2.6.8-r3.ebuild,
python-2.6.9.ebuild, python-2.7.5-r3.ebuild, python-2.7.5-r4.ebuild,
diff --git a/dev-lang/python/python-2.6.8-r3.ebuild b/dev-lang/python/python-2.6.8-r3.ebuild
index cb25b019d12a..52e105ac1bcb 100644
--- a/dev-lang/python/python-2.6.8-r3.ebuild
+++ b/dev-lang/python/python-2.6.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r3.ebuild,v 1.13 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r3.ebuild,v 1.14 2013/12/30 21:57:26 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -197,7 +197,7 @@ src_configure() {
--with-libc="" \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-2.6.9.ebuild b/dev-lang/python/python-2.6.9.ebuild
index e43e54692c72..bc9c14c3b870 100644
--- a/dev-lang/python/python-2.6.9.ebuild
+++ b/dev-lang/python/python-2.6.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.9.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.9.ebuild,v 1.3 2013/12/30 21:57:26 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -196,7 +196,7 @@ src_configure() {
--with-libc="" \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-2.7.5-r3.ebuild b/dev-lang/python/python-2.7.5-r3.ebuild
index fd1e70138665..4dd8bf8ad971 100644
--- a/dev-lang/python/python-2.7.5-r3.ebuild
+++ b/dev-lang/python/python-2.7.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r3.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r3.ebuild,v 1.3 2013/12/30 21:57:26 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -204,7 +204,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-2.7.5-r4.ebuild b/dev-lang/python/python-2.7.5-r4.ebuild
index d88354cca272..6cc64d609741 100644
--- a/dev-lang/python/python-2.7.5-r4.ebuild
+++ b/dev-lang/python/python-2.7.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r4.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r4.ebuild,v 1.3 2013/12/30 21:57:26 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -205,7 +205,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-2.7.6.ebuild b/dev-lang/python/python-2.7.6.ebuild
index 83ceedeee4fd..411fe2801a9d 100644
--- a/dev-lang/python/python-2.7.6.ebuild
+++ b/dev-lang/python/python-2.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.6.ebuild,v 1.3 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.6.ebuild,v 1.4 2013/12/30 21:57:26 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -200,7 +200,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-3.2.5-r3.ebuild b/dev-lang/python/python-3.2.5-r3.ebuild
index df0f3c11400c..fbc49fffddb5 100644
--- a/dev-lang/python/python-3.2.5-r3.ebuild
+++ b/dev-lang/python/python-3.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r3.ebuild,v 1.2 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r3.ebuild,v 1.3 2013/12/30 21:57:26 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -196,7 +196,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-3.3.2-r2.ebuild b/dev-lang/python/python-3.3.2-r2.ebuild
index da5cb490fe0c..7b3bebb72ac5 100644
--- a/dev-lang/python/python-3.3.2-r2.ebuild
+++ b/dev-lang/python/python-3.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.2-r2.ebuild,v 1.15 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.2-r2.ebuild,v 1.16 2013/12/30 21:57:26 floppym Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -169,7 +169,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"
diff --git a/dev-lang/python/python-3.3.3.ebuild b/dev-lang/python/python-3.3.3.ebuild
index dc69abb97942..6e174bbaa8eb 100644
--- a/dev-lang/python/python-3.3.3.ebuild
+++ b/dev-lang/python/python-3.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.5 2013/12/30 01:45:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.3.3.ebuild,v 1.6 2013/12/30 21:57:26 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -167,7 +167,7 @@ src_configure() {
--with-system-expat \
--with-system-ffi
- if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
+ if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."
eerror "Please ensure that /dev/shm is mounted as a tmpfs with mode 1777."
die "Broken sem_open function (bug 496328)"