summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-26 12:04:53 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-26 12:04:53 +0000
commitd984d5905cb36208d14c26cb4319262c1dceb765 (patch)
treeeb1bb8d54f2d560fe7c4b1ad4f2e93535ef66e73 /dev-lang/python
parentRemoving wmmixer-alsa as wmmixer now supports both ALSA and OSS. (diff)
downloadgentoo-2-d984d5905cb36208d14c26cb4319262c1dceb765.tar.gz
gentoo-2-d984d5905cb36208d14c26cb4319262c1dceb765.tar.bz2
gentoo-2-d984d5905cb36208d14c26cb4319262c1dceb765.zip
re-instating pkg_setup() warning/abort message. added apache mime.types to mime type search list. changed to tar.bz2
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/files/digest-python-2.3.32
-rw-r--r--dev-lang/python/files/python-2.3-mimetypes_apache.patch11
-rw-r--r--dev-lang/python/python-2.3.3.ebuild14
4 files changed, 25 insertions, 8 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 1bdab08e31b5..ec7598908fe5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.73 2004/01/24 22:31:51 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.74 2004/01/26 12:04:53 liquidx Exp $
+
+ 26 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
+ re-instating pkg_setup() warning/abort message. added apache mime.types to
+ mime type search list. modified to use tar.bz2 (saves 1MB of downloads)
24 Jan 2004; Guy Martin <gmsoft@gentoo.org> python-2.3.3.ebuild:
Added ~hppa to KEYWORDS.
diff --git a/dev-lang/python/files/digest-python-2.3.3 b/dev-lang/python/files/digest-python-2.3.3
index 297b96aa86d0..8c0e033775a0 100644
--- a/dev-lang/python/files/digest-python-2.3.3
+++ b/dev-lang/python/files/digest-python-2.3.3
@@ -1 +1 @@
-MD5 4d16732b1cfccc0ed250956d41463c61 Python-2.3.3.tgz 8491380
+MD5 70ada9f65742ab2c77a96bcd6dffd9b1 Python-2.3.3.tar.bz2 7195007
diff --git a/dev-lang/python/files/python-2.3-mimetypes_apache.patch b/dev-lang/python/files/python-2.3-mimetypes_apache.patch
new file mode 100644
index 000000000000..7254aa0b2ecb
--- /dev/null
+++ b/dev-lang/python/files/python-2.3-mimetypes_apache.patch
@@ -0,0 +1,11 @@
+--- Lib/mimetypes.py.old 2004-01-24 21:48:39.957577048 +0000
++++ Lib/mimetypes.py 2004-01-24 21:49:27.023421952 +0000
+@@ -33,6 +33,8 @@
+
+ knownfiles = [
+ "/etc/mime.types",
++ "/etc/apache/conf/mime.types", # Apache 1.x for Gentoo
++ "/etc/apache2/conf/mime.types", # Apache 2.x for Gentoo
+ "/usr/local/etc/httpd/conf/mime.types",
+ "/usr/local/lib/netscape/mime.types",
+ "/usr/local/etc/httpd/conf/mime.types", # Apache 1.2
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index ba51bedd3fe0..aede86041f46 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.8 2004/01/24 22:31:51 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.9 2004/01/26 12:04:53 liquidx Exp $
inherit flag-o-matic python
@@ -11,7 +11,7 @@ PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S="${WORKDIR}/Python-${MY_PV}"
DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${MY_PV}.tgz"
+SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${MY_PV}.tar.bz2"
HOMEPAGE="http://www.python.org"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc"
@@ -43,7 +43,7 @@ PROVIDE="virtual/python"
# add portage to DEPENDS otherwise it'll create a circular dependency
# NOTE: we don't need this any more as sys-apps/portage-2.0.49-r18 is
# already stable
-pkg_setup_disabled() {
+pkg_setup() {
if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
eerror "Please run: emerge portage"
@@ -54,12 +54,14 @@ pkg_setup_disabled() {
src_unpack() {
unpack ${A}
+ cd ${S}
# adds /usr/lib/portage/pym to sys.path - liquidx (08 Oct 03)
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-add_portage_search_path.patch
+ epatch ${FILESDIR}/${PN}-2.3-add_portage_search_path.patch
# adds support for PYTHON_DONTCOMPILE shell environment to
# supress automatic generation of .pyc and .pyo files - liquidx (08 Oct 03)
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-gentoo_py_dontcompile.patch
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
+ epatch ${FILESDIR}/${PN}-2.3-gentoo_py_dontcompile.patch
+ epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
+ epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
}
src_configure() {