summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-07-20 00:21:52 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-07-20 00:21:52 +0000
commitf0ed668fc1a18056b724b793c07e068a770e9cd7 (patch)
tree96a48ffa949a2e3cdd1f30a76604a92c346083f4 /dev-lang/rubinius
parentMask sys-auth/pam_ssh_agent in favour of sys-auth/pam_ssh (diff)
downloadgentoo-2-f0ed668fc1a18056b724b793c07e068a770e9cd7.tar.gz
gentoo-2-f0ed668fc1a18056b724b793c07e068a770e9cd7.tar.bz2
gentoo-2-f0ed668fc1a18056b724b793c07e068a770e9cd7.zip
version bump, 0.9.0
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang/rubinius')
-rw-r--r--dev-lang/rubinius/ChangeLog7
-rw-r--r--dev-lang/rubinius/rubinius-0.9.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-lang/rubinius/ChangeLog b/dev-lang/rubinius/ChangeLog
index c0504357a63a..4f9b8ef71fb4 100644
--- a/dev-lang/rubinius/ChangeLog
+++ b/dev-lang/rubinius/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/rubinius
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/ChangeLog,v 1.2 2008/02/08 15:23:39 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/ChangeLog,v 1.3 2008/07/20 00:21:52 caleb Exp $
+
+*rubinius-0.9.0 (20 Jul 2008)
+
+ 20 Jul 2008; Caleb Tennis <caleb@gentoo.org> +rubinius-0.9.0.ebuild:
+ version bump, 0.9.0
*rubinius-0.8_pre20080208 (08 Feb 2008)
diff --git a/dev-lang/rubinius/rubinius-0.9.0.ebuild b/dev-lang/rubinius/rubinius-0.9.0.ebuild
new file mode 100644
index 000000000000..fae2d26100ed
--- /dev/null
+++ b/dev-lang/rubinius/rubinius-0.9.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/rubinius-0.9.0.ebuild,v 1.1 2008/07/20 00:21:52 caleb Exp $
+
+EAPI=1
+EGIT_REPO_URI="git://git.rubini.us/code"
+
+inherit multilib git
+
+# Must go after inherit git
+# This is the tree shaid that we want to grab
+EGIT_TREE="tags/v0.9.0"
+
+DESCRIPTION="An alternative ruby interpreter"
+HOMEPAGE="http://rubini.us"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/ruby-1.8.6_p110:1.8
+ dev-ruby/rubygems"
+DEPEND="sys-devel/bison
+ dev-util/pkgconfig
+ dev-ruby/rake
+ ${RDEPEND}"
+
+src_compile() {
+ export PREFIX="${S}"/usr
+
+ if use debug; then
+ DEV=1 rake build
+ else
+ rake build
+ fi
+}
+
+src_install() {
+ mkdir -p "${D}/usr/lib"
+ install -c lib/librubinius-0.9.0.so "${D}/usr/lib"
+
+ mkdir -p "${D}/usr/bin"
+ install -c bin/rbx "${D}/usr/bin"
+
+ export PREFIX="${D}"/usr
+ rake install
+}
+
+src_test() {
+ ./bin/ci
+}