summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-25 14:23:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-25 14:23:16 +0000
commitf630a1d062ffa3b9d4e092262639e8241bdbfa38 (patch)
tree782d1ef5183961c50c1718655e8df0fbe9733f4b /dev-lang/ruby
parentFix path for bug #159071 (diff)
downloadgentoo-2-f630a1d062ffa3b9d4e092262639e8241bdbfa38.tar.gz
gentoo-2-f630a1d062ffa3b9d4e092262639e8241bdbfa38.tar.bz2
gentoo-2-f630a1d062ffa3b9d4e092262639e8241bdbfa38.zip
Version bump, thanks to M. Edward Borasky in bug #158458.
(Portage version: 2.1.2_rc4)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.5_p126
-rw-r--r--dev-lang/ruby/ruby-1.8.5_p12.ebuild146
3 files changed, 158 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 9725aebc4206..9007d6827d53 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.247 2006/12/14 14:20:08 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.248 2006/12/25 14:23:15 flameeyes Exp $
+
+*ruby-1.8.5_p12 (25 Dec 2006)
+
+ 25 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5_p12.ebuild:
+ Version bump, thanks to M. Edward Borasky in bug #158458.
14 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
ruby-1.8.5_p2.ebuild:
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.5_p12 b/dev-lang/ruby/files/digest-ruby-1.8.5_p12
new file mode 100644
index 000000000000..386047e9dce9
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.5_p12
@@ -0,0 +1,6 @@
+MD5 dcaa0b3608990791a5348e94b2f427d5 onigd2_5_7.tar.gz 215529
+RMD160 43cf52af1243acf21932690307ed7b0c81ff2771 onigd2_5_7.tar.gz 215529
+SHA256 205b2857d77efc4caa3b98eaf91fd1cc8b8722b497df933d1fbd23f7a5186549 onigd2_5_7.tar.gz 215529
+MD5 d7d12dd9124c9b7d55cdbbee313e3931 ruby-1.8.5-p12.tar.gz 4526961
+RMD160 104e78ea4ce0d8fbd3ca1195ca064eda9c9721ea ruby-1.8.5-p12.tar.gz 4526961
+SHA256 c72ad433adee87c79ece02f506008afa9ea783a11d1acdaf4107306caede5d0a ruby-1.8.5-p12.tar.gz 4526961
diff --git a/dev-lang/ruby/ruby-1.8.5_p12.ebuild b/dev-lang/ruby/ruby-1.8.5_p12.ebuild
new file mode 100644
index 000000000000..5dcede29e152
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.5_p12.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p12.ebuild,v 1.1 2006/12/25 14:23:16 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_7"
+
+inherit flag-o-matic alternatives eutils multilib autotools versionator
+
+MY_P="${P/_p/-p}"
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${MY_P}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug socks5 tk cjk doc threads examples ipv6"
+RESTRICT="confcache"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3
+ !=dev-lang/ruby-cvs-1.8*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+# epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+ econf --with-rubydir=${S} || die "econf failed"
+ MY_PV=$(get_version_component_range 1-2)
+ make ${MY_PV/./}
+ popd
+ fi
+
+ cd "${S}"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6 ipv6) \
+ $(use_enable debug debug) \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find ${S}/ext -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir ${ROOT}usr/share/doc/${PF}
+ cp -pPR sample ${D}/${ROOT}usr/share/doc/${PF}
+ fi
+
+ if use ppc-macos ; then
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
+ else
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
+ fi
+
+ dodoc ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+ if ! use ppc-macos ; then
+ ewarn
+ ewarn "Warning: Vim won't work if you've just updated ruby from"
+ ewarn "1.6.x to 1.8.x due to the library version change."
+ ewarn "In that case, you will need to remerge vim."
+ ewarn
+
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ einfo
+ einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ if ! use ppc-macos ; then
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ fi
+}