summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-07-04 14:56:04 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-07-04 14:56:04 +0000
commit8166e1efba02ad6766eac1d9e03cf93f82353334 (patch)
tree084df84a26ccd4bbaa3b38387603f033564e69d0 /dev-lang/rust
parentVersion bump, drop old (diff)
downloadgentoo-2-8166e1efba02ad6766eac1d9e03cf93f82353334.tar.gz
gentoo-2-8166e1efba02ad6766eac1d9e03cf93f82353334.tar.bz2
gentoo-2-8166e1efba02ad6766eac1d9e03cf93f82353334.zip
version bump, fix bug 553442
(Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key B2EFA1D4)
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/ChangeLog8
-rw-r--r--dev-lang/rust/files/rust-1.1.0-install.patch16
-rw-r--r--dev-lang/rust/rust-1.1.0.ebuild (renamed from dev-lang/rust/rust-1.0.0.ebuild)20
3 files changed, 31 insertions, 13 deletions
diff --git a/dev-lang/rust/ChangeLog b/dev-lang/rust/ChangeLog
index 8c9bfd601d03..adea830457c5 100644
--- a/dev-lang/rust/ChangeLog
+++ b/dev-lang/rust/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/rust
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.20 2015/06/06 15:39:57 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.21 2015/07/04 14:56:04 jauhien Exp $
+
+*rust-1.1.0 (04 Jul 2015)
+
+ 04 Jul 2015; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/rust-1.1.0-install.patch, +rust-1.1.0.ebuild, -rust-1.0.0.ebuild:
+ version bump, fix bug 553442
06 Jun 2015; Jauhien Piatlicki <jauhien@gentoo.org> rust-1.0.0.ebuild:
move to new SLOTs schema
diff --git a/dev-lang/rust/files/rust-1.1.0-install.patch b/dev-lang/rust/files/rust-1.1.0-install.patch
new file mode 100644
index 000000000000..ee8c3f4813ca
--- /dev/null
+++ b/dev-lang/rust/files/rust-1.1.0-install.patch
@@ -0,0 +1,16 @@
+# le kludge that fixes https://github.com/Heather/gentoo-rust/issues/41
+--- src/rust-installer/install-template.sh
++++ src/rust-installer/install-template.sh
+@@ -622,12 +622,6 @@ install_components() {
+ # Decide the destination of the file
+ local _file_install_path="$_dest_prefix/$_file"
+
+- if echo "$_file" | grep "^lib/" > /dev/null
+- then
+- local _f="$(echo "$_file" | sed 's/^lib\///')"
+- _file_install_path="$CFG_LIBDIR/$_f"
+- fi
+-
+ if echo "$_file" | grep "^share/man/" > /dev/null
+ then
+ local _f="$(echo "$_file" | sed 's/^share\/man\///')"
diff --git a/dev-lang/rust/rust-1.0.0.ebuild b/dev-lang/rust/rust-1.1.0.ebuild
index 8431643599fa..9d5a629ef408 100644
--- a/dev-lang/rust/rust-1.0.0.ebuild
+++ b/dev-lang/rust/rust-1.1.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.0.0.ebuild,v 1.2 2015/06/06 15:39:57 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-1.1.0.ebuild,v 1.1 2015/07/04 14:56:04 jauhien Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils python-any-r1
+inherit eutils multilib python-any-r1
MY_P="rustc-${PV}"
@@ -14,8 +14,9 @@ DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="http://www.rust-lang.org/"
SRC_URI="http://static.rust-lang.org/dist/${MY_P}-src.tar.gz
- x86? ( http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-03-27-5520801-linux-i386-1ef82402ed16f5a6d2f87a9a62eaa83170e249ec.tar.bz2 )
- amd64? ( http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-03-27-5520801-linux-x86_64-ef2154372e97a3cb687897d027fd51c8f2c5f349.tar.bz2 )"
+ amd64? ( http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-04-27-857ef6e-linux-x86_64-94089740e48167c5975c92c139ae9c286764012f.tar.bz2 )
+ x86? ( http://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-04-27-857ef6e-linux-i386-0bc8cffdce611fb71fd7d3d8e7cdbfaf748a4f16.tar.bz2 )
+"
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
@@ -47,6 +48,7 @@ src_unpack() {
src_prepare() {
local postfix="gentoo-${SLOT}"
sed -i -e "s/CFG_FILENAME_EXTRA=.*/CFG_FILENAME_EXTRA=${postfix}/" mk/main.mk || die
+ epatch "${FILESDIR}/${P}-install.patch"
}
src_configure() {
@@ -54,7 +56,7 @@ src_configure() {
"${ECONF_SOURCE:-.}"/configure \
--prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/lib/${P}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)/${P}" \
--mandir="${EPREFIX}/usr/share/${P}/man" \
--release-channel=${SLOT} \
--disable-manage-submodules \
@@ -86,18 +88,12 @@ src_install() {
dodoc COPYRIGHT LICENSE-APACHE LICENSE-MIT
- # le kludge that fixes https://github.com/Heather/gentoo-rust/issues/41
- mv "${D}/usr/lib/rust-${PV}/rust-${PV}/rustlib"/* "${D}/usr/lib/rust-${PV}/rustlib/" || die
- rmdir "${D}/usr/lib/rust-${PV}/rust-${PV}/rustlib" || die
- mv "${D}/usr/lib/rust-${PV}/rust-${PV}/"/* "${D}/usr/lib/rust-${PV}/" || die
- rmdir "${D}/usr/lib/rust-${PV}/rust-${PV}/" || die
-
dodir "/usr/share/doc/rust-${PV}/"
mv "${D}/usr/share/doc/rust"/* "${D}/usr/share/doc/rust-${PV}/" || die
rmdir "${D}/usr/share/doc/rust/" || die
cat <<-EOF > "${T}"/50${P}
- LDPATH="/usr/lib/${P}"
+ LDPATH="/usr/$(get_libdir)/${P}"
MANPATH="/usr/share/${P}/man"
EOF
doenvd "${T}"/50${P}