summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:02:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-07 08:02:28 +0000
commit3435e980e7ae5bd83bb3dc8b5603581cba899e15 (patch)
treedd23e949b1c041b49c917226749e6342fd09b262 /dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
parentadding sed-4 dep (diff)
downloadgentoo-2-3435e980e7ae5bd83bb3dc8b5603581cba899e15.tar.gz
gentoo-2-3435e980e7ae5bd83bb3dc8b5603581cba899e15.tar.bz2
gentoo-2-3435e980e7ae5bd83bb3dc8b5603581cba899e15.zip
major fixups
Diffstat (limited to 'dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild')
-rw-r--r--dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild b/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
index 8f0f75933f13..f8a48afedff6 100644
--- a/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
+++ b/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild
@@ -1,23 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild,v 1.2 2003/02/13 10:29:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smalltalkx/smalltalkx-4.1.4.ebuild,v 1.3 2003/06/07 08:02:25 seemant Exp $
+IUSE=""
+
+MY_PV=${PV//./}
+S=${WORKDIR}/stx
DESCRIPTION="The non-commercial version of a complete implementation of the Smalltalk programming language and development environment"
HOMEPAGE="http://www.exept.de/exept_99/english/welcomeFrame_smalltalk.html"
-SRC_URI="mirror://gentoo/smalltalkx-common-414.tar.gz
- mirror://gentoo/smalltalkx-linux-414.tar.gz"
-DEPEND="virtual/glibc virtual/x11"
-LICENSE="as-is"
+SRC_URI="mirror://gentoo/${PN}-common-${MY_PV}.tar.gz
+ mirror://gentoo/${PN}-linux-${MY_PV}.tar.gz"
+
SLOT="0"
+LICENSE="as-is"
KEYWORDS="~x86"
-S=${WORKDIR}/stx
-IUSE=""
+
+DEPEND="virtual/glibc virtual/x11"
src_install () {
dodir /opt
./INSTALL.sh -q -top ${D}/opt
- dosed ${D}/opt/smalltalk/${PV}/bin/smalltalk
+ dosed /opt/smalltalk/${PV}/bin/smalltalk
cd ${D}/opt/smalltalk/${PV}/
for i in `find . -type l` ; do
@@ -28,4 +32,10 @@ src_install () {
dodir /usr/bin
dosym /opt/smalltalk/${PV}/bin/smalltalk /usr/bin/smalltalk
+
+ # create a path entry in /etc/env.d
+ echo "PATH=/opt/smalltalk/${PV}/bin" >> ${WORKDIR}/50smalltalkx
+ insinto /etc/env.d
+ doins ${WORKDIR}/50smalltalkx
+
}