summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-10-14 19:42:30 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-10-14 19:42:30 +0000
commit9c3be43909f0d770b5c9b2f1496e3abeaf693c40 (patch)
tree4cd1917108e98a083a274e727be12cef3abd2ad4 /dev-lang/tcc/tcc-0.9.20.ebuild
parentupdate to fix linking issues (diff)
downloadgentoo-2-9c3be43909f0d770b5c9b2f1496e3abeaf693c40.tar.gz
gentoo-2-9c3be43909f0d770b5c9b2f1496e3abeaf693c40.tar.bz2
gentoo-2-9c3be43909f0d770b5c9b2f1496e3abeaf693c40.zip
update to fix linking issues
Diffstat (limited to 'dev-lang/tcc/tcc-0.9.20.ebuild')
-rw-r--r--dev-lang/tcc/tcc-0.9.20.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-lang/tcc/tcc-0.9.20.ebuild b/dev-lang/tcc/tcc-0.9.20.ebuild
new file mode 100644
index 000000000000..b3976bc2fabd
--- /dev/null
+++ b/dev-lang/tcc/tcc-0.9.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcc/tcc-0.9.20.ebuild,v 1.1 2003/10/14 19:42:23 spider Exp $
+
+IUSE=""
+
+DESCRIPTION="A very small C compiler for ix86"
+HOMEPAGE="http://www.tinycc.org/"
+SRC_URI="http://fabrice.bellard.free.fr/tcc/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die
+
+ # Fix examples
+ for example in ex*.c; do
+ tail -n +2 $example >$example.temp
+ echo '#! /usr/bin/env tcc' >$example
+ cat $example.temp >>$example
+ chmod 755 $example
+ done
+}
+
+src_install() {
+ #autoconf for the package does not create dirs if they are missing for some reason
+ dodir /usr/bin
+ dodir /usr/lib/tcc
+ dodir /usr/share/man/man1
+ dodir /usr/include
+ make prefix=${D}/usr \
+ bindir=${D}/usr/bin/ \
+ libdir=${D}/usr/lib/ \
+ includedir=${D}/usr/include/ \
+ mandir=${D}/usr/share/man/ install || die
+ dodoc Changelog README TODO VERSION COPYING
+ dohtml tcc-doc.html
+ mkdir ${D}/usr/share/doc/${PF}/examples
+ cp ex*.c ${D}/usr/share/doc/${PF}/examples/
+}