summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-09-21 15:24:07 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-09-21 15:24:07 +0000
commit78f6ce442104680e52a4e32af22973c90184fe60 (patch)
tree799e31f03984f29c87258582e999fd86eed90def /dev-lang/tcl
parentAdded ~sparc (Manifest recommit) (diff)
downloadgentoo-2-78f6ce442104680e52a4e32af22973c90184fe60.tar.gz
gentoo-2-78f6ce442104680e52a4e32af22973c90184fe60.tar.bz2
gentoo-2-78f6ce442104680e52a4e32af22973c90184fe60.zip
fixed tclConfig.sh when using custom $PORTAGE_TMPDIR... also fixed potential cross compiling issues
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog8
-rw-r--r--dev-lang/tcl/Manifest8
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.6-r11
-rw-r--r--dev-lang/tcl/tcl-8.4.6-r1.ebuild99
4 files changed, 112 insertions, 4 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index a88bebe1b746..1731216a7fc0 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.40 2004/09/14 20:33:33 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.41 2004/09/21 15:24:07 cardoe Exp $
+
+*tcl-8.4.6-r1 (21 Sep 2004)
+
+ 21 Sep 2004; Doug Goldstein <cardoe@gentoo.org> +tcl-8.4.6-r1.ebuild:
+ fixed tclConfig.sh when using custom $PORTAGE_TMPDIR... also fixed potential
+ cross compiling issues
14 Sep 2004; Guy Martin <gmsoft@gentoo.org> tcl-8.4.6.ebuild:
Stable on hppa.
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 18fd2dd5385e..fbcee7871fe8 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,6 +1,8 @@
-MD5 fed6b2292383fa8476389b56c8904be6 ChangeLog 5309
-MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 2cfd331c4234b3d109bf51d1697bd461 tcl-8.3.4.ebuild 2538
+MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
+MD5 586b9c93d32bee2724a48f7e4d04aad6 tcl-8.4.6-r1.ebuild 2961
+MD5 fed6b2292383fa8476389b56c8904be6 ChangeLog 5309
MD5 d2bf35d1b9d4e346394bc2a823fcdf02 tcl-8.4.6.ebuild 2921
-MD5 d8691f60be4023222834ccdf6ee6d498 files/digest-tcl-8.3.4 61
+MD5 cb07b4bc1984a971b376e1da5e478fdc files/digest-tcl-8.4.6-r1 65
MD5 cb07b4bc1984a971b376e1da5e478fdc files/digest-tcl-8.4.6 65
+MD5 d8691f60be4023222834ccdf6ee6d498 files/digest-tcl-8.3.4 61
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.6-r1 b/dev-lang/tcl/files/digest-tcl-8.4.6-r1
new file mode 100644
index 000000000000..61274224905f
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.6-r1
@@ -0,0 +1 @@
+MD5 9009a92dc648775fb8a9b0789b995756 tcl8.4.6-src.tar.gz 3448711
diff --git a/dev-lang/tcl/tcl-8.4.6-r1.ebuild b/dev-lang/tcl/tcl-8.4.6-r1.ebuild
new file mode 100644
index 000000000000..318845744bad
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.6-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.6-r1.ebuild,v 1.1 2004/09/21 15:24:07 cardoe Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool Command Language"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="threads"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if use threads
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_compile() {
+ local local_config_use=""
+
+ if use threads
+ then
+ local_config_use="--enable-threads"
+ fi
+
+ cd ${S}/unix
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ ${local_config_use} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}/usr/lib," \
+ -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${ROOT}/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${ROOT}/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${ROOT}/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild"
+ ewarn "in package app-portage/gentoolkit."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+ ewarn ${S}
+}