summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-10 14:43:02 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-10 14:43:02 +0000
commit0ae84867caaf65d26c55db0c7eb3e517e3f45824 (patch)
treeff8214981064ff15a95da95a06c00a439bbca595 /dev-lang
parentKeyworded ~x86-fbsd (diff)
downloadgentoo-2-0ae84867caaf65d26c55db0c7eb3e517e3f45824.tar.gz
gentoo-2-0ae84867caaf65d26c55db0c7eb3e517e3f45824.tar.bz2
gentoo-2-0ae84867caaf65d26c55db0c7eb3e517e3f45824.zip
stop using $IMAGE
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/fpc/fpc-2.0.0-r1.ebuild6
-rw-r--r--dev-lang/fpc/fpc-2.0.2.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/fpc/fpc-2.0.0-r1.ebuild b/dev-lang/fpc/fpc-2.0.0-r1.ebuild
index 4f7f76dba3ff..257c4b96d996 100644
--- a/dev-lang/fpc/fpc-2.0.0-r1.ebuild
+++ b/dev-lang/fpc/fpc-2.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-2.0.0-r1.ebuild,v 1.6 2007/01/31 14:31:05 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-2.0.0-r1.ebuild,v 1.7 2007/03/10 14:43:02 vapier Exp $
inherit eutils
@@ -115,7 +115,7 @@ src_install() {
}
pkg_preinst() {
- ${IMAGE}/usr/lib/fpc/${MY_PV}/samplecfg /usr/lib/fpc/${MY_PV} ${IMAGE}/etc
+ ${D}/usr/lib/fpc/${MY_PV}/samplecfg /usr/lib/fpc/${MY_PV} ${IMAGE}/etc
case ${ARCH} in
x86)
FPCARCH=386
@@ -130,7 +130,7 @@ pkg_preinst() {
FPCARCH=x64
;;
esac
- ln -s ../lib/fpc/${MY_PV}/ppc${FPCARCH} ${IMAGE}/usr/bin/
+ ln -s ../lib/fpc/${MY_PV}/ppc${FPCARCH} ${D}/usr/bin/
}
pkg_postinst() {
diff --git a/dev-lang/fpc/fpc-2.0.2.ebuild b/dev-lang/fpc/fpc-2.0.2.ebuild
index de85d507b130..528e05ecde88 100644
--- a/dev-lang/fpc/fpc-2.0.2.ebuild
+++ b/dev-lang/fpc/fpc-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-2.0.2.ebuild,v 1.4 2007/01/31 14:31:05 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-2.0.2.ebuild,v 1.5 2007/03/10 14:43:02 vapier Exp $
inherit eutils
@@ -130,7 +130,7 @@ src_install() {
}
pkg_preinst() {
- ${IMAGE}/usr/lib/fpc/${PV}/samplecfg /usr/lib/fpc/${PV} ${IMAGE}/etc
+ ${D}/usr/lib/fpc/${PV}/samplecfg /usr/lib/fpc/${PV} ${IMAGE}/etc
case ${ARCH} in
x86) FPC_ARCH="386" ;;
ppc) FPC_ARCH="ppc" ;;
@@ -138,7 +138,7 @@ pkg_preinst() {
sparc) FPC_ARCH="sparc" ;;
*) die "This ebuild doesn't support ${ARCH}." ;;
esac
- ln -s ../lib/fpc/${PV}/ppc${FPC_ARCH} ${IMAGE}/usr/bin/
+ ln -s ../lib/fpc/${PV}/ppc${FPC_ARCH} ${D}/usr/bin/
}
pkg_postinst() {