summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-01-03 16:37:29 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-01-03 16:37:29 +0000
commit3f114ce66d432bb7481838f9e818bc4b8df301ca (patch)
treeafe979fd0b5d8ba4ba7522fb1751d30a9cc1d8f2 /dev-lang
parentNew version of less (diff)
downloadgentoo-2-3f114ce66d432bb7481838f9e818bc4b8df301ca.tar.gz
gentoo-2-3f114ce66d432bb7481838f9e818bc4b8df301ca.tar.bz2
gentoo-2-3f114ce66d432bb7481838f9e818bc4b8df301ca.zip
Updated ebuild to copy files/python-config-2.2 to /usr/bin/python-config.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/python-config-2.23
-rw-r--r--dev-lang/python/python-2.2.ebuild5
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/python/files/python-config-2.2 b/dev-lang/python/files/python-config-2.2
new file mode 100644
index 000000000000..253285032259
--- /dev/null
+++ b/dev-lang/python/files/python-config-2.2
@@ -0,0 +1,3 @@
+#!/usr/bin/python
+import distutils.sysconfig, string
+print "-lpython2.2",string.join(string.split(distutils.sysconfig.get_config_var("MODLIBS")))
diff --git a/dev-lang/python/python-2.2.ebuild b/dev-lang/python/python-2.2.ebuild
index 09ec4d4fd2bd..836e04c15248 100644
--- a/dev-lang/python/python-2.2.ebuild
+++ b/dev-lang/python/python-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.ebuild,v 1.1 2002/01/02 16:55:21 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.ebuild,v 1.2 2002/01/03 16:37:29 g2boojum Exp $
S=${WORKDIR}/Python-${PV}
FCHKSUM="python-fchksum-1.6"
@@ -119,7 +119,7 @@ src_install() {
# install our own custom python-config
exeinto /usr/bin
- doexe ${FILESDIR}/python-config
+ newexe ${FILESDIR}/python-config-2.2 python-config
# If USE tcltk lets install idle
# Need to script the python version in the path
@@ -127,5 +127,6 @@ src_install() {
mkdir "${D}/usr/lib/python2.2/tools"
mv "${S}/Tools/idle" "${D}/usr/lib/python2.2/tools/"
dosym /usr/lib/python2.2/tools/idle/idle.py /usr/bin/idle.py
+ dosym /usr/bin/idle.py /usr/bin/idle
fi
}