summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-07-04 12:24:16 +0000
committerMatti Bickel <mabi@gentoo.org>2010-07-04 12:24:16 +0000
commit4e80b20f556fc6d81c48a55225e7a400bc5bd94e (patch)
tree2ad2d9c8f29272c7b86bf64226dc03653273778a /dev-lang
parentppc64 stable wrt #322861 (diff)
downloadgentoo-2-4e80b20f556fc6d81c48a55225e7a400bc5bd94e.tar.gz
gentoo-2-4e80b20f556fc6d81c48a55225e7a400bc5bd94e.tar.bz2
gentoo-2-4e80b20f556fc6d81c48a55225e7a400bc5bd94e.zip
fix bug #281316, #322303
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-5.3.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/php/php-5.3.2.ebuild b/dev-lang/php/php-5.3.2.ebuild
index 8c9fa0122deb..cb0d76294a47 100644
--- a/dev-lang/php/php-5.3.2.ebuild
+++ b/dev-lang/php/php-5.3.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.2.ebuild,v 1.8 2010/06/14 17:03:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.2.ebuild,v 1.9 2010/07/04 12:24:16 mabi Exp $
EAPI=2
-PHPCONFUTILS_MISSING_DEPS="adabas birdstep db2 dbmaker empress empress-bcs esoob interbase oci8 sapdb solid sybase-ct"
+PHPCONFUTILS_MISSING_DEPS="adabas birdstep db2 dbmaker empress empress-bcs esoob interbase oci8 sapdb solid"
inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use phpconfutils php-common-r1 libtool
@@ -74,7 +74,7 @@ SAPIS="cli cgi embed apache2"
# Gentoo-specific, common features
IUSE="kolab"
-# SAPIs and SAPI-specific USE flags:
+# SAPIs and SAPI-specific USE flags (cli SAPI is default on):
IUSE="${IUSE}
+${SAPIS}
concurrentmodphp threads"
@@ -134,7 +134,7 @@ DEPEND="app-admin/php-toolkit
ldap? ( !oci8? ( >=net-nds/openldap-1.2.11 ) )
ldap-sasl? ( !oci8? ( dev-libs/cyrus-sasl >=net-nds/openldap-1.2.11 ) )
libedit? ( || ( sys-freebsd/freebsd-lib dev-libs/libedit ) )
- mssql? ( dev-db/freetds )
+ mssql? ( dev-db/freetds[mssql] )
!mysqlnd? (
mysql? ( virtual/mysql )
mysqli? ( >=virtual/mysql-4.1 )
@@ -166,6 +166,7 @@ DEPEND="app-admin/php-toolkit
sqlite? ( =dev-db/sqlite-2* pdo? ( =dev-db/sqlite-3* ) )
sqlite3? ( =dev-db/sqlite-3* )
ssl? ( >=dev-libs/openssl-0.9.7 )
+ sybase-ct? ( dev-db/freetds )
tidy? ( app-text/htmltidy )
truetype? (
=media-libs/freetype-2*
@@ -214,7 +215,6 @@ RDEPEND="${DEPEND}
empress? ( $php[odbc] )
esoob? ( $php[odbc] )
db2? ( $php[odbc] )
- iodbc? ( $php[iodbc] )
sapdb? ( $php[odbc] )
solid? ( $php[odbc] )
kolab? ( $php[imap] )