summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-03-28 17:25:20 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-03-28 17:25:20 +0000
commit5e3b553306c77e20c32ebe25f2003d67e05de686 (patch)
treeadfd60c2df1bfb3c10cefef351c82b93e000a844 /dev-lang
parentversion bump (diff)
downloadgentoo-2-5e3b553306c77e20c32ebe25f2003d67e05de686.tar.gz
gentoo-2-5e3b553306c77e20c32ebe25f2003d67e05de686.tar.bz2
gentoo-2-5e3b553306c77e20c32ebe25f2003d67e05de686.zip
Change the use of CFLAGS again. Filter out -O2 on arches where it breaks.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-6.4.1-r3.ebuild21
2 files changed, 18 insertions, 8 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 7c599c69198a..519ba1326c93 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.91 2006/03/27 12:38:49 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.92 2006/03/28 17:25:20 dcoutts Exp $
+
+ 28 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild:
+ Change the use of CFLAGS again. Filter out -O2 on arches where it breaks.
27 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> -ghc-6.4.ebuild:
Remove 6.4 since 6.4.1 is stable and 6.4 was rather buggy anyway.
diff --git a/dev-lang/ghc/ghc-6.4.1-r3.ebuild b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
index 5026b381b0e8..2ac489525a20 100644
--- a/dev-lang/ghc/ghc-6.4.1-r3.ebuild
+++ b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.1 2006/03/26 23:03:00 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.2 2006/03/28 17:25:20 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -97,17 +97,24 @@ ghc_setup_cflags() {
strip-unsupported-flags
filter-flags -fPIC
- # On ia64 ghc doesn't cope well with the assembler output of gcc if we use
- # too high a level of optimisation. -O2 is too much while -O is ok.
- use ia64 && replace-flags -O? -O
-
GHC_CFLAGS=""
for flag in ${CFLAGS}; do
case ${flag} in
- -O*) append-ghc-cflags compile ${flag};;
+
+ # These would just dup what ghc does anyway
+ -O|-O1) ;;
+
+ # We have to be really careful with more agressive -O flags
+ # as they do break ghc on some arches.
+ -O2|-O3|-Os) use ia64 || use sparc || append-ghc-cflags compile ${flag};;
+
+ # Arch and ABI flags are probably ok
-m*) append-ghc-cflags compile assemble ${flag};;
+
+ # Debugging flags are also probably ok
-g*) append-ghc-cflags compile assemble ${flag};;
- # ignore all other flags, including all -f* flags
+
+ # Ignore all other flags, including all -f* flags
esac
done