summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2006-06-03 18:08:15 +0000
committerGuy Martin <gmsoft@gentoo.org>2006-06-03 18:08:15 +0000
commit7a8915a0dc4fa377ce21c449354cab4b6afe44c5 (patch)
treeab7aaec6ee41cad614e79e0e6670772919c688f4 /dev-lang
parentFixed wrong comparision for PYTHON_SLOT_VERSION and added support for 2.3 (diff)
downloadgentoo-2-7a8915a0dc4fa377ce21c449354cab4b6afe44c5.tar.gz
gentoo-2-7a8915a0dc4fa377ce21c449354cab4b6afe44c5.tar.bz2
gentoo-2-7a8915a0dc4fa377ce21c449354cab4b6afe44c5.zip
On PA7200, uname -a contains a single quote and we need to filter it otherwise configure fails. See #125535.
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/files/perl-hppa-pa7200-configure.patch11
-rw-r--r--dev-lang/perl/perl-5.8.8-r2.ebuild7
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index a5fbae00ac3a..5a27b6b2ae2b 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.216 2006/05/30 11:39:43 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.217 2006/06/03 18:08:15 gmsoft Exp $
+
+ 03 Jun 2006; Guy Martin <gmsoft@gentoo.org>
+ +files/perl-hppa-pa7200-configure.patch, perl-5.8.8-r2.ebuild:
+ On PA7200, uname -a contains a single quote and we need to filter it
+ otherwise configure fails. See #125535.
30 May 2006; <mcummings@gentoo.org> perl-5.8.8-r2.ebuild:
Bug 134859, fixed USE=build removals on lib64
diff --git a/dev-lang/perl/files/perl-hppa-pa7200-configure.patch b/dev-lang/perl/files/perl-hppa-pa7200-configure.patch
new file mode 100644
index 000000000000..396209af112b
--- /dev/null
+++ b/dev-lang/perl/files/perl-hppa-pa7200-configure.patch
@@ -0,0 +1,11 @@
+--- Configure.orig 2006-06-02 13:14:22.000000000 -0500
++++ Configure 2006-06-02 13:07:03.000000000 -0500
+@@ -2967,7 +2967,7 @@
+ : Try to determine whether config.sh was made on this system
+ case "$config_sh" in
+ '')
+-myuname=`$uname -a 2>/dev/null`
++myuname=`$uname -a | $sed -e "s/'//" 2>/dev/null`
+ $test -z "$myuname" && myuname=`hostname 2>/dev/null`
+ # tr '[A-Z]' '[a-z]' would not work in EBCDIC
+ # because the A-Z/a-z are not consecutive.
diff --git a/dev-lang/perl/perl-5.8.8-r2.ebuild b/dev-lang/perl/perl-5.8.8-r2.ebuild
index 4c135ddd683d..a0ec4f3117ca 100644
--- a/dev-lang/perl/perl-5.8.8-r2.ebuild
+++ b/dev-lang/perl/perl-5.8.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.10 2006/05/30 11:39:43 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.11 2006/06/03 18:08:15 gmsoft Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -109,6 +109,11 @@ src_unpack() {
[[ -n $(test-flags -fno-stack-protector) ]] && \
epatch ${FILESDIR}/${PN}-regexp-nossp.patch
+
+ # On PA7200, uname -a contains a single quote and we need to
+ # filter it otherwise configure fails. See #125535.
+ epatch ${FILESDIR}/perl-hppa-pa7200-configure.patch
+
use amd64 && cd ${S} && epatch ${FILESDIR}/${P}-lib64.patch
[[ ${CHOST} == *-dragonfly* ]] && cd ${S} && epatch ${FILESDIR}/${P}-dragonfly-clean.patch