summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2010-08-03 01:41:47 +0000
committerBrian Harring <ferringb@gentoo.org>2010-08-03 01:41:47 +0000
commit7b92ba14c1a0dff2f277c318d75a9c26fe245d55 (patch)
tree1bea773b94b85f305f051c61e50056bae7235fd7 /dev-lang
parentVersion bump to be in sync with the rest; no code changes (diff)
downloadgentoo-2-7b92ba14c1a0dff2f277c318d75a9c26fe245d55.tar.gz
gentoo-2-7b92ba14c1a0dff2f277c318d75a9c26fe245d55.tar.bz2
gentoo-2-7b92ba14c1a0dff2f277c318d75a9c26fe245d55.zip
remove the backported versions; they're autogenerated, obviously not tested for 2.6 (bug 330937, breaking portage for anyone runing unstable python at time of commit), and have been the source of a shitload of other rather odd bugs till identification of what was occuring (bug 330667). ignoring a PDEPEND.bad for 3.1.2-r3 for >=app-admin/python-updater-0.8 also to get these removed
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.6.5_p20100801.ebuild302
-rw-r--r--dev-lang/python/python-2.7_p20100801.ebuild316
-rw-r--r--dev-lang/python/python-3.1.2_p20100801.ebuild309
4 files changed, 7 insertions, 928 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index efddf8c54162..141ce09741ea 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.486 2010/08/02 19:24:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.487 2010/08/03 01:41:47 ferringb Exp $
*python-3.1.2_p20100801 (02 Aug 2010)
*python-2.7_p20100801 (02 Aug 2010)
*python-2.6.5_p20100801 (02 Aug 2010)
+ 02 Aug 2010; Brian Harring <ferringb@gentoo.org>
+ -python-2.6.5_p20100801.ebuild, -python-2.7_p20100801.ebuild,
+ -python-3.1.2_p20100801.ebuild:
+ Remove untested versions, one of which flat out breaks emerge (bug 330937).
+ These should not be re-added without going through devrel/qa.
+
02 Aug 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+python-2.6.5_p20100801.ebuild, +python-2.7_p20100801.ebuild,
+python-3.1.2_p20100801.ebuild:
diff --git a/dev-lang/python/python-2.6.5_p20100801.ebuild b/dev-lang/python/python-2.6.5_p20100801.ebuild
deleted file mode 100644
index 882809909887..000000000000
--- a/dev-lang/python/python-2.6.5_p20100801.ebuild
+++ /dev/null
@@ -1,302 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5_p20100801.ebuild,v 1.1 2010/08/02 19:24:35 arfrever Exp $
-
-EAPI="2"
-
-inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
-
-MY_PV="${PV%_p*}"
-MY_P="Python-${MY_PV}"
-
-PATCHSET_REVISION="6"
-
-DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
-HOMEPAGE="http://www.python.org/"
-SRC_URI="http://www.python.org/ftp/python/${MY_PV}/${MY_P}.tar.bz2
- mirror://gentoo/python-gentoo-patches-${MY_PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
-
-LICENSE="PSF-2.2"
-SLOT="2.6"
-PYTHON_ABI="${SLOT}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
-
-RDEPEND=">=app-admin/eselect-python-20091230
- >=sys-libs/zlib-1.1.3
- virtual/libffi
- virtual/libintl
- !build? (
- berkdb? ( || (
- sys-libs/db:4.7
- sys-libs/db:4.6
- sys-libs/db:4.5
- sys-libs/db:4.4
- sys-libs/db:4.3
- sys-libs/db:4.2
- ) )
- gdbm? ( sys-libs/gdbm )
- ncurses? (
- >=sys-libs/ncurses-5.2
- readline? ( >=sys-libs/readline-4.1 )
- )
- sqlite? ( >=dev-db/sqlite-3 )
- ssl? ( dev-libs/openssl )
- tk? ( >=dev-lang/tk-8.0 )
- xml? ( >=dev-libs/expat-2 )
- )
- doc? ( dev-python/python-docs:${SLOT} )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- !sys-devel/gcc[libffi]"
-RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND="app-admin/python-updater"
-
-PROVIDE="virtual/python"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_pkg_setup
-
- if use berkdb; then
- ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
- ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
- ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
- fi
-}
-
-src_prepare() {
- # Ensure that internal copies of expat, libffi and zlib are not used.
- rm -fr Modules/expat
- rm -fr Modules/_ctypes/libffi*
- rm -fr Modules/zlib
-
- if ! tc-is-cross-compiler; then
- rm "${WORKDIR}/${MY_PV}"/*_all_crosscompile.patch
- fi
-
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${MY_PV}"
-
- # Avoid regeneration, which would not change contents of files.
- touch Include/Python-ast.h Python/Python-ast.c
-
- sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
- Lib/distutils/command/install.py \
- Lib/distutils/sysconfig.py \
- Lib/site.py \
- Makefile.pre.in \
- Modules/Setup.dist \
- Modules/getpath.c \
- setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
-
- if ! use wininst; then
- # Remove Microsoft Windows executables.
- rm Lib/distutils/command/wininst-*.exe
- fi
-
- # Fix OtherFileTests.testStdin() not to assume
- # that stdin is a tty for bug #248081.
- sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- # Disable extraneous modules with extra dependencies.
- if use build; then
- export PYTHON_DISABLE_MODULES="dbm _bsddb gdbm _curses _curses_panel readline _sqlite3 _tkinter _elementtree pyexpat"
- export PYTHON_DISABLE_SSL="1"
- else
- # dbm module can be linked against berkdb or gdbm.
- # Defaults to gdbm when both are enabled, #204343.
- local disable
- use berkdb || use gdbm || disable+=" dbm"
- use berkdb || disable+=" _bsddb"
- use gdbm || disable+=" gdbm"
- use ncurses || disable+=" _curses _curses_panel"
- use readline || disable+=" readline"
- use sqlite || disable+=" _sqlite3"
- use ssl || export PYTHON_DISABLE_SSL="1"
- use tk || disable+=" _tkinter"
- use xml || disable+=" _elementtree pyexpat" # _elementtree uses pyexpat.
- export PYTHON_DISABLE_MODULES="${disable}"
-
- if ! use xml; then
- ewarn "You have configured Python without XML support."
- ewarn "This is NOT a recommended configuration as you"
- ewarn "may face problems parsing any XML documents."
- fi
- fi
-
- if [[ -n "${PYTHON_DISABLE_MODULES}" ]]; then
- einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
- fi
-
- if [[ "$(gcc-major-version)" -ge 4 ]]; then
- append-flags -fwrapv
- fi
-
- filter-flags -malign-double
-
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
- if tc-is-cross-compiler; then
- OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
- ./configure --{build,host}=${CBUILD} || die "cross-configure failed"
- emake python Parser/pgen || die "cross-make failed"
- mv python hostpython
- mv Parser/pgen Parser/hostpgen
- make distclean
- sed -i \
- -e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
- -e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
- Makefile.pre.in || die "sed failed"
- fi
-
- # Export CXX so it ends up in /usr/lib/python2.X/config/Makefile.
- tc-export CXX
-
- # Set LDFLAGS so we link modules with -lpython2.6 correctly.
- # Needed on FreeBSD unless Python 2.6 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
- OPT="" econf \
- --with-fpectl \
- --enable-shared \
- $(use_enable ipv6) \
- $(use_with threads) \
- $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
- --infodir='${prefix}/share/info' \
- --mandir='${prefix}/share/man' \
- --with-libc="" \
- --with-system-ffi
-}
-
-src_test() {
- # Tests will not work when cross compiling.
- if tc-is-cross-compiler; then
- elog "Disabling tests due to crosscompiling."
- return
- fi
-
- # Byte compiling should be enabled here.
- # Otherwise test_import fails.
- python_enable_pyc
-
- # Skip failing tests.
- local skip_tests="distutils httpservers minidom pyexpat sax tcl"
-
- # test_ctypes fails with PAX kernel (bug #234498).
- host-is-pax && skip_tests+=" ctypes"
-
- for test in ${skip_tests}; do
- mv "${S}/Lib/test/test_${test}.py" "${T}"
- done
-
- # Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" emake test
- local result="$?"
-
- for test in ${skip_tests}; do
- mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
- done
-
- elog "The following tests have been skipped:"
- for test in ${skip_tests}; do
- elog "test_${test}.py"
- done
-
- elog "If you would like to run them, you may:"
- elog "cd '${EPREFIX}$(python_get_libdir)/test'"
- elog "and run the tests separately."
-
- python_disable_pyc
-
- if [[ "${result}" -ne 0 ]]; then
- die "emake test failed"
- fi
-}
-
-src_install() {
- [[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
-
- emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
- python_clean_installation_image -q
-
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
-
- # Fix collisions between different slots of Python.
- mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
- mv "${ED}usr/bin/pydoc" "${ED}usr/bin/pydoc${SLOT}"
- mv "${ED}usr/bin/idle" "${ED}usr/bin/idle${SLOT}"
- mv "${ED}usr/share/man/man1/python.1" "${ED}usr/share/man/man1/python${SLOT}.1"
- rm -f "${ED}usr/bin/smtpd.py"
-
- if use build; then
- rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{bsddb,idlelib,lib-tk,sqlite3,test}
- else
- use elibc_uclibc && rm -fr "${ED}$(python_get_libdir)/"{bsddb/test,test}
- use berkdb || rm -fr "${ED}$(python_get_libdir)/"{bsddb,test/test_bsddb*}
- use sqlite || rm -fr "${ED}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{idlelib,lib-tk}
- fi
-
- use threads || rm -fr "${ED}$(python_get_libdir)/multiprocessing"
-
- prep_ml_includes $(python_get_includedir)
-
- dodoc Misc/{ACKS,HISTORY,NEWS} || die "dodoc failed"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S}/Tools" || die "doins failed"
- fi
-
- newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
-
- # Do not install empty directory.
- rmdir "${ED}$(python_get_libdir)/lib-old"
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.6" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
-eselect_python_update() {
- eselect python update --python2 || eselect python update
-}
-
-pkg_postinst() {
- eselect_python_update
-
- python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should run 'python-updater \${options}' to rebuild Python modules."
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
- ebeep 12
- fi
-}
-
-pkg_postrm() {
- eselect_python_update
-
- python_mod_cleanup $(python_get_libdir)
-}
diff --git a/dev-lang/python/python-2.7_p20100801.ebuild b/dev-lang/python/python-2.7_p20100801.ebuild
deleted file mode 100644
index 3c7323ebeed9..000000000000
--- a/dev-lang/python/python-2.7_p20100801.ebuild
+++ /dev/null
@@ -1,316 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7_p20100801.ebuild,v 1.1 2010/08/02 19:24:35 arfrever Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib pax-utils python toolchain-funcs
-
-MY_PV="${PV%_p*}"
-MY_P="Python-${MY_PV}"
-
-PATCHSET_REVISION="1"
-
-DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
-HOMEPAGE="http://www.python.org/"
-SRC_URI="http://www.python.org/ftp/python/${MY_PV}/${MY_P}.tar.bz2
- mirror://gentoo/python-gentoo-patches-${MY_PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
-
-LICENSE="PSF-2.2"
-SLOT="2.7"
-PYTHON_ABI="${SLOT}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
-
-# NOTE: dev-python/{elementtree,celementtree,pysqlite}
-# do not conflict with the ones in python proper. - liquidx
-
-RDEPEND=">=app-admin/eselect-python-20091230
- >=sys-libs/zlib-1.1.3
- virtual/libffi
- virtual/libintl
- !build? (
- berkdb? ( || (
- sys-libs/db:4.8
- sys-libs/db:4.7
- sys-libs/db:4.6
- sys-libs/db:4.5
- sys-libs/db:4.4
- sys-libs/db:4.3
- sys-libs/db:4.2
- ) )
- gdbm? ( sys-libs/gdbm )
- ncurses? (
- >=sys-libs/ncurses-5.2
- readline? ( >=sys-libs/readline-4.1 )
- )
- sqlite? ( >=dev-db/sqlite-3 )
- ssl? ( dev-libs/openssl )
- tk? ( >=dev-lang/tk-8.0 )
- xml? ( >=dev-libs/expat-2 )
- )
- doc? ( dev-python/python-docs:${SLOT} )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- !sys-devel/gcc[libffi]"
-RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND="app-admin/python-updater"
-
-PROVIDE="virtual/python"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_pkg_setup
-
- if use berkdb; then
- ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
- ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
- ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
- fi
-}
-
-src_prepare() {
- # Ensure that internal copies of expat, libffi and zlib are not used.
- rm -fr Modules/expat
- rm -fr Modules/_ctypes/libffi*
- rm -fr Modules/zlib
-
- if ! tc-is-cross-compiler; then
- rm "${WORKDIR}/${MY_PV}"/*_all_crosscompile.patch
- fi
-
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${MY_PV}"
-
- sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
- Lib/distutils/command/install.py \
- Lib/distutils/sysconfig.py \
- Lib/site.py \
- Lib/sysconfig.py \
- Lib/test/test_site.py \
- Makefile.pre.in \
- Modules/Setup.dist \
- Modules/getpath.c \
- setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
-
- if ! use wininst; then
- # Remove Microsoft Windows executables.
- rm Lib/distutils/command/wininst-*.exe
- fi
-
- # Fix OtherFileTests.testStdin() not to assume
- # that stdin is a tty for bug #248081.
- sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
-
- # Support versions of Autoconf other than 2.65.
- sed -e "/version_required(2\.65)/d" -i configure.in || die "sed failed"
-}
-
-src_configure() {
- # Disable extraneous modules with extra dependencies.
- if use build; then
- export PYTHON_DISABLE_MODULES="dbm _bsddb gdbm _curses _curses_panel readline _sqlite3 _tkinter _elementtree pyexpat"
- export PYTHON_DISABLE_SSL="1"
- else
- # dbm module can be linked against berkdb or gdbm.
- # Defaults to gdbm when both are enabled, #204343.
- local disable
- use berkdb || use gdbm || disable+=" dbm"
- use berkdb || disable+=" _bsddb"
- use gdbm || disable+=" gdbm"
- use ncurses || disable+=" _curses _curses_panel"
- use readline || disable+=" readline"
- use sqlite || disable+=" _sqlite3"
- use ssl || export PYTHON_DISABLE_SSL="1"
- use tk || disable+=" _tkinter"
- use xml || disable+=" _elementtree pyexpat" # _elementtree uses pyexpat.
- export PYTHON_DISABLE_MODULES="${disable}"
-
- if ! use xml; then
- ewarn "You have configured Python without XML support."
- ewarn "This is NOT a recommended configuration as you"
- ewarn "may face problems parsing any XML documents."
- fi
- fi
-
- if [[ -n "${PYTHON_DISABLE_MODULES}" ]]; then
- einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
- fi
-
- if [[ "$(gcc-major-version)" -ge 4 ]]; then
- append-flags -fwrapv
- fi
-
- filter-flags -malign-double
-
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
- if tc-is-cross-compiler; then
- OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
- ./configure --{build,host}=${CBUILD} || die "cross-configure failed"
- emake python Parser/pgen || die "cross-make failed"
- mv python hostpython
- mv Parser/pgen Parser/hostpgen
- make distclean
- sed -i \
- -e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
- -e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
- Makefile.pre.in || die "sed failed"
- fi
-
- # Export CXX so it ends up in /usr/lib/python2.X/config/Makefile.
- tc-export CXX
-
- # Set LDFLAGS so we link modules with -lpython2.7 correctly.
- # Needed on FreeBSD unless Python 2.7 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
- local dbmliborder
- if use gdbm; then
- dbmliborder+="${dbmliborder:+:}gdbm"
- fi
- if use berkdb; then
- dbmliborder+="${dbmliborder:+:}bdb"
- fi
-
- OPT="" econf \
- --with-fpectl \
- --enable-shared \
- $(use_enable ipv6) \
- $(use_with threads) \
- $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
- --infodir='${prefix}/share/info' \
- --mandir='${prefix}/share/man' \
- --with-dbmliborder="${dbmliborder}" \
- --with-libc="" \
- --with-system-expat \
- --with-system-ffi
-}
-
-src_test() {
- # Tests will not work when cross compiling.
- if tc-is-cross-compiler; then
- elog "Disabling tests due to crosscompiling."
- return
- fi
-
- # Byte compiling should be enabled here.
- # Otherwise test_import fails.
- python_enable_pyc
-
- # Skip failing tests.
- local skip_tests="distutils gdb minidom pyexpat sax"
-
- # test_ctypes fails with PAX kernel (bug #234498).
- host-is-pax && skip_tests+=" ctypes"
-
- for test in ${skip_tests}; do
- mv "${S}/Lib/test/test_${test}.py" "${T}"
- done
-
- # Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" emake test
- local result="$?"
-
- for test in ${skip_tests}; do
- mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
- done
-
- elog "The following tests have been skipped:"
- for test in ${skip_tests}; do
- elog "test_${test}.py"
- done
-
- elog "If you would like to run them, you may:"
- elog "cd '${EPREFIX}$(python_get_libdir)/test'"
- elog "and run the tests separately."
-
- python_disable_pyc
-
- if [[ "${result}" -ne 0 ]]; then
- die "emake test failed"
- fi
-}
-
-src_install() {
- [[ -z "${ED}" ]] && ED="${D%/}${EPREFIX}/"
-
- emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
- python_clean_installation_image -q
-
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
-
- # Fix collisions between different slots of Python.
- mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
- mv "${ED}usr/bin/pydoc" "${ED}usr/bin/pydoc${SLOT}"
- mv "${ED}usr/bin/idle" "${ED}usr/bin/idle${SLOT}"
- rm -f "${ED}usr/bin/smtpd.py"
-
- if use build; then
- rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{bsddb,idlelib,lib-tk,sqlite3,test}
- else
- use elibc_uclibc && rm -fr "${ED}$(python_get_libdir)/"{bsddb/test,test}
- use berkdb || rm -fr "${ED}$(python_get_libdir)/"{bsddb,test/test_bsddb*}
- use sqlite || rm -fr "${ED}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{idlelib,lib-tk}
- fi
-
- use threads || rm -fr "${ED}$(python_get_libdir)/multiprocessing"
-
- prep_ml_includes $(python_get_includedir)
-
- dodoc Misc/{ACKS,HISTORY,NEWS} || die "dodoc failed"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S}/Tools" || die "doins failed"
- fi
-
- newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
-
- # Do not install empty directories.
- rmdir "${ED}$(python_get_libdir)/lib-old"
- rmdir "${ED}$(python_get_libdir)/test/data"
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
-eselect_python_update() {
- eselect python update --python2 || eselect python update
-}
-
-pkg_postinst() {
- eselect_python_update
-
- python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should run 'python-updater \${options}' to rebuild Python modules."
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
- ebeep 12
- fi
-}
-
-pkg_postrm() {
- eselect_python_update
-
- python_mod_cleanup $(python_get_libdir)
-}
diff --git a/dev-lang/python/python-3.1.2_p20100801.ebuild b/dev-lang/python/python-3.1.2_p20100801.ebuild
deleted file mode 100644
index 2600c72725f1..000000000000
--- a/dev-lang/python/python-3.1.2_p20100801.ebuild
+++ /dev/null
@@ -1,309 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2_p20100801.ebuild,v 1.1 2010/08/02 19:24:35 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
-
-MY_PV="${PV%_p*}"
-MY_P="Python-${MY_PV}"
-
-PATCHSET_REVISION="7"
-
-DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
-HOMEPAGE="http://www.python.org/"
-SRC_URI="http://www.python.org/ftp/python/${MY_PV}/${MY_P}.tar.bz2
- mirror://gentoo/python-gentoo-patches-${MY_PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
-
-LICENSE="PSF-2.2"
-SLOT="3.1"
-PYTHON_ABI="${SLOT}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
-
-RDEPEND=">=app-admin/eselect-python-20091230
- >=sys-libs/zlib-1.1.3
- virtual/libffi
- virtual/libintl
- !build? (
- gdbm? ( sys-libs/gdbm )
- ncurses? (
- >=sys-libs/ncurses-5.2
- readline? ( >=sys-libs/readline-4.1 )
- )
- sqlite? ( >=dev-db/sqlite-3 )
- ssl? ( dev-libs/openssl )
- tk? ( >=dev-lang/tk-8.0 )
- xml? ( >=dev-libs/expat-2 )
- )
- doc? ( dev-python/python-docs:${SLOT} )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- !sys-devel/gcc[libffi]"
-RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-admin/python-updater-0.8
- || (
- dev-lang/python:2.7[gdbm?,ipv6?,ncurses?,readline?,sqlite?,ssl?,threads?,tk?,xml?]
- dev-lang/python:2.6[gdbm?,ipv6?,ncurses?,readline?,sqlite?,ssl?,threads?,tk?,xml?]
- )"
-
-PROVIDE="virtual/python"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- python_pkg_setup
-}
-
-src_prepare() {
- # Ensure that internal copies of expat, libffi and zlib are not used.
- rm -fr Modules/expat
- rm -fr Modules/_ctypes/libffi*
- rm -fr Modules/zlib
-
- if ! tc-is-cross-compiler; then
- rm "${WORKDIR}/${MY_PV}"/*_all_crosscompile.patch
- fi
-
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${MY_PV}"
-
- # Avoid regeneration, which would not change contents of files.
- touch Include/Python-ast.h Python/Python-ast.c
-
- sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
- Lib/distutils/command/install.py \
- Lib/distutils/sysconfig.py \
- Lib/site.py \
- Makefile.pre.in \
- Modules/Setup.dist \
- Modules/getpath.c \
- setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
-
- if ! use wininst; then
- # Remove Microsoft Windows executables.
- rm Lib/distutils/command/wininst-*.exe
- fi
-
- # Fix OtherFileTests.testStdin() not to assume
- # that stdin is a tty for bug #248081.
- sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- # Disable extraneous modules with extra dependencies.
- if use build; then
- export PYTHON_DISABLE_MODULES="gdbm _curses _curses_panel readline _sqlite3 _tkinter _elementtree pyexpat"
- export PYTHON_DISABLE_SSL="1"
- else
- local disable
- use gdbm || disable+=" gdbm"
- use ncurses || disable+=" _curses _curses_panel"
- use readline || disable+=" readline"
- use sqlite || disable+=" _sqlite3"
- use ssl || export PYTHON_DISABLE_SSL="1"
- use tk || disable+=" _tkinter"
- use xml || disable+=" _elementtree pyexpat" # _elementtree uses pyexpat.
- export PYTHON_DISABLE_MODULES="${disable}"
-
- if ! use xml; then
- ewarn "You have configured Python without XML support."
- ewarn "This is NOT a recommended configuration as you"
- ewarn "may face problems parsing any XML documents."
- fi
- fi
-
- if [[ -n "${PYTHON_DISABLE_MODULES}" ]]; then
- einfo "Disabled modules: ${PYTHON_DISABLE_MODULES}"
- fi
-
- if [[ "$(gcc-major-version)" -ge 4 ]]; then
- append-flags -fwrapv
- fi
-
- filter-flags -malign-double
-
- [[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
-
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
- if tc-is-cross-compiler; then
- OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
- ./configure --{build,host}=${CBUILD} || die "cross-configure failed"
- emake python Parser/pgen || die "cross-make failed"
- mv python hostpython
- mv Parser/pgen Parser/hostpgen
- make distclean
- sed -i \
- -e "/^HOSTPYTHON/s:=.*:=./hostpython:" \
- -e "/^HOSTPGEN/s:=.*:=./Parser/hostpgen:" \
- Makefile.pre.in || die "sed failed"
- fi
-
- # Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
- tc-export CXX
-
- # Set LDFLAGS so we link modules with -lpython3.1 correctly.
- # Needed on FreeBSD unless Python 3.1 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
- local dbmliborder
- if use gdbm; then
- dbmliborder+="${dbmliborder:+:}gdbm"
- fi
-
- OPT="" econf \
- --with-fpectl \
- --enable-shared \
- $(use_enable ipv6) \
- $(use_with threads) \
- $(use_with wide-unicode) \
- --infodir='${prefix}/share/info' \
- --mandir='${prefix}/share/man' \
- --with-computed-gotos \
- --with-dbmliborder="${dbmliborder}" \
- --with-libc="" \
- --with-system-ffi
-}
-
-src_test() {
- # Tests will not work when cross compiling.
- if tc-is-cross-compiler; then
- elog "Disabling tests due to crosscompiling."
- return
- fi
-
- if ! use threads; then
- ewarn "Disabling tests due to USE=\"-threads\""
- return
- fi
-
- # Byte compiling should be enabled here.
- # Otherwise test_import fails.
- python_enable_pyc
-
- # Skip failing tests.
- local skip_tests="distutils"
-
- # test_ctypes fails with PAX kernel (bug #234498).
- host-is-pax && skip_tests+=" ctypes"
-
- for test in ${skip_tests}; do
- mv "${S}/Lib/test/test_${test}.py" "${T}"
- done
-
- # Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" emake test
- local result="$?"
-
- for test in ${skip_tests}; do
- mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
- done
-
- elog "The following tests have been skipped:"
- for test in ${skip_tests}; do
- elog "test_${test}.py"
- done
-
- elog "If you would like to run them, you may:"
- elog "cd '${EPREFIX}$(python_get_libdir)/test'"
- elog "and run the tests separately."
-
- python_disable_pyc
-
- if [[ "${result}" -ne 0 ]]; then
- die "emake test failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" altinstall || die "emake altinstall failed"
- python_clean_installation_image -q
-
- mv "${ED}usr/bin/python${SLOT}-config" "${ED}usr/bin/python-config-${SLOT}"
-
- # Fix collisions between different slots of Python.
- mv "${ED}usr/bin/2to3" "${ED}usr/bin/2to3-${SLOT}"
- mv "${ED}usr/bin/pydoc3" "${ED}usr/bin/pydoc${SLOT}"
- mv "${ED}usr/bin/idle3" "${ED}usr/bin/idle${SLOT}"
- rm -f "${ED}usr/bin/smtpd.py"
-
- if use build; then
- rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{idlelib,sqlite3,test,tkinter}
- else
- use elibc_uclibc && rm -fr "${ED}$(python_get_libdir)/test"
- use sqlite || rm -fr "${ED}$(python_get_libdir)/"{sqlite3,test/test_sqlite*}
- use tk || rm -fr "${ED}usr/bin/idle${SLOT}" "${ED}$(python_get_libdir)/"{idlelib,tkinter,test/test_tk*}
- fi
-
- use threads || rm -fr "${ED}$(python_get_libdir)/multiprocessing"
-
- prep_ml_includes $(python_get_includedir)
-
- dodoc Misc/{ACKS,HISTORY,NEWS} || die "dodoc failed"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${S}/Tools" || die "doins failed"
- fi
-
- newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
- newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
-}
-
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version ">=${CATEGORY}/${PN}-${SLOT}_alpha"; then
- python_updater_warning="1"
- fi
-}
-
-eselect_python_update() {
- eselect python update --python3 || eselect python update
-}
-
-pkg_postinst() {
- eselect_python_update
-
- python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
-
- if [[ "$(eselect python show)" == "python2."* ]]; then
- ewarn
- ewarn "WARNING!"
- ewarn "Many Python modules have not been ported yet to Python 3.*."
- ewarn "Python 3 has not been activated and Python wrapper is still configured to use Python 2."
- ewarn "You can manually activate Python ${SLOT} using \`eselect python set python${SLOT}\`."
- ewarn "It is recommended to currently have Python wrapper configured to use Python 2."
- ewarn "Having Python wrapper configured to use Python 3 is unsupported."
- ewarn
- fi
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should run 'python-updater \${options}' to rebuild Python modules."
- ewarn
- ewarn "\e[1;31m************************************************************************\e[0m"
- ewarn
-
- local n
- for ((n = 0; n < 12; n++)); do
- echo -ne "\a"
- sleep 1
- done
- fi
-}
-
-pkg_postrm() {
- eselect_python_update
-
- python_mod_cleanup $(python_get_libdir)
-}