summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2006-06-30 18:39:06 +0000
committerJoel Martin <kanaka@gentoo.org>2006-06-30 18:39:06 +0000
commit83adedac58b7a90c75fede4e75240129a31f7d05 (patch)
tree65cf3cb9e87f209359bbb145259167aaef9b3639 /dev-lang
parentFix digest. (diff)
downloadgentoo-2-83adedac58b7a90c75fede4e75240129a31f7d05.tar.gz
gentoo-2-83adedac58b7a90c75fede4e75240129a31f7d05.tar.bz2
gentoo-2-83adedac58b7a90c75fede4e75240129a31f7d05.zip
Cross-compile update: bindir-libdir patch is no longer needed and will break the patching if it's there. Also, unset CC to force the native python build to use the native compiler.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.4.3-r1.ebuild5
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index c250bacb906b..bb01094597b7 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.200 2006/06/28 17:35:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.201 2006/06/30 18:39:06 kanaka Exp $
+
+ 30 Jun 2006; Joel Martin <kanaka@gentoo.org> python-2.4.3-r1.ebuild:
+ Cross-compile update: bindir-libdir patch is no longer needed and will break
+ the patching if it's there. Also, unset CC to force the native python build
+ to use the native compiler.
28 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org>
python-2.4.3-r1.ebuild:
diff --git a/dev-lang/python/python-2.4.3-r1.ebuild b/dev-lang/python/python-2.4.3-r1.ebuild
index bbb60e88f471..ce275884a13f 100644
--- a/dev-lang/python/python-2.4.3-r1.ebuild
+++ b/dev-lang/python/python-2.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.3-r1.ebuild,v 1.6 2006/06/28 17:35:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.3-r1.ebuild,v 1.7 2006/06/30 18:39:06 kanaka Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -93,7 +93,6 @@ src_unpack() {
[ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i ${S}/configure
if tc-is-cross-compiler ; then
- epatch "${WORKDIR}/${PATCHTAR}"/python-2.4.1-bindir-libdir.patch
epatch "${WORKDIR}/${PATCHTAR}"/python-2.4.1-crosscompile.patch
fi
@@ -155,7 +154,7 @@ src_compile() {
src_configure
if tc-is-cross-compiler ; then
- OPT="-O1" CFLAGS="" LDFLAGS="" \
+ OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
./configure --with-cxx=no || die "cross-configure failed"
emake python Parser/pgen || die "cross-make failed"
mv python hostpython