summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-10-03 07:58:15 +0000
committerKeri Harris <keri@gentoo.org>2006-10-03 07:58:15 +0000
commit91220545bb7d01efa031b813407b51a721916634 (patch)
treefd5f2ea04fa7bf073749b41cc56eb8007a3a9d0e /dev-lang
parentUse get_libdir to get the path to mask from revdep-rebuild. (diff)
downloadgentoo-2-91220545bb7d01efa031b813407b51a721916634.tar.gz
gentoo-2-91220545bb7d01efa031b813407b51a721916634.tar.bz2
gentoo-2-91220545bb7d01efa031b813407b51a721916634.zip
Fix string_format tests for 64bit architectures.
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mercury/ChangeLog5
-rw-r--r--dev-lang/mercury/files/mercury-0.12.2-tests.patch54
2 files changed, 46 insertions, 13 deletions
diff --git a/dev-lang/mercury/ChangeLog b/dev-lang/mercury/ChangeLog
index 5c0dee7a4536..401203448f64 100644
--- a/dev-lang/mercury/ChangeLog
+++ b/dev-lang/mercury/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/mercury
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.47 2006/10/03 07:30:40 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury/ChangeLog,v 1.48 2006/10/03 07:58:15 keri Exp $
+
+ 03 Oct 2006; keri <keri@gentoo.org> files/mercury-0.12.2-tests.patch:
+ Fix string_format tests for 64bit architectures.
03 Oct 2006; keri <keri@gentoo.org> mercury-0.12.2-r3.ebuild:
Add ~amd64 keyword.
diff --git a/dev-lang/mercury/files/mercury-0.12.2-tests.patch b/dev-lang/mercury/files/mercury-0.12.2-tests.patch
index d250658e4373..d65ff295a014 100644
--- a/dev-lang/mercury/files/mercury-0.12.2-tests.patch
+++ b/dev-lang/mercury/files/mercury-0.12.2-tests.patch
@@ -1,6 +1,36 @@
+diff -urN mercury-tests-0.12.2.orig/general/string_format/Mmakefile mercury-tests-0.12.2/general/string_format/Mmakefile
+--- mercury-tests-0.12.2.orig/general/string_format/Mmakefile 2004-12-11 05:23:46.000000000 +1300
++++ mercury-tests-0.12.2/general/string_format/Mmakefile 2006-10-03 20:46:24.000000000 +1300
+@@ -89,22 +89,22 @@
+ echo "Matched $*.sorted_exp" && \
+ cp $*.res1 $@; } || \
+ { test -f $*.exp2 && \
+- @sort $*.exp2 > $*.sorted_exp2 \
++ sort $*.exp2 > $*.sorted_exp2 && \
+ diff $(DIFF_OPTS) $*.sorted_exp2 $*.sorted_out > $*.res2 && \
+ echo "Matched $*.sorted_exp2" && \
+ cp $*.res2 $@; } || \
+ { test -f $*.exp3 && \
+- @sort $*.exp3 > $*.sorted_exp3 \
++ sort $*.exp3 > $*.sorted_exp3 && \
+ diff $(DIFF_OPTS) $*.sorted_exp3 $*.sorted_out > $*.res3 && \
+ echo "Matched $*.sorted_exp3" && \
+ cp $*.res3 $@; } || \
+ { test -f $*.exp4 && \
+- @sort $*.exp4 > $*.sorted_exp4 \
++ sort $*.exp4 > $*.sorted_exp4 && \
+ diff $(DIFF_OPTS) $*.sorted_exp4 $*.sorted_out > $*.res4 && \
+ echo "Matched $*.sorted_exp4" && \
+ cp $*.res4 $@; } || \
+ { test -f $*.exp5 && \
+- @sort $*.exp5 > $*.sorted_exp5 \
++ sort $*.exp5 > $*.sorted_exp5 && \
+ diff $(DIFF_OPTS) $*.sorted_exp5 $*.sorted_out > $*.res5 && \
+ echo "Matched $*.sorted_exp5" && \
+ cp $*.res5 $@; } || \
diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp mercury-tests-0.12.2/hard_coded/dir_test.exp
--- mercury-tests-0.12.2.orig/hard_coded/dir_test.exp 2003-07-29 03:50:45.000000000 +1200
-+++ mercury-tests-0.12.2/hard_coded/dir_test.exp 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/hard_coded/dir_test.exp 2006-10-03 20:55:25.000000000 +1300
@@ -130,7 +130,6 @@
"foo"/"bar/baz" = "foo\bar\baz".
"foo/"/"bar/baz" = "foo\bar\baz".
@@ -11,7 +41,7 @@ diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp mercury-tests-0.12.2
dir.make_single_directory with non-existent parent failed as expected.
diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp2 mercury-tests-0.12.2/hard_coded/dir_test.exp2
--- mercury-tests-0.12.2.orig/hard_coded/dir_test.exp2 2003-07-29 03:50:45.000000000 +1200
-+++ mercury-tests-0.12.2/hard_coded/dir_test.exp2 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/hard_coded/dir_test.exp2 2006-10-03 20:55:25.000000000 +1300
@@ -127,7 +127,6 @@
"foo"/"bar/baz" = "foo/bar/baz".
"foo/"/"bar/baz" = "foo/bar/baz".
@@ -22,7 +52,7 @@ diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp2 mercury-tests-0.12.
dir.make_single_directory with non-existent parent failed as expected.
diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp3 mercury-tests-0.12.2/hard_coded/dir_test.exp3
--- mercury-tests-0.12.2.orig/hard_coded/dir_test.exp3 2003-07-29 03:50:45.000000000 +1200
-+++ mercury-tests-0.12.2/hard_coded/dir_test.exp3 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/hard_coded/dir_test.exp3 2006-10-03 20:55:25.000000000 +1300
@@ -130,7 +130,6 @@
"foo"/"bar/baz" = "foo/bar/baz".
"foo/"/"bar/baz" = "foo/bar/baz".
@@ -33,7 +63,7 @@ diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.exp3 mercury-tests-0.12.
dir.make_single_directory with non-existent parent failed as expected.
diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.m mercury-tests-0.12.2/hard_coded/dir_test.m
--- mercury-tests-0.12.2.orig/hard_coded/dir_test.m 2003-08-05 22:50:33.000000000 +1200
-+++ mercury-tests-0.12.2/hard_coded/dir_test.m 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/hard_coded/dir_test.m 2006-10-03 20:55:25.000000000 +1300
@@ -50,16 +50,6 @@
io__write(ReadResult),
io__nl,
@@ -53,14 +83,14 @@ diff -urN mercury-tests-0.12.2.orig/hard_coded/dir_test.m mercury-tests-0.12.2/h
% Test making a directory that already exists.
diff -urN mercury-tests-0.12.2.orig/invalid/foreign_decl_line_number.err_exp3 mercury-tests-0.12.2/invalid/foreign_decl_line_number.err_exp3
--- mercury-tests-0.12.2.orig/invalid/foreign_decl_line_number.err_exp3 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/invalid/foreign_decl_line_number.err_exp3 2006-08-13 16:19:25.000000000 +1200
++++ mercury-tests-0.12.2/invalid/foreign_decl_line_number.err_exp3 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+foreign_decl_line_number.m:19:2: error: #error Error in foreign decl
+foreign_decl_line_number.m:23:2: error: #error Error in foreign code
+foreign_decl_line_number.m:37:2: error: #error Error in foreign proc
diff -urN mercury-tests-0.12.2.orig/mdbrc mercury-tests-0.12.2/mdbrc
--- mercury-tests-0.12.2.orig/mdbrc 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/mdbrc 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/mdbrc 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,19 @@
+source MDB_DOC
+alias s step
@@ -83,42 +113,42 @@ diff -urN mercury-tests-0.12.2.orig/mdbrc mercury-tests-0.12.2/mdbrc
+set xml_tmp_filename ''
diff -urN mercury-tests-0.12.2.orig/tabling/loopcheck.exp5 mercury-tests-0.12.2/tabling/loopcheck.exp5
--- mercury-tests-0.12.2.orig/tabling/loopcheck.exp5 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/tabling/loopcheck.exp5 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/tabling/loopcheck.exp5 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+Uncaught Mercury exception:
+Software Error: detected infinite recursion in pred loopcheck.loop/1
+Stack dump not available in this grade.
diff -urN mercury-tests-0.12.2.orig/tabling/loopcheck_nondet.exp2 mercury-tests-0.12.2/tabling/loopcheck_nondet.exp2
--- mercury-tests-0.12.2.orig/tabling/loopcheck_nondet.exp2 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/tabling/loopcheck_nondet.exp2 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/tabling/loopcheck_nondet.exp2 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+Uncaught Mercury exception:
+Software Error: detected infinite recursion in pred loopcheck_nondet.loop/2
+Stack dump not available in this grade.
diff -urN mercury-tests-0.12.2.orig/tabling/tc_loop.exp3 mercury-tests-0.12.2/tabling/tc_loop.exp3
--- mercury-tests-0.12.2.orig/tabling/tc_loop.exp3 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/tabling/tc_loop.exp3 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/tabling/tc_loop.exp3 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+Uncaught Mercury exception:
+Software Error: detected infinite recursion in pred tc_loop.tc/2
+Stack dump not available in this grade.
diff -urN mercury-tests-0.12.2.orig/tabling/tc_memo.exp2 mercury-tests-0.12.2/tabling/tc_memo.exp2
--- mercury-tests-0.12.2.orig/tabling/tc_memo.exp2 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/tabling/tc_memo.exp2 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/tabling/tc_memo.exp2 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+Uncaught Mercury exception:
+Software Error: detected infinite recursion in pred tc_memo.tc/2
+Stack dump not available in this grade.
diff -urN mercury-tests-0.12.2.orig/tabling/tc_memo2.exp2 mercury-tests-0.12.2/tabling/tc_memo2.exp2
--- mercury-tests-0.12.2.orig/tabling/tc_memo2.exp2 1970-01-01 12:00:00.000000000 +1200
-+++ mercury-tests-0.12.2/tabling/tc_memo2.exp2 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/tabling/tc_memo2.exp2 2006-10-03 20:55:25.000000000 +1300
@@ -0,0 +1,3 @@
+Uncaught Mercury exception:
+Software Error: detected need for minimal model in pred tc_memo2.tc/2
+Stack dump not available in this grade.
diff -urN mercury-tests-0.12.2.orig/valid/Mmakefile mercury-tests-0.12.2/valid/Mmakefile
--- mercury-tests-0.12.2.orig/valid/Mmakefile 2005-08-17 16:44:17.000000000 +1200
-+++ mercury-tests-0.12.2/valid/Mmakefile 2006-08-13 21:25:10.000000000 +1200
++++ mercury-tests-0.12.2/valid/Mmakefile 2006-10-03 20:55:25.000000000 +1300
@@ -376,3 +376,5 @@
rm -f *.err *.h