summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2013-11-22 08:56:13 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2013-11-22 08:56:13 +0000
commitb1da44968b28ba00a557d269ca8a215e85129e3f (patch)
tree2c47b0dd999a9a42d12671226b3bd579e3eca3a6 /dev-lang
parentpython-mhash-1.4-r1: Add ~ppc-aix keyword. (diff)
downloadgentoo-2-b1da44968b28ba00a557d269ca8a215e85129e3f.tar.gz
gentoo-2-b1da44968b28ba00a557d269ca8a215e85129e3f.tar.bz2
gentoo-2-b1da44968b28ba00a557d269ca8a215e85129e3f.zip
perl eblits v50160001: Support AIX platform (ppc-aix keyword).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit5
-rw-r--r--dev-lang/perl/files/eblits/src_configure-v50160001.eblit40
3 files changed, 32 insertions, 20 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 4dd92d6ca5a4..1066535a7b32 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.398 2013/09/10 03:18:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.399 2013/11/22 08:56:12 haubi Exp $
+
+ 22 Nov 2013; Michael Haubenwallner <haubi@gentoo.org>
+ files/eblits/pkg_setup-v50160001.eblit,
+ files/eblits/src_configure-v50160001.eblit:
+ Support AIX platform (ppc-aix keyword).
10 Sep 2013; Patrick Lauer <patrick@gentoo.org> perl-5.12.5.ebuild:
Whitespace
diff --git a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
index 99310759acb4..f8d01f8fb4f3 100644
--- a/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit,v 1.1 2012/06/05 17:52:35 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit,v 1.2 2013/11/22 08:56:13 haubi Exp $
eblit-perl-pkg_setup() {
case ${CHOST} in
@@ -10,6 +10,7 @@ eblit-perl-pkg_setup() {
*-openbsd*) osname="openbsd" ;;
*-darwin*) osname="darwin" ;;
*-interix*) osname="interix" ;;
+ *-aix*) osname="aix" ;;
*) osname="linux" ;;
esac
diff --git a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit b/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
index bd0abdd64e98..3c3239a692a0 100644
--- a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
+++ b/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50160001.eblit,v 1.5 2012/08/16 10:47:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50160001.eblit,v 1.6 2013/11/22 08:56:13 haubi Exp $
myconf() {
# the myconf array is declared in src_configure
@@ -80,21 +80,27 @@ eblit-perl-src_configure() {
if use prefix ; then
local ldir
local paths=""
- echo "int main() {}" > "${T}"/t.c
- # need to ensure dirs contain compatible libs,
- # bugs #358875, #400839, use scanelf for #425538
- $(tc-getCC) -o "${T}"/t "${T}"/t.c > /dev/null || die
- local scantool=scanelf
- [[ ${CHOST} == *-darwin* ]] && scantool=scanmacho
- local mtype=$(${scantool} -BF "%M%D#f" "${T}"/t)
- einfo "searching libdirs for ${mtype}"
- for ldir in /lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib ; do
- [[ -e ${ldir} ]] || continue
- if ${scantool} -BF "%M%D#f" ${ldir}/ | grep -q ${mtype} ; then
- paths="${paths} ${ldir}"
- einfo "found ${ldir}"
- fi
- done
+ local scantool=""
+ case ${CHOST} in
+ *-aix*) paths="/lib /usr/lib" ;;
+ *-darwin*) scantool=scanmacho ;;
+ *) scantool=scanelf ;;
+ esac
+ if [[ -n ${scantool} ]]; then
+ echo "int main() {}" > "${T}"/t.c
+ # need to ensure dirs contain compatible libs,
+ # bugs #358875, #400839, use scanelf for #425538
+ $(tc-getCC) -o "${T}"/t "${T}"/t.c > /dev/null || die
+ local mtype=$(${scantool} -BF "%M%D#f" "${T}"/t)
+ einfo "searching libdirs for ${mtype}"
+ for ldir in /lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib ; do
+ [[ -e ${ldir} ]] || continue
+ if ${scantool} -BF "%M%D#f" ${ldir}/ | grep -q ${mtype} ; then
+ paths="${paths} ${ldir}"
+ einfo "found ${ldir}"
+ fi
+ done
+ fi
myconf "-Dlibpth=${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir) ${paths}"
elif [[ $(get_libdir) != "lib" ]] ; then
# We need to use " and not ', as the written config.sh use ' ...