summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-10-15 22:11:33 +0000
committerPeter Johanson <latexer@gentoo.org>2005-10-15 22:11:33 +0000
commitb92232103aaf4a19e7c0133af67d1eea99d75620 (patch)
treef413e268780ba48053496589e278ed2c728d98ca /dev-lang
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-b92232103aaf4a19e7c0133af67d1eea99d75620.tar.gz
gentoo-2-b92232103aaf4a19e7c0133af67d1eea99d75620.tar.bz2
gentoo-2-b92232103aaf4a19e7c0133af67d1eea99d75620.zip
Mark stable on x86, and remove the old 1.0.6 version.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/files/digest-mono-1.0.62
-rw-r--r--dev-lang/mono/mono-1.0.6.ebuild139
-rw-r--r--dev-lang/mono/mono-1.1.8.3.ebuild4
4 files changed, 7 insertions, 144 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 2d5bf4f80c7e..03d9e3144306 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.62 2005/10/15 21:53:18 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.63 2005/10/15 22:11:33 latexer Exp $
+
+ 15 Oct 2005; Peter Johanson <latexer@gentoo.org> -mono-1.0.6.ebuild,
+ mono-1.1.8.3.ebuild:
+ Mark stable on x86, and remove the old 1.0.6 version.
*mono-1.1.9.2 (15 Oct 2005)
diff --git a/dev-lang/mono/files/digest-mono-1.0.6 b/dev-lang/mono/files/digest-mono-1.0.6
deleted file mode 100644
index 58c23e350ff3..000000000000
--- a/dev-lang/mono/files/digest-mono-1.0.6
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 61700d5e113a1c9c99511971141b6901 mono-1.0.6.tar.gz 18486989
-MD5 465cf1256ae0ae7aac8c70a85991ddeb mcs-1.0.6.tar.gz 22322108
diff --git a/dev-lang/mono/mono-1.0.6.ebuild b/dev-lang/mono/mono-1.0.6.ebuild
deleted file mode 100644
index 3b46468a1058..000000000000
--- a/dev-lang/mono/mono-1.0.6.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.0.6.ebuild,v 1.2 2005/05/13 00:29:15 latexer Exp $
-
-inherit eutils mono flag-o-matic debug
-
-MCS_P=${P/mono/mcs}
-MCS_S=${WORKDIR}/${MCS_P}
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com/"
-SRC_URI="http://www.go-mono.com/archive/${PV}/${P}.tar.gz
- http://www.go-mono.com/archive/${PV}/${MCS_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-2 X11)"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE="nptl"
-
-DEPEND="virtual/libc
- >=dev-libs/glib-2.0
- >=dev-libs/icu-2.6.1
- !<dev-dotnet/pnet-0.6.12
- >=sys-devel/gcc-3.3.5
- ppc? (
- >=sys-libs/glibc-2.3.3_pre20040420
- )"
-
-RDEPEND="${DEPEND}
- dev-util/pkgconfig
- dev-libs/libxml2"
-
-src_unpack() {
- unpack ${A}
-
- cd ${MCS_S}
- epatch ${FILESDIR}/mcs-1.0.5-pathfix.diff
-
- # Disable installing the precompiled mcs/classlibs
- sed -i "s: runtime : :" ${S}/Makefile.in
- # Fix the path for the jay man page
- sed -i "s:man/man1:share/man/man1:" ${MCS_S}/jay/Makefile
-
- # Ugly sed to replace windows path with *nix equivalent
- for file in $(find ${MCS_S}/nunit20 -name AssemblyInfo.cs)
- do
- sed -i "s:\.\.\\\\\\\\:../:g" "${file}"
- done
-
- # Fix MONO_CFG_DIR for signing
- sed -i \
- "s:^\t\(MONO_PATH.*)\):\tMONO_CFG_DIR='${D}/etc/' \1:" \
- ${MCS_S}/build/library.make
-
- # add our own little in-place mcs script
- echo "${S}/mono/mini/mono ${S}/runtime/mcs.exe \"\$@\" " > ${S}/runtime/mcs
- chmod +x ${S}/runtime/mcs
-
- echo "${S}/mono/mini/mono ${S}/runtime/monoresgen.exe \"\$@\" " > ${S}/runtime/monoresgen
- chmod +x ${S}/runtime/monoresgen
-
- PATH="${S}/runtime:${PATH}"
- MONO_CFG_DIR='${D}/etc/'
- export PATH
- export MONO_CFG_DIR
-}
-
-src_compile() {
- strip-flags
-
- local myconf="--with-sigaltstack=yes"
- if use nptl
- then
- myconf="${myconf} --with-tls=__thread"
- sed -i "s: -fexceptions::" ${S}/libgc/configure.host
- else
- myconf="${myconf} --with-tls=pthread"
- fi
-
- econf ${myconf} || die
- emake -j1 || die "mono runtime compilation failure"
-
- cd ${S}
- ln -s ../runtime ${WORKDIR}/${P}/runtime/lib
-
- # Now that we have a valid config for lib mappings, put them
- # in our temporary config directory.
-
- dodir /etc/mono
- cp ${S}/data/{config,machine.config} ${D}/etc/mono/
-
- cd ${MCS_S}
- echo "prefix=${S}/runtime" > build/config.make
- echo "MONO_PATH=${S}/runtime/net_1_1" >> build/config.make
- echo "BOOTSTRAP_MCS=${S}/runtime/mcs" >> build/config.make
- echo "RUNTIME=${S}/mono/mini/mono \${RUNTIME_FLAGS}" >> build/config.make
- echo "PATH=${S}/runtime:${PATH}" >> build/config.make
- echo "export PATH" >> build/config.make
- echo "export MONO_PATH" >> build/config.make
- emake -j1 PLATFORM=linux || die "mcs compiler compilation failure"
- echo "prefix=/usr" >> build/config.make
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- dodoc AUTHORS ChangeLog NEWS README
- docinto docs
- dodoc docs/*
- docinto libgc
- dodoc libgc/ChangeLog
-
- cd ${MCS_S}
- make PLATFORM=linux DESTDIR=${D} install || die
-
- docinto mcs
- dodoc AUTHORS README* ChangeLog INSTALL.txt
- docinto mcs/docs
- dodoc docs/*.txt
-
- # Remove some extraneous tools
- cd ${D}/usr/bin
- rm {CorCompare,EnumCheck,GenerateDelegate,ictool,IFaceDisco}.exe
- rm nunit-console.exe
- # Remove gmcs script, as we don't install gmcs for mono-1.0.x
- rm gmcs
-
- # init script
- exeinto /etc/init.d ; newexe ${FILESDIR}/dotnet.init dotnet
- insinto /etc/conf.d ; newins ${FILESDIR}/dotnet.conf dotnet
-}
-
-pkg_postinst() {
- echo
- einfo "If you want to avoid typing '<runtime> program.exe'"
- einfo "you can configure your runtime in /etc/conf.d/dotnet"
- einfo "Use /etc/init.d/dotnet to register your runtime"
- echo
-}
diff --git a/dev-lang/mono/mono-1.1.8.3.ebuild b/dev-lang/mono/mono-1.1.8.3.ebuild
index 0a22eee6d066..c5443989e625 100644
--- a/dev-lang/mono/mono-1.1.8.3.ebuild
+++ b/dev-lang/mono/mono-1.1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.8.3.ebuild,v 1.4 2005/09/28 19:00:16 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.8.3.ebuild,v 1.5 2005/10/15 22:11:33 latexer Exp $
inherit eutils mono flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 X11)"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE="nptl icu X"
DEPEND="virtual/libc