summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-10-07 14:34:24 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-10-07 14:34:24 +0000
commitbf9975dc79fc3652d23f558888affb8994a13730 (patch)
treebd3c5966dfb24a8b5dbf2310d7cfc80d379cfb28 /dev-lang
parentBump to github snapshot from 2014-04-23 for security bug 482140 (diff)
downloadgentoo-2-bf9975dc79fc3652d23f558888affb8994a13730.tar.gz
gentoo-2-bf9975dc79fc3652d23f558888affb8994a13730.tar.bz2
gentoo-2-bf9975dc79fc3652d23f558888affb8994a13730.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog7
-rw-r--r--dev-lang/go/go-1.3.3.ebuild141
2 files changed, 147 insertions, 1 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 4dc130afb66e..a12a7dc4722a 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.46 2014/08/28 11:20:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.47 2014/10/07 14:34:24 williamh Exp $
+
+*go-1.3.3 (07 Oct 2014)
+
+ 07 Oct 2014; William Hubbs <williamh@gentoo.org> +go-1.3.3.ebuild:
+ version bump
28 Aug 2014; Michał Górny <mgorny@gentoo.org> go-1.3.1.ebuild:
Remove USE=bash-completion, install the completion file unconditionally
diff --git a/dev-lang/go/go-1.3.3.ebuild b/dev-lang/go/go-1.3.3.ebuild
new file mode 100644
index 000000000000..9ab480a89b56
--- /dev/null
+++ b/dev-lang/go/go-1.3.3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.3.ebuild,v 1.1 2014/10/07 14:34:24 williamh Exp $
+
+EAPI=5
+
+export CTARGET=${CTARGET:-${CHOST}}
+
+inherit bash-completion-r1 elisp-common eutils
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://go.googlecode.com/hg"
+ inherit mercurial
+else
+ SRC_URI="https://storage.googleapis.com/golang/go${PV}.src.tar.gz"
+ # Upstream only supports go on amd64, arm and x86 architectures.
+ KEYWORDS="-* ~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A concurrent garbage collected and typesafe programming language"
+HOMEPAGE="http://www.golang.org"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="emacs vim-syntax zsh-completion"
+
+DEPEND=""
+RDEPEND="emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ zsh-completion? ( app-shells/zsh-completion )"
+
+# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
+QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
+
+# The go language uses *.a files which are _NOT_ libraries and should not be
+# stripped.
+STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}"/go
+fi
+
+src_prepare()
+{
+ if [[ ${PV} != 9999 ]]; then
+ epatch "${FILESDIR}"/${PN}-1.2-no-Werror.patch
+ fi
+ epatch_user
+}
+
+src_compile()
+{
+ export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
+ export GOROOT="$(pwd)"
+ export GOBIN="${GOROOT}/bin"
+ if [[ $CTARGET = armv5* ]]
+ then
+ export GOARM=5
+ fi
+
+ cd src
+ ./make.bash || die "build failed"
+ cd ..
+
+ if use emacs; then
+ elisp-compile misc/emacs/*.el
+ fi
+}
+
+src_test()
+{
+ cd src
+ PATH="${GOBIN}:${PATH}" \
+ ./run.bash --no-rebuild --banner || die "tests failed"
+}
+
+src_install()
+{
+ dobin bin/*
+ dodoc AUTHORS CONTRIBUTORS PATENTS README
+
+ dodir /usr/lib/go
+ insinto /usr/lib/go
+
+ # There is a known issue which requires the source tree to be installed [1].
+ # Once this is fixed, we can consider using the doc use flag to control
+ # installing the doc and src directories.
+ # [1] http://code.google.com/p/go/issues/detail?id=2775
+ doins -r doc include lib pkg src
+
+ dobashcomp misc/bash/go
+
+ if use emacs; then
+ elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r misc/vim/ftdetect
+ doins -r misc/vim/ftplugin
+ doins -r misc/vim/syntax
+ doins -r misc/vim/plugin
+ doins -r misc/vim/indent
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/go
+ fi
+
+ fperms -R +x /usr/lib/go/pkg/tool
+}
+
+pkg_postinst()
+{
+ if use emacs; then
+ elisp-site-regen
+ fi
+
+ # If the go tool sees a package file timestamped older than a dependancy it
+ # will rebuild that file. So, in order to stop go from rebuilding lots of
+ # packages for every build we need to fix the timestamps. The compiler and
+ # linker are also checked - so we need to fix them too.
+ ebegin "fixing timestamps to avoid unnecessary rebuilds"
+ tref="usr/lib/go/pkg/*/runtime.a"
+ find "${EROOT}"usr/lib/go -type f \
+ -exec touch -r "${EROOT}"${tref} {} \;
+ eend $?
+
+ if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
+ ${REPLACING_VERSIONS} != ${PV} ]]; then
+ elog "Release notes are located at http://golang.org/doc/go${PV}"
+ fi
+}
+
+pkg_postrm()
+{
+ if use emacs; then
+ elisp-site-regen
+ fi
+}