summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-03 18:04:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-03 18:04:24 +0000
commitd2d430f307afc9c819b9bf51a3623456c4eb07cd (patch)
tree89c59f2e2e72fe49f1acb4a383181bf789f08bd5 /dev-lang
parentMarking ghostscript-gpl-8.61-r1 ppc for bug 202217 (diff)
downloadgentoo-2-d2d430f307afc9c819b9bf51a3623456c4eb07cd.tar.gz
gentoo-2-d2d430f307afc9c819b9bf51a3623456c4eb07cd.tar.bz2
gentoo-2-d2d430f307afc9c819b9bf51a3623456c4eb07cd.zip
Allow to disable ocamlopt via an useflag
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.10.0.ebuild12
-rw-r--r--dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild10
3 files changed, 18 insertions, 10 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index a3c1b2c7546b..a95c79123190 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.132 2008/01/02 18:35:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.133 2008/01/03 18:04:24 aballier Exp $
+
+ 03 Jan 2008; Alexis Ballier <aballier@gentoo.org> ocaml-3.10.0.ebuild,
+ ocaml-3.10.1_rc2.ebuild:
+ Allow to disable ocamlopt via an useflag
02 Jan 2008; Alexis Ballier <aballier@gentoo.org> ocaml-3.08.4.ebuild,
ocaml-3.09.2.ebuild, ocaml-3.09.3.ebuild:
diff --git a/dev-lang/ocaml/ocaml-3.10.0.ebuild b/dev-lang/ocaml/ocaml-3.10.0.ebuild
index c8d7ce42ad61..df6259a967d3 100644
--- a/dev-lang/ocaml/ocaml-3.10.0.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.10 2007/12/20 20:24:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.11 2008/01/03 18:04:24 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
+EAPI="1"
+
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/${P}.tar.gz"
@@ -11,7 +13,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="emacs gdbm latex ncurses tk X xemacs"
+IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
@@ -79,8 +81,8 @@ src_compile() {
make world || die "make world failed!"
- # Native code generation is unsupported on some archs
- if ! use ppc64 ; then
+ # Native code generation can be disabled now
+ if use ocamlopt ; then
make opt || die "make opt failed!"
make opt.opt || die "make opt.opt failed!"
fi
diff --git a/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild b/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild
index ff820e4b25b3..23b8429af0ab 100644
--- a/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild,v 1.1 2008/01/02 17:27:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.1_rc2.ebuild,v 1.2 2008/01/03 18:04:24 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
+EAPI="1"
+
MY_P="${P/_rc/+rc}"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -12,7 +14,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="emacs gdbm latex ncurses tk X xemacs"
+IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
@@ -81,8 +83,8 @@ src_compile() {
make world || die "make world failed!"
- # Native code generation is unsupported on some archs
- if ! use ppc64 ; then
+ # Native code generation can be disabled now
+ if use ocamlopt ; then
make opt || die "make opt failed!"
make opt.opt || die "make opt.opt failed!"
fi