summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-01-03 15:50:25 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-01-03 15:50:25 +0000
commite8fa9fefd223cd4736383c25f4c9f880728c446c (patch)
tree38417456691c56034221cee8e379554961564db5 /dev-lang
parentNew teapop ebuild, untested (diff)
downloadgentoo-2-e8fa9fefd223cd4736383c25f4c9f880728c446c.tar.gz
gentoo-2-e8fa9fefd223cd4736383c25f4c9f880728c446c.tar.bz2
gentoo-2-e8fa9fefd223cd4736383c25f4c9f880728c446c.zip
New version. Masking until it's tested.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/files/digest-php-4.1.11
-rw-r--r--dev-lang/php/php-4.1.1.ebuild172
2 files changed, 173 insertions, 0 deletions
diff --git a/dev-lang/php/files/digest-php-4.1.1 b/dev-lang/php/files/digest-php-4.1.1
new file mode 100644
index 000000000000..9673f2e64d60
--- /dev/null
+++ b/dev-lang/php/files/digest-php-4.1.1
@@ -0,0 +1 @@
+MD5 776362ff53bf6ea77b60496f6632b6b6 php-4.1.1.tar.gz 3362816
diff --git a/dev-lang/php/php-4.1.1.ebuild b/dev-lang/php/php-4.1.1.ebuild
new file mode 100644
index 000000000000..4439f7dff1d2
--- /dev/null
+++ b/dev-lang/php/php-4.1.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.1.1.ebuild,v 1.1 2002/01/03 15:50:25 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML embedded scripting language"
+SRC_URI="http://www.php.net/distributions/${P}.tar.gz"
+HOMEPAGE="http://www.php.net/"
+
+DEPEND="virtual/glibc
+
+ >=dev-libs/gmp-3.1.1
+ ~media-libs/freetype-1.3.1
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.7
+ >=media-libs/libgd-1.8.3
+ >=media-libs/t1lib-1.0.1
+ >=net-www/apache-1.3
+ pam? ( >=sys-libs/pam-0.75 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ gettext? ( sys-devel/gettext )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ X? ( virtual/x11 )
+ qt? ( >=x11-libs/qt-2.3.0 )
+ xml? ( >=app-text/sablotron-0.44 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ imap? ( virtual/imap )
+ flash? ( media-libs/libswf media-libs/ming )
+ xml2? ( dev-libs/libxml2 )
+ java? ( virtual/jdk )"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/gmp-3.1.1
+ ~media-libs/freetype-1.3.1
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.7
+ >=media-libs/t1lib-1.0.1
+ >=net-www/apache-1.3
+ pam? ( >=sys-libs/pam-0.75 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ X? ( virtual/x11 )
+ qt? ( >=x11-libs/qt-2.3.0 )
+ xml? ( >=app-text/sablotron-0.44 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ xml2? ( dev-libs/libxml2 )
+ imap? ( virtual/imap )
+ java? ( virtual/jdk )"
+
+src_compile() {
+
+ local myconf
+ # readline can only be used w/ CGI build, so I'll turn it off
+ #if [ "`use readline`" ] ; then
+ # myconf="--with-readline"
+ #fi
+ # also, t1lib support seems to be broken: gcc: /usr/lib/.libs/libt1.so: No such file or directory
+ myconf="--without-readline --without-t1lib"
+ if [ "`use pam`" ] ; then
+ myconf="$myconf --with-pam"
+ fi
+ if [ "`use gettext`" ] ; then
+ myconf="$myconf --with-gettext"
+ fi
+ if [ "`use gdbm`" ] ; then
+ myconf="$myconf --with-gdbm=/usr"
+ fi
+ if [ "`use berkdb`" ] ; then
+ myconf="$myconf --with-db3=/usr"
+ fi
+ if [ "`use mysql`" ] ; then
+ myconf="$myconf --with-mysql=/usr"
+ fi
+ if [ "`use postgres`" ] ; then
+ myconf="$myconf --with-pgsql=/usr"
+ fi
+ if [ "`use odbc`" ] ; then
+ myconf="$myconf --with-unixODBC=/usr"
+ fi
+ if [ "`use ldap`" ] ; then
+ myconf="$myconf --with-ldap"
+ fi
+ if [ "`use qt`" ] ; then
+ EXPORT QTDIR=/usr/qt/2 #hope this helps - danarmak
+ myconf="$myconf --with-qtdom"
+ fi
+ if [ "`use imap`" ] ; then
+ myconf="$myconf --with-imap"
+ fi
+ if [ "`use libwww`" ] ; then
+ myconf="$myconf --with-xml"
+ else
+ myconf="$myconf --disable-xml"
+ fi
+ if [ "`use flash`" ] ; then
+ myconf="$myconf --with-swf=/usr --with-ming=/usr"
+ fi
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="$myconf --with-sablot=/usr"
+ fi
+ if [ "`use xml2`" ] ; then
+ myconf="$myconf --with-dom"
+ fi
+ if [ "`use java`" ] ; then
+ myconf="$myconf --with-java=/opt/java"
+ fi
+
+ LDFLAGS="$LDFLAGS -ltiff -ljpeg"
+
+ if [ "`use X`" ] ; then
+ myconf="$myconf --with-xpm-dir=/usr/X11R6"
+ LDFLAGS="$LDFLAGS -L/usr/X11R6/lib"
+ fi
+
+
+
+ ./configure --enable-safe-mode --enable-ftp --enable-track-vars --with-gmp \
+ --enable-dbase --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
+ --enable-calendar --enable-versioning --enable-inline-optimization --enable-trans-sid \
+ --with-gd --with-ttf --with-t1lib --with-jpeg-dir=/usr/lib --prefix=/usr \
+ --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` --host=${CHOST} \
+ --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" $myconf || die
+ make || die
+}
+
+
+src_install() {
+
+ make INSTALL_ROOT=${D} install-pear || die
+ dodir /usr/lib/apache
+ cp .libs/libphp4.so ${D}/usr/lib/apache
+
+ dodir /etc/httpd
+ cp php.ini-dist ${D}/etc/httpd/php.ini
+ dodoc CODING_STANDARDS LICENSE EXTENSIONS
+ dodoc RELEASE_PROCESS README.* TODO NEWS
+ dodoc ChangeLog* *.txt
+}
+
+pkg_config() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ if [ -f "${ROOT}/etc/httpd/httpd.conf" ]
+ then
+
+ # Activate PHP-Extension in httpd.conf
+ echo "Activate PHP in httpd.conf..."
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
+ -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
+ -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
+ -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+
+ fi
+}
+
+
+