summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-10 02:34:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-10 02:34:51 +0000
commit3a84dd27f9ef4ffb34fe1c0771fdb585a5f5308a (patch)
tree62ad31db9ce58894f400698682a9df9ae9c440ac /dev-libs/DirectFB
parentModified gpgme dependancy in preparation of stabilisation (Manifest recommit) (diff)
downloadgentoo-2-3a84dd27f9ef4ffb34fe1c0771fdb585a5f5308a.tar.gz
gentoo-2-3a84dd27f9ef4ffb34fe1c0771fdb585a5f5308a.tar.bz2
gentoo-2-3a84dd27f9ef4ffb34fe1c0771fdb585a5f5308a.zip
dont let broken sdl break stuff #61592
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog7
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild34
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.20.ebuild100
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.201
4 files changed, 27 insertions, 115 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index 10591bc12f5e..72b42e923a51 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.42 2004/08/12 07:09:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.43 2004/09/10 02:34:51 vapier Exp $
+
+ 09 Sep 2004; Mike Frysinger <vapier@gentoo.org> DirectFB-0.9.20-r1.ebuild,
+ -DirectFB-0.9.20.ebuild:
+ Add detection to prevent circular dependency causing build failures #61592 by
+ Anton Starikov.
*DirectFB-0.9.20-r1 (12 Aug 2004)
diff --git a/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
index 910899934711..2bd376019741 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild,v 1.1 2004/08/12 07:09:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20-r1.ebuild,v 1.2 2004/09/10 02:34:51 vapier Exp $
-inherit eutils 64-bit
+inherit eutils 64-bit flag-o-matic gcc
IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 matrox neomagic nsc nvidia radeon savage tdfx"
@@ -13,9 +13,10 @@ SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ppc -sparc alpha hppa ia64 -mips amd64"
-IUSE="jpeg gif png truetype mpeg mmx sse fusion"
+IUSE="sdl jpeg gif png truetype mpeg mmx sse fusion debug fbcon static"
DEPEND="dev-lang/perl
+ sdl? ( media-libs/libsdl )
gif? ( media-libs/giflib )
png? ( media-libs/libpng )
jpeg? ( media-libs/jpeg )
@@ -51,11 +52,7 @@ src_unpack() {
}
src_compile() {
- local vidcards
- local card
- local mycppflags
- local myconf
-
+ local vidcards card
for card in ${VIDEO_CARDS} ; do
has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
done
@@ -63,11 +60,20 @@ src_compile() {
&& vidcards="all" \
|| vidcards="${vidcards:1}"
- use mpeg && mycppflags="-I/usr/include/libmpeg3"
- if use amd64 ; then
- myconf="--enable-mmx --enable-sse"
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(gcc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
fi
- econf CPPFLAGS="${mycppflags}" \
+
+ use mpeg && export CPPFLAGS="${CPPFLAGS} -I/usr/include/libmpeg3"
+ econf \
+ $(use_enable fbcon fbdev) \
$(use_enable mmx) \
$(use_enable sse) \
$(use_enable mpeg libmpeg3) \
@@ -76,7 +82,9 @@ src_compile() {
$(use_enable gif) \
$(use_enable truetype freetype) \
$(use_enable fusion multi) \
- ${myconf} \
+ $(use_enable debug) \
+ $(use_enable static) \
+ ${sdlconf} \
--with-gfxdrivers="${vidcards}" \
|| die
diff --git a/dev-libs/DirectFB/DirectFB-0.9.20.ebuild b/dev-libs/DirectFB/DirectFB-0.9.20.ebuild
deleted file mode 100644
index 4231377591cc..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.20.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.20.ebuild,v 1.16 2004/06/24 23:05:08 agriffis Exp $
-
-inherit eutils 64-bit
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 matrox neomagic nsc nvidia radeon savage tdfx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 ppc -sparc alpha hppa ia64 -mips amd64"
-IUSE="jpeg gif png truetype mpeg mmx sse fusion"
-
-DEPEND="dev-lang/perl
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mpeg? ( media-libs/libmpeg3 )
- truetype? ( >=media-libs/freetype-2.0.1 )"
-
-pkg_setup() {
- if [ -z "${VIDEO_CARDS}" ] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- einfo "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-linux-2.6.patch
-
- # This patch changes ints to longs where appropriate
- 64-bit && epatch ${FILESDIR}/DirectFB-0.9.20-64bit.diff
-
- # This patch enables simd optimisations for amd64. Since mmx and sse are
- # masked USE flags on amd64 due to their enabling x86 specific asm more
- # often than not, we'll just enable them by default. All x86_64 cpus
- # should support mmx and see. Travis Tilley <lv@gentoo.org>
- use amd64 && epatch ${FILESDIR}/DirectFB-0.9.20-simd-amd64.diff
-
- sed -i 's:wm97xx_ts=yes:wm97xx_ts=no:' configure #36924
-}
-
-src_compile() {
- local vidcards
- local card
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- done
- [ -z "${vidcards}" ] \
- && vidcards="all" \
- || vidcards="${vidcards:1}"
-
- local mycppflags
- use mpeg && mycppflags="-I/usr/include/libmpeg3"
- econf CPPFLAGS="${mycppflags}" \
- `use_enable mmx` \
- `use_enable sse` \
- `use_enable amd64 mmx` \
- `use_enable amd64 sse` \
- `use_enable mpeg libmpeg3` \
- `use_enable jpeg` \
- `use_enable png` \
- `use_enable gif` \
- `use_enable truetype freetype` \
- `use_enable fusion multi` \
- --with-gfxdrivers="${vidcards}" \
- || die
-
- use mpeg && \
- sed -i \
- s':#include <libmpeg3.h>:#include <libmpeg3/libmpeg3.h>:' \
- ${S}/interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_libmpeg3.c
-
- # add extra -lstdc++ so libpng/libflash link correctly
- make CPPFLAGS="${mycppflags}" LDFLAGS="${LDFLAGS} -lstdc++" || die
-}
-
-src_install() {
- insinto /etc
- doins fb.modes
-
- make DESTDIR=${D} install || die
-
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \`revdep-rebuild\` which can be"
- ewarn "found by emerging the package 'gentoolkit'."
-}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.20 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.20
deleted file mode 100644
index 439811397232..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.20
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e42e8ae43f0ad873643f73cc0a9ae7d0 DirectFB-0.9.20.tar.gz 1307323