summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-06-13 08:43:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-06-13 08:43:39 +0000
commit5b06cb870a64eeab49ed8e0c6944872587c4bf90 (patch)
tree53077516ddebaac3cdadb43052cc2a2372f9756a /dev-libs/bitset
parentBump (diff)
downloadgentoo-2-5b06cb870a64eeab49ed8e0c6944872587c4bf90.tar.gz
gentoo-2-5b06cb870a64eeab49ed8e0c6944872587c4bf90.tar.bz2
gentoo-2-5b06cb870a64eeab49ed8e0c6944872587c4bf90.zip
Properly handle 'minimal' USE-flag for dev-util/google-perftools dependency
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/bitset')
-rw-r--r--dev-libs/bitset/ChangeLog6
-rw-r--r--dev-libs/bitset/bitset-2.8.3.ebuild4
-rw-r--r--dev-libs/bitset/bitset-2.8.4.ebuild7
3 files changed, 12 insertions, 5 deletions
diff --git a/dev-libs/bitset/ChangeLog b/dev-libs/bitset/ChangeLog
index 4ac0026d2999..84676fc58d47 100644
--- a/dev-libs/bitset/ChangeLog
+++ b/dev-libs/bitset/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/bitset
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.7 2013/06/13 00:50:14 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/ChangeLog,v 1.8 2013/06/13 08:43:39 pinkbyte Exp $
+
+ 13 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> bitset-2.8.3.ebuild,
+ bitset-2.8.4.ebuild:
+ Properly handle 'minimal' USE-flag for dev-util/google-perftools dependency
*bitset-2.8.4 (13 Jun 2013)
diff --git a/dev-libs/bitset/bitset-2.8.3.ebuild b/dev-libs/bitset/bitset-2.8.3.ebuild
index a6fd83b0c1d9..2c84a88bb7f4 100644
--- a/dev-libs/bitset/bitset-2.8.3.ebuild
+++ b/dev-libs/bitset/bitset-2.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.3.ebuild,v 1.3 2013/04/15 08:51:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.3.ebuild,v 1.4 2013/06/13 08:43:38 pinkbyte Exp $
EAPI="5"
@@ -16,7 +16,7 @@ SLOT="0"
IUSE="jemalloc static-libs tcmalloc"
KEYWORDS="amd64 x86"
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
+RDEPEND="tcmalloc? ( dev-util/google-perftools[-minimal] )
jemalloc? ( >=dev-libs/jemalloc-3.2 )"
DEPEND="${RDEPEND}"
diff --git a/dev-libs/bitset/bitset-2.8.4.ebuild b/dev-libs/bitset/bitset-2.8.4.ebuild
index e76b6191d6c3..3f62fcf25cae 100644
--- a/dev-libs/bitset/bitset-2.8.4.ebuild
+++ b/dev-libs/bitset/bitset-2.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.4.ebuild,v 1.1 2013/06/13 00:50:14 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/bitset/bitset-2.8.4.ebuild,v 1.2 2013/06/13 08:43:39 pinkbyte Exp $
EAPI="5"
@@ -25,9 +25,12 @@ REQUIRED_USE="?? ( jemalloc tcmalloc )"
DOCS=( README.md )
src_configure() {
+ local tcmalloc_lib_name='tcmalloc'
+ has_version dev-util/google-perftools[minimal] && tcmalloc_lib_name='tcmalloc_minimal'
local myeconfargs=(
$(use_with jemalloc) \
- $(use_with tcmalloc)
+ $(use_with tcmalloc) \
+ $(use_with tcmalloc tcmalloc-lib "${tcmalloc_lib_name}")
)
autotools-utils_src_configure
}