summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-19 13:47:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-19 13:47:24 +0000
commitb4e04ec944b8c2b881169ce88ed1400acd8f0ba0 (patch)
tree25466dc7a5a607d626500697d59f67ae4d1fba79 /dev-libs/blitz/files
parentMarked stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-b4e04ec944b8c2b881169ce88ed1400acd8f0ba0.tar.gz
gentoo-2-b4e04ec944b8c2b881169ce88ed1400acd8f0ba0.tar.bz2
gentoo-2-b4e04ec944b8c2b881169ce88ed1400acd8f0ba0.zip
version bump thanks to Andy <andyreif@studcs.uni-sb.de> in bug #71678
Diffstat (limited to 'dev-libs/blitz/files')
-rw-r--r--dev-libs/blitz/files/blitz-0.8-makefile.patch221
-rw-r--r--dev-libs/blitz/files/digest-blitz-0.81
2 files changed, 222 insertions, 0 deletions
diff --git a/dev-libs/blitz/files/blitz-0.8-makefile.patch b/dev-libs/blitz/files/blitz-0.8-makefile.patch
new file mode 100644
index 000000000000..e1542db67bcb
--- /dev/null
+++ b/dev-libs/blitz/files/blitz-0.8-makefile.patch
@@ -0,0 +1,221 @@
+--- doc/doxygen/Makefile.am.orig 2004-11-19 22:47:59.269861928 +0930
++++ doc/doxygen/Makefile.am 2004-11-19 22:51:53.094977624 +0930
+@@ -76,20 +76,20 @@
+ # Install hooks
+ make-install-dirs:
+ @if test '!' -d $(docdir) ; \
+- then mkdir -p $(docdir) ; \
++ then mkdir -p $(DESTDIR)$(docdir) ; \
+ fi
+
+ install-data-hook: make-install-dirs
+ @if test -d html; then \
+- echo Installing documentations into $(docdir) ; \
+- $(INSTALL_DATA) html/* $(docdir) ; \
++ echo Installing documentations into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) html/* $(DESTDIR)$(docdir) ; \
+ fi
+ @if test -f $(PACKAGE).pdf; then \
+- echo Installing PDF manual into $(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).pdf $(docdir) ; \
++ echo Installing PDF manual into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).pdf $(DESTDIR)$(docdir) ; \
+ fi
+ @if test -f $(PACKAGE).ps; then \
+- echo Installing PS manual into $(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).ps $(docdir) ; \
++ echo Installing PS manual into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).ps $(DESTDIR)$(docdir) ; \
+ fi
+
+--- doc/doxygen/Makefile.in.orig 2004-11-19 22:48:07.721022440 +0930
++++ doc/doxygen/Makefile.in 2004-11-19 22:59:15.847113320 +0930
+@@ -1,4 +1,4 @@
+-# Makefile.in generated by automake 1.8.3 from Makefile.am.
++# Makefile.in generated by automake 1.8.5 from Makefile.am.
+ # @configure_input@
+
+ # Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+@@ -40,72 +40,7 @@
+ DIST_COMMON = $(srcdir)/Doxyfile.in $(srcdir)/Makefile.am \
+ $(srcdir)/Makefile.in
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+-am__aclocal_m4_deps = $(top_srcdir)/m4/ac_check_cxx_features.m4 \
+- $(top_srcdir)/m4/ac_compiler_specific_header.m4 \
+- $(top_srcdir)/m4/ac_compilers_64bits.m4 \
+- $(top_srcdir)/m4/ac_cxx_bool.m4 \
+- $(top_srcdir)/m4/ac_cxx_complex_math_in_namespace_std.m4 \
+- $(top_srcdir)/m4/ac_cxx_const_cast.m4 \
+- $(top_srcdir)/m4/ac_cxx_default_template_parameters.m4 \
+- $(top_srcdir)/m4/ac_cxx_dynamic_cast.m4 \
+- $(top_srcdir)/m4/ac_cxx_enable_debug.m4 \
+- $(top_srcdir)/m4/ac_cxx_enable_optimize.m4 \
+- $(top_srcdir)/m4/ac_cxx_enum_computations.m4 \
+- $(top_srcdir)/m4/ac_cxx_enum_computations_with_cast.m4 \
+- $(top_srcdir)/m4/ac_cxx_exceptions.m4 \
+- $(top_srcdir)/m4/ac_cxx_explicit.m4 \
+- $(top_srcdir)/m4/ac_cxx_explicit_template_function_qualification.m4 \
+- $(top_srcdir)/m4/ac_cxx_flags_preset.m4 \
+- $(top_srcdir)/m4/ac_cxx_full_specialization_syntax.m4 \
+- $(top_srcdir)/m4/ac_cxx_function_nontype_parameters.m4 \
+- $(top_srcdir)/m4/ac_cxx_general.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_climits.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_complex.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_complex_fcns.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_complex_math1.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_complex_math2.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_ieee_math.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_numeric_limits.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_rusage.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_std.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_stl.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_system_v_math.m4 \
+- $(top_srcdir)/m4/ac_cxx_have_valarray.m4 \
+- $(top_srcdir)/m4/ac_cxx_keywords.m4 \
+- $(top_srcdir)/m4/ac_cxx_math_fn_in_namespace_std.m4 \
+- $(top_srcdir)/m4/ac_cxx_member_constants.m4 \
+- $(top_srcdir)/m4/ac_cxx_member_templates.m4 \
+- $(top_srcdir)/m4/ac_cxx_member_templates_outside_class.m4 \
+- $(top_srcdir)/m4/ac_cxx_mutable.m4 \
+- $(top_srcdir)/m4/ac_cxx_namespaces.m4 \
+- $(top_srcdir)/m4/ac_cxx_nceg_restrict.m4 \
+- $(top_srcdir)/m4/ac_cxx_nceg_restrict_egcs.m4 \
+- $(top_srcdir)/m4/ac_cxx_old_for_scoping.m4 \
+- $(top_srcdir)/m4/ac_cxx_partial_ordering.m4 \
+- $(top_srcdir)/m4/ac_cxx_partial_specialization.m4 \
+- $(top_srcdir)/m4/ac_cxx_reinterpret_cast.m4 \
+- $(top_srcdir)/m4/ac_cxx_rtti.m4 \
+- $(top_srcdir)/m4/ac_cxx_standard_library.m4 \
+- $(top_srcdir)/m4/ac_cxx_static_cast.m4 \
+- $(top_srcdir)/m4/ac_cxx_template_keyword_qualifier.m4 \
+- $(top_srcdir)/m4/ac_cxx_template_qualified_base_class.m4 \
+- $(top_srcdir)/m4/ac_cxx_template_qualified_return_type.m4 \
+- $(top_srcdir)/m4/ac_cxx_template_scoped_argument_matching.m4 \
+- $(top_srcdir)/m4/ac_cxx_templates.m4 \
+- $(top_srcdir)/m4/ac_cxx_templates_as_template_arguments.m4 \
+- $(top_srcdir)/m4/ac_cxx_templates_features.m4 \
+- $(top_srcdir)/m4/ac_cxx_type_casts.m4 \
+- $(top_srcdir)/m4/ac_cxx_type_promotion.m4 \
+- $(top_srcdir)/m4/ac_cxx_typename.m4 \
+- $(top_srcdir)/m4/ac_cxx_use_numtrait.m4 \
+- $(top_srcdir)/m4/ac_env.m4 \
+- $(top_srcdir)/m4/ac_fortran_flags_preset.m4 \
+- $(top_srcdir)/m4/ac_info.m4 $(top_srcdir)/m4/ac_lib_blas.m4 \
+- $(top_srcdir)/m4/ac_prog_doxygen.m4 \
+- $(top_srcdir)/m4/ax_create_pkgconfig_info.m4 \
+- $(top_srcdir)/m4/ax_dirname.m4 \
+- $(top_srcdir)/m4/ax_prefix_config_h.m4 \
+- $(top_srcdir)/configure.ac
++am__aclocal_m4_deps = $(top_srcdir)/configure.ac
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+ mkinstalldirs = $(mkdir_p)
+@@ -119,36 +54,22 @@
+ AMDEP_TRUE = @AMDEP_TRUE@
+ AMTAR = @AMTAR@
+ AR = @AR@
+-AR_FLAGS = @AR_FLAGS@
+ AUTOCONF = @AUTOCONF@
+ AUTOHEADER = @AUTOHEADER@
+ AUTOMAKE = @AUTOMAKE@
+ AWK = @AWK@
+-BLASLIB = @BLASLIB@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+-COMPILER_SPECIFIC_HEADER = @COMPILER_SPECIFIC_HEADER@
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+ CXXCPP = @CXXCPP@
+ CXXDEPMODE = @CXXDEPMODE@
+-CXXFCFLAG = @CXXFCFLAG@
+-CXXFFLAGS = @CXXFFLAGS@
+ CXXFLAGS = @CXXFLAGS@
+-CXX_DEBUG_FLAGS = @CXX_DEBUG_FLAGS@
+-CXX_LIBS = @CXX_LIBS@
+-CXX_OPTIMIZE_FLAGS = @CXX_OPTIMIZE_FLAGS@
+-CXX_PROFIL_FLAGS = @CXX_PROFIL_FLAGS@
+ CYGPATH_W = @CYGPATH_W@
+-DATE = @DATE@
+ DEFS = @DEFS@
+ DEPDIR = @DEPDIR@
+-DOT = @DOT@
+-DOXYGEN = @DOXYGEN@
+-DOXYGEN_DOC_FALSE = @DOXYGEN_DOC_FALSE@
+-DOXYGEN_DOC_TRUE = @DOXYGEN_DOC_TRUE@
+ ECHO = @ECHO@
+ ECHO_C = @ECHO_C@
+ ECHO_N = @ECHO_N@
+@@ -156,15 +77,10 @@
+ EGREP = @EGREP@
+ EXEEXT = @EXEEXT@
+ F77 = @F77@
+-F77_OPTIMIZE_FLAGS = @F77_OPTIMIZE_FLAGS@
+-F90_COMPILER_FALSE = @F90_COMPILER_FALSE@
+-F90_COMPILER_TRUE = @F90_COMPILER_TRUE@
+ FC = @FC@
+ FCFLAGS = @FCFLAGS@
+ FCFLAGS_f90 = @FCFLAGS_f90@
+-FC_OPTIMIZE_FLAGS = @FC_OPTIMIZE_FLAGS@
+ FFLAGS = @FFLAGS@
+-FORTLIBS = @FORTLIBS@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+@@ -180,7 +96,6 @@
+ MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
+ MAKEINFO = @MAKEINFO@
+ OBJEXT = @OBJEXT@
+-OS = @OS@
+ PACKAGE = @PACKAGE@
+ PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+ PACKAGE_NAME = @PACKAGE_NAME@
+@@ -214,9 +129,6 @@
+ build_os = @build_os@
+ build_vendor = @build_vendor@
+ datadir = @datadir@
+-enable_dot = @enable_dot@
+-enable_html_docs = @enable_html_docs@
+-enable_latex_docs = @enable_latex_docs@
+ exec_prefix = @exec_prefix@
+ host = @host@
+ host_alias = @host_alias@
+@@ -232,8 +144,6 @@
+ mandir = @mandir@
+ mkdir_p = @mkdir_p@
+ oldincludedir = @oldincludedir@
+-pkgconfig_libdir = @pkgconfig_libdir@
+-pkgconfig_libfile = @pkgconfig_libfile@
+ prefix = @prefix@
+ program_transform_name = @program_transform_name@
+ sbindir = @sbindir@
+@@ -475,21 +385,21 @@
+ # Install hooks
+ make-install-dirs:
+ @if test '!' -d $(docdir) ; \
+- then mkdir -p $(docdir) ; \
++ then mkdir -p $(DESTDIR)$(docdir) ; \
+ fi
+
+ install-data-hook: make-install-dirs
+ @if test -d html; then \
+- echo Installing documentations into $(docdir) ; \
+- $(INSTALL_DATA) html/* $(docdir) ; \
++ echo Installing documentations into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) html/* $(DESTDIR)$(docdir) ; \
+ fi
+ @if test -f $(PACKAGE).pdf; then \
+- echo Installing PDF manual into $(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).pdf $(docdir) ; \
++ echo Installing PDF manual into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).pdf $(DESTDIR)$(docdir) ; \
+ fi
+ @if test -f $(PACKAGE).ps; then \
+- echo Installing PS manual into $(docdir) ; \
+- $(INSTALL_DATA) $(PACKAGE).ps $(docdir) ; \
++ echo Installing PS manual into $(DESTDIR)$(docdir) ; \
++ $(INSTALL_DATA) $(PACKAGE).ps $(DESTDIR)$(docdir) ; \
+ fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/dev-libs/blitz/files/digest-blitz-0.8 b/dev-libs/blitz/files/digest-blitz-0.8
new file mode 100644
index 000000000000..76305ed2e1b1
--- /dev/null
+++ b/dev-libs/blitz/files/digest-blitz-0.8
@@ -0,0 +1 @@
+MD5 358cdd8716de5d615f91df660f1c92d9 blitz-0.8.tar.gz 2729167