summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-04-07 10:57:06 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-04-07 10:57:06 +0000
commitbd973e79423382030846b9e086027ca5c4b74b00 (patch)
treeaa24cad7c759ed5625d00728662223a82988cc83 /dev-libs/boost/boost-1.54.0-r1.ebuild
parentAdd support for user patches via epatch_user (diff)
downloadgentoo-2-bd973e79423382030846b9e086027ca5c4b74b00.tar.gz
gentoo-2-bd973e79423382030846b9e086027ca5c4b74b00.tar.bz2
gentoo-2-bd973e79423382030846b9e086027ca5c4b74b00.zip
Fix parallel compilation with high number of MAKEOPTS jobs, wrt bugs #506064 and #498134
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/boost/boost-1.54.0-r1.ebuild')
-rw-r--r--dev-libs/boost/boost-1.54.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-libs/boost/boost-1.54.0-r1.ebuild b/dev-libs/boost/boost-1.54.0-r1.ebuild
index 2c5c970f7894..dc949afb6532 100644
--- a/dev-libs/boost/boost-1.54.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.54.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0-r1.ebuild,v 1.2 2014/04/07 10:17:50 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0-r1.ebuild,v 1.3 2014/04/07 10:57:06 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -92,6 +92,9 @@ ejam() {
}
src_configure() {
+ # Workaround for too many parallel processes requested, bug #506064
+ [ "$(makeopts_jobs)" -gt 64 ] && MAKEOPTS="${MAKEOPTS} -j64"
+
OPTIONS="$(usex debug gentoodebug gentoorelease) -j$(makeopts_jobs) -q -d+2 --user-config=${S}/user-config.jam"
if [[ ${CHOST} == *-darwin* ]]; then