summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-03-03 12:19:36 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-03-03 12:19:36 +0000
commit7504f66fffe833c11eba783be7ac364f59b7cc88 (patch)
tree394970f46d76e39a4d6b2706e2c9c810ac213d84 /dev-libs/boost
parentstable x86, bug 299419 (diff)
downloadgentoo-2-7504f66fffe833c11eba783be7ac364f59b7cc88.tar.gz
gentoo-2-7504f66fffe833c11eba783be7ac364f59b7cc88.tar.bz2
gentoo-2-7504f66fffe833c11eba783be7ac364f59b7cc88.zip
Fix bug 298489 in dev-libs/boost-1.41.0-r3.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.41.0-r3.ebuild20
2 files changed, 18 insertions, 7 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index efab3da8fb2e..d50fa59e2212 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.186 2010/03/03 10:57:57 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.187 2010/03/03 12:19:36 djc Exp $
+
+ 03 Mar 2010; Dirkjan Ochtman <djc@gentoo.org> boost-1.41.0-r3.ebuild:
+ Fix bug 298489 in boost-1.41.0-r3.
03 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
boost-1.41.0-r3.ebuild:
diff --git a/dev-libs/boost/boost-1.41.0-r3.ebuild b/dev-libs/boost/boost-1.41.0-r3.ebuild
index 0c7b4a000b47..8e2ae961c760 100644
--- a/dev-libs/boost/boost-1.41.0-r3.ebuild
+++ b/dev-libs/boost/boost-1.41.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.2 2010/03/03 10:57:57 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.41.0-r3.ebuild,v 1.3 2010/03/03 12:19:36 djc Exp $
EAPI="2"
@@ -134,6 +134,11 @@ src_configure() {
# Using -fno-strict-aliasing to prevent possible creation of invalid code.
append-flags -fno-strict-aliasing
+ # bug 298489
+ if use ppc || use ppc64 ; then
+ [[ $(gcc-version) > 4.3 ]] && append-flags -mno-altivec
+ fi;
+
use mpi && mpi="using mpi ;"
if use python ; then
@@ -174,7 +179,7 @@ __EOF__
OPTIONS="${OPTIONS} --disable-long-double"
fi
- OPTIONS="${OPTIONS} --user-config=\"${S}/user-config.jam\" --boost-build=/usr/share/boost-build-${MAJOR_PV} --prefix=\"${D}/usr\" --layout=versioned"
+ OPTIONS="${OPTIONS} pch=off --user-config=\"${S}/user-config.jam\" --boost-build=/usr/share/boost-build-${MAJOR_PV} --prefix=\"${D}/usr\" --layout=versioned"
}
@@ -369,7 +374,7 @@ src_install () {
cd "${S}/status"
if [ -f regress.log ] ; then
docinto status
- dohtml *.{html,gif} ../boost.png
+ dohtml *.html ../boost.png
dodoc regress.log
fi
@@ -437,7 +442,7 @@ src_test() {
--dump-tests 2>&1 | tee regress.log
# Postprocessing
- cat regress.log | "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/process_jam_log" --v2
+ cat regress.log | "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/process_jam_log" --v2
if test $? != 0 ; then
die "Postprocessing the build log failed"
fi
@@ -447,7 +452,7 @@ src_test() {
__EOF__
# Generate the build log html summary page
- "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/compiler_status" --v2 \
+ "${S}/tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/compiler_status" --v2 \
--comment "${S}/status/comment.html" "${S}" \
cs-$(uname).html cs-$(uname)-links.html
if test $? != 0 ; then
@@ -459,7 +464,10 @@ __EOF__
}
pkg_postinst() {
- use eselect && eselect boost update
+ if use eselect ; then
+ eselect boost update || ewarn "eselect boost update failed."
+ fi
+
if [ ! -h "${ROOT}/etc/eselect/boost/active" ] ; then
elog "No active boost version found. Calling eselect to select one..."
eselect boost update