summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-09-30 23:15:22 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-09-30 23:15:22 +0000
commit9c892bb87b450054efc8810a725f408a0ca877de (patch)
tree1226aab9dd750864ea0d3856eb3e8c89775116fb /dev-libs/boost
parentMasking version 1.34* of dev-libs/boost for testing (diff)
downloadgentoo-2-9c892bb87b450054efc8810a725f408a0ca877de.tar.gz
gentoo-2-9c892bb87b450054efc8810a725f408a0ca877de.tar.bz2
gentoo-2-9c892bb87b450054efc8810a725f408a0ca877de.zip
Added dev-libs/boost-1.34 snapshot for testing
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.34_pre20060930.ebuild212
-rw-r--r--dev-libs/boost/files/digest-boost-1.34_pre200609303
-rw-r--r--dev-libs/boost/metadata.xml4
4 files changed, 223 insertions, 1 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 7582b8bec9a6..5600be81f4a9 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.89 2006/07/21 02:34:06 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.90 2006/09/30 23:15:22 dev-zero Exp $
+
+ 30 Sep 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ Snapshot for 1.34 added for testing
20 Jul 2006; <psi29a@gentoo.org> boost-1.33.1.ebuild:
stable on mips
diff --git a/dev-libs/boost/boost-1.34_pre20060930.ebuild b/dev-libs/boost/boost-1.34_pre20060930.ebuild
new file mode 100644
index 000000000000..73e57a48a908
--- /dev/null
+++ b/dev-libs/boost/boost-1.34_pre20060930.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20060930.ebuild,v 1.1 2006/09/30 23:15:22 dev-zero Exp $
+
+inherit python distutils multilib eutils versionator
+
+MY_P=${PN}_$(replace_all_version_separators _)
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="1"
+KEYWORDS="~x86"
+IUSE="bcp bjam debug doc icu pyste static threads threadsonly"
+
+DEPEND="icu? ( dev-libs/icu )"
+RDEPEND="${DEPEND}
+ pyste? ( dev-cpp/gccxml dev-python/elementtree )"
+
+S=${WORKDIR}/${MY_P}
+
+# NOTE: Before unmasking this release, there are some unresolved issues:
+# - pre-stripped files
+# - Check whether the threading-patch for alpha is still needed
+# - Check the LICENSE, upstream updated a lot and changed licenses
+# - possibility to add a separate boost-build package and depend on it
+# - possibility to split out boost.python
+# - gccxml which is needed by pyste is broken with gcc-4.1.1, bug #147976
+# - This version doesn't block boost-jam anymore as preparation for it's removal
+
+pkg_setup() {
+ BOOSTJAM="${S}/tools/jam/src/bin.*/bjam"
+
+ # Just make sure that we only get the '-j [0-9]+' part from MAKEOPTS
+ NUMJOBS=$(echo ${MAKEOPTS} | sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/')
+
+ python_version
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if [ "${ARCH}" == "ppc-macos" ] ; then
+ BOOST_TOOLSET="darwin"
+ TOOLSET_NAME="darwin"
+ SOSUFFIX="dylib"
+ else
+ BOOST_TOOLSET="gcc"
+ TOOLSET_NAME="gcc"
+ SOSUFFIX="so"
+ fi
+
+ if use static ; then
+ BUILD="release <runtime-link>static"
+ else
+ BUILD="release <runtime-link>dynamic"
+ fi
+
+ if use debug ; then
+ BUILD="${BUILD} debug"
+ fi
+
+ if use threads && use threadsonly ; then
+ BUILD="${BUILD} <threading>multi"
+ fi
+
+ if use threads && ! use threadsonly ; then
+ BUILD="${BUILD} <threading>single/multi"
+ fi
+
+ if ! use threads ; then
+ BUILD="${BUILD} <threading>single"
+ fi
+
+ if use icu ; then
+ ADDITIONAL_OPTIONS="-sHAVE_ICU=1 -sICU_PATH=/usr"
+ fi
+
+}
+
+src_compile() {
+ cd "${S}/tools/jam/src"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+
+ cd "${S}"
+ #Fixing boost with threads on alpha. Thanks to ibm <imirkin@mit.edu>
+ #if use threads && [ "${ARCH}" == "alpha" ]; then
+ # epatch ${FILESDIR}/boost-alpha-threads.patch
+ #fi
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_compile
+ fi
+
+ if use bcp; then
+ cd "${S}/tools/bcp/"
+ ${BOOSTJAM} || die "Building bcp failed"
+ fi
+}
+
+src_install () {
+
+ cd "${S}/tools/build"
+ dodir /usr/share/boost-build
+ insinto /usr/share/boost-build
+ cp -pPR index.html v1/ v2/ "${D}/usr/share/boost-build" || die "failed to install docs"
+
+ cd "${S}"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix="${D}/usr" \
+ --layout=system \
+ install || die "Install failed"
+
+
+ dodoc README
+
+ if use doc ; then
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css \
+ -A pdf -r more-r people -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} "${D}/usr/share/doc/${PF}/html/{}" \;
+ fi
+
+ #and finally set "default" links to -gcc-mt versions
+ cd "${D}/usr/lib"
+
+ for fn in $(ls -1 *.${SOSUFFIX}| cut -d- -f1 | sort -u) ; do
+ if [ -f "$fn.${SOSUFFIX}" ] ; then
+ dosym "$fn.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-d.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.${SOSUFFIX}"
+ fi
+ done
+
+ for fn in $(ls -1 *.a| cut -d- -f1 | sort -u) ; do
+ if [ -f "$fn.a" ] ; then
+ dosym "$fn.a" "/usr/lib/$fn-${TOOLSET_NAME}.a"
+ fi
+ if [ -f "$fn-mt.a" ] ; then
+ dosym "$fn-mt.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt.a"
+ fi
+ if [ -f "$fn-d.a" ] ; then
+ dosym "$fn-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-d.a"
+ fi
+ if [ -f "$fn-mt-d.a" ] ; then
+ dosym "$fn-mt-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.a"
+ fi
+ done
+
+ [[ $(get_libdir) == "lib" ]] || mv "${D}/usr/lib" "${D}/usr/$(get_libdir)"
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_install
+ fi
+
+ if use bcp; then
+ dobin "${S}/tools/bcp/run/bcp" || die "bcp install failed"
+ fi
+
+ if use bjam; then
+ cd "${S}"/tools/jam/src/bin.*/
+ dobin bjam || die "bjam install failed"
+ fi
+}
diff --git a/dev-libs/boost/files/digest-boost-1.34_pre20060930 b/dev-libs/boost/files/digest-boost-1.34_pre20060930
new file mode 100644
index 000000000000..423035c277b1
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.34_pre20060930
@@ -0,0 +1,3 @@
+MD5 6c403a683e08b93945ac7fef5e089e85 boost_1_34_pre20060930.tar.bz2 12465498
+RMD160 ddf4c22efe379c3f620aca4d75012587f237b207 boost_1_34_pre20060930.tar.bz2 12465498
+SHA256 5f98f27309994f2d660bc763efef177c76954421f308748f732b2d62e35753ad boost_1_34_pre20060930.tar.bz2 12465498
diff --git a/dev-libs/boost/metadata.xml b/dev-libs/boost/metadata.xml
index 9986e749c7b5..b6498a4fc035 100644
--- a/dev-libs/boost/metadata.xml
+++ b/dev-libs/boost/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>cpp</herd>
+<maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+</maintainer>
<longdescription>
Boost is a free peer-reviewed portable C++ source libraries.
</longdescription>