summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-02-19 00:36:20 +0000
committerDonny Davies <woodchip@gentoo.org>2002-02-19 00:36:20 +0000
commit5086736e1fe3106a916a7a184224f2bbbc443ada (patch)
tree0b111a7f57dc825f913b6926c9d5a082a6397e1a /dev-libs/cyrus-sasl
parentsylpheed-claws 0.7.1 (diff)
downloadgentoo-2-5086736e1fe3106a916a7a184224f2bbbc443ada.tar.gz
gentoo-2-5086736e1fe3106a916a7a184224f2bbbc443ada.tar.bz2
gentoo-2-5086736e1fe3106a916a7a184224f2bbbc443ada.zip
initial checkin.
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog12
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild75
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.21-des.patch10
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.24-rpath.patch11
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.27-scram.patch19
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-configdir.patch244
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-saslauthd.patch199
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.271
-rw-r--r--dev-libs/cyrus-sasl/files/pwcheck.rc621
-rw-r--r--dev-libs/cyrus-sasl/files/saslauthd.confd20
-rw-r--r--dev-libs/cyrus-sasl/files/saslauthd.rc621
11 files changed, 633 insertions, 0 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
new file mode 100644
index 000000000000..ea33459db1ad
--- /dev/null
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-libs/cyrus-sasl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.1 2002/02/19 00:36:20 woodchip Exp $
+
+*cyrus-sasl-1.5.27 (18 Feb 2002)
+
+ 18 Feb 2002; Donny Davies <woodchip@gentoo.org>:
+
+ Initial checkin of this package. Postfix now compiles with this
+ library by default, and I have tested successfully with *outbound*
+ smtp authentication. Should you discover a bug, or any issues with
+ *inbound* authentication, lemme know.
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild
new file mode 100644
index 000000000000..e95cf931f27c
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild,v 1.1 2002/02/19 00:36:20 woodchip Exp $
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+DEPEND="virtual/glibc >=sys-libs/db-3.2 >=sys-libs/pam-0.75"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # some nice patches... thanks mandrake ;-)
+ patch -p1 < ${FILESDIR}/${PN}-1.5.21-des.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-configdir.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-saslauthd.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-1.5.24-rpath.patch || die
+ patch -p0 < ${FILESDIR}/${PN}-1.5.27-scram.patch || die
+ automake || die
+ autoconf || die
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --with-configdir=/etc/sasl \
+ --with-pwcheck=/var/lib/sasl \
+ --with-plugindir=/usr/lib/sasl \
+ --with-saslauthd=/var/lib/sasl \
+ --with-dbpath=/var/lib/sasl/sasl.db \
+ --with-des \
+ --with-rc4 \
+ --enable-pam \
+ --enable-anon \
+ --enable-cram \
+ --with-gnu-ld \
+ --enable-scram \
+ --enable-plain \
+ --enable-login \
+ --disable-krb4 \
+ --enable-static \
+ --enable-shared \
+ --without-mysql \
+ --enable-digest \
+ --disable-gssapi \
+ --disable-sample \
+ --with-dblib=berkeley \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING AUTHORS INSTALL NEWS README* TODO \
+ ChangeLog testing.txt doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
+
+pkg_postinst() {
+ # empty directories..
+ install -d -m0755 ${ROOT}/var/lib/sasl
+ install -d -m0755 ${ROOT}/etc/sasl
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.21-des.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.21-des.patch
new file mode 100644
index 000000000000..4d4fdea7d3ae
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.21-des.patch
@@ -0,0 +1,10 @@
+--- cyrus-sasl-1.5.21/configure.in Thu Jun 8 13:35:00 2000
++++ cyrus-sasl-1.5.21/configure.in Thu Jun 8 13:40:15 2000
+@@ -356,7 +356,6 @@
+
+ if test "$with_des" != no; then
+ AC_DEFINE(WITH_DES)
+- LIB_DES="-ldes"
+ fi
+
+ AC_SUBST(LIB_DES)
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.24-rpath.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.24-rpath.patch
new file mode 100644
index 000000000000..5fd8cfae2a6e
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.24-rpath.patch
@@ -0,0 +1,11 @@
+--- cyrus-sasl-1.5.24/aclocal.m4.fred Wed Jun 13 10:00:31 2001
++++ cyrus-sasl-1.5.24/aclocal.m4 Wed Jun 13 10:02:06 2001
+@@ -204,7 +204,7 @@
+ LDFLAGS="-R /usr/lib"
+ AC_TRY_LINK([],[],[andrew_runpath_switch="-R"], [
+ LDFLAGS="-Wl,-rpath,/usr/lib"
+- AC_TRY_LINK([],[],[andrew_runpath_switch="-Wl,-rpath,"],
++ AC_TRY_LINK([],[],[andrew_runpath_switch="none"],
+ [andrew_runpath_switch="none"])
+ ])
+ LDFLAGS="${SAVE_LDFLAGS}"
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.27-scram.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.27-scram.patch
new file mode 100644
index 000000000000..1bc3c9d595b4
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-1.5.27-scram.patch
@@ -0,0 +1,19 @@
+--- plugins/scram.c.gentoo Sat Jan 19 03:28:55 2002
++++ plugins/scram.c Sat Jan 19 03:28:02 2002
+@@ -255,7 +255,7 @@
+ if (! getsecret)
+ return SASL_FAIL;
+
+- result = getsecret(getsecret_context, "SCRAM-MD5", user, &sec);
++ result = getsecret(getsecret_context, "SCRAM-MD5", user, "", &sec);
+ if (result != SASL_OK)
+ return result;
+
+@@ -600,6 +600,7 @@
+ return putsecret(putsecret_context,
+ "SCRAM-MD5",
+ user,
++ "",
+ secret);
+ }
+
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-configdir.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-configdir.patch
new file mode 100644
index 000000000000..56156bcb39fb
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-configdir.patch
@@ -0,0 +1,244 @@
+diff -urN cyrus-sasl-1.5.21.orig/acconfig.h cyrus-sasl-1.5.21/acconfig.h
+--- cyrus-sasl-1.5.21.orig/acconfig.h Tue Mar 7 06:19:51 2000
++++ cyrus-sasl-1.5.21/acconfig.h Thu Jun 1 13:08:35 2000
+@@ -64,6 +64,9 @@
+ /* This is where plugins will live at runtime */
+ #undef PLUGINDIR
+
++/* This is where config files will live at runtime */
++#undef CONFIGDIR
++
+ /* Make autoheader happy */
+ #undef WITH_SYMBOL_UNDERSCORE
+
+@@ -152,6 +155,7 @@
+ #endif
+
+ #define SASL_PATH_ENV_VAR "SASL_PATH"
++#define SASL_CONF_PATH_ENV_VAR "SASL_CONF_PATH"
+
+ #include <stdlib.h>
+ #include <sys/types.h>
+diff -urN cyrus-sasl-1.5.21.orig/configure.in cyrus-sasl-1.5.21/configure.in
+--- cyrus-sasl-1.5.21.orig/configure.in Tue May 9 19:52:53 2000
++++ cyrus-sasl-1.5.21/configure.in Thu Jun 1 13:48:11 2000
+@@ -583,6 +583,13 @@
+ AC_DEFINE_UNQUOTED(PLUGINDIR, "$plugindir")
+ AC_SUBST(plugindir)
+
++AC_ARG_WITH(configdir, [ --with-configdir=DIR set the directory where config files will
++ be found [/etc/sasl] ],
++ configdir=$withval,
++ configdir=/etc/sasl)
++AC_DEFINE_UNQUOTED(CONFIGDIR, "$configdir")
++AC_SUBST(configdir)
++
+ dnl look for rc4 libraries. we accept the CMU one or one from openSSL
+ AC_ARG_WITH(rc4, [ --with-rc4=DIR use rc4 (look in DIR) [yes] ],
+ with_rc4=$withval,
+diff -urN cyrus-sasl-1.5.21.orig/include/sasl.h cyrus-sasl-1.5.21/include/sasl.h
+--- cyrus-sasl-1.5.21.orig/include/sasl.h Tue May 9 19:52:53 2000
++++ cyrus-sasl-1.5.21/include/sasl.h Thu Jun 1 13:04:48 2000
+@@ -14,6 +14,7 @@
+ * sasl_getopt_t client/server: Get an option value
+ * sasl_log_t client/server: Log message handler
+ * sasl_getpath_t client/server: Get path to search for mechanisms
++ * sasl_getconfpath_t server: Get path to search for config file
+ * sasl_getsimple_t client: Get user/language list
+ * sasl_getsecret_t client: Get authentication secret
+ * sasl_chalprompt_t client: Display challenge and prompt for response
+@@ -401,6 +402,25 @@
+ const char * file, const int type);
+
+ #define SASL_CB_VERIFYFILE (4)
++
++/* getconfpath callback -- this allows applications to specify the
++ * colon-separated path to search for config files (by default,
++ * taken from the SASL_CONF_PATH environment variable).
++ * inputs:
++ * context -- getconfpath context from the callback record
++ * outputs:
++ * path -- colon seperated path (allocated on the heap; the
++ * library will free it using the sasl_free_t *
++ * passed to sasl_set_callback, or the standard free()
++ * library call).
++ * returns:
++ * SASL_OK -- no error
++ * SASL_FAIL -- error
++ */
++typedef int sasl_getconfpath_t(void * context,
++ char ** path);
++
++#define SASL_CB_GETCONFPATH (5)
+
+ /* these are the types of files libsasl will ask about */
+ #define SASL_VRFY_PLUGIN (1)
+diff -urN cyrus-sasl-1.5.21.orig/lib/common.c cyrus-sasl-1.5.21/lib/common.c
+--- cyrus-sasl-1.5.21.orig/lib/common.c Fri May 5 14:41:42 2000
++++ cyrus-sasl-1.5.21/lib/common.c Thu Jun 1 12:53:19 2000
+@@ -666,6 +666,20 @@
+ }
+
+ static int
++_sasl_getconfpath(void *context __attribute__((unused)),
++ char ** path_dest)
++{
++ char *path;
++
++ if (! path_dest)
++ return SASL_BADPARAM;
++ path = getenv(SASL_CONF_PATH_ENV_VAR);
++ if (! path)
++ path = CONFIGDIR;
++ return _sasl_strdup(path, path_dest, NULL);
++}
++
++static int
+ _sasl_verifyfile(void *context __attribute__((unused)),
+ char *file __attribute__((unused)),
+ int type __attribute__((unused)))
+@@ -768,6 +782,10 @@
+ *pproc = (int (*)()) &_sasl_getpath;
+ *pcontext = NULL;
+ return SASL_OK;
++ case SASL_CB_GETCONFPATH:
++ *pproc = (int (*)()) &_sasl_getconfpath;
++ *pcontext = NULL;
++ return SASL_OK;
+ case SASL_CB_AUTHNAME:
+ *pproc = (int (*)()) &_sasl_getsimple;
+ *pcontext = conn;
+@@ -1093,6 +1111,30 @@
+
+ return &default_getpath_cb;
+ }
++
++const sasl_callback_t *
++_sasl_find_getconfpath_callback(const sasl_callback_t *callbacks)
++{
++ static const sasl_callback_t default_getconfpath_cb = {
++ SASL_CB_GETCONFPATH,
++ &_sasl_getconfpath,
++ NULL
++ };
++
++ if (callbacks)
++ while (callbacks->id != SASL_CB_LIST_END)
++ {
++ if (callbacks->id == SASL_CB_GETCONFPATH)
++ {
++ return callbacks;
++ } else {
++ ++callbacks;
++ }
++ }
++
++ return &default_getconfpath_cb;
++}
++
+
+ const sasl_callback_t *
+ _sasl_find_verifyfile_callback(const sasl_callback_t *callbacks)
+diff -urN cyrus-sasl-1.5.21.orig/lib/saslint.h cyrus-sasl-1.5.21/lib/saslint.h
+--- cyrus-sasl-1.5.21.orig/lib/saslint.h Wed Mar 29 06:45:21 2000
++++ cyrus-sasl-1.5.21/lib/saslint.h Thu Jun 1 12:56:37 2000
+@@ -59,6 +59,9 @@
+ _sasl_find_getpath_callback(const sasl_callback_t *callbacks);
+
+ extern const sasl_callback_t *
++_sasl_find_getconfpath_callback(const sasl_callback_t *callbacks);
++
++extern const sasl_callback_t *
+ _sasl_find_verifyfile_callback(const sasl_callback_t *callbacks);
+
+ extern int _sasl_done_with_plugin(void *plugin);
+diff -urN cyrus-sasl-1.5.21.orig/lib/server.c cyrus-sasl-1.5.21/lib/server.c
+--- cyrus-sasl-1.5.21.orig/lib/server.c Tue May 9 19:52:53 2000
++++ cyrus-sasl-1.5.21/lib/server.c Thu Jun 1 12:59:03 2000
+@@ -540,15 +540,15 @@
+ char *path_to_config=NULL, *c;
+ char *config_filename=NULL;
+ int len;
+- const sasl_callback_t *getpath_cb=NULL;
++ const sasl_callback_t *getconfpath_cb=NULL;
+
+ /* get the path to the plugins; for now the config file will reside there */
+- getpath_cb=_sasl_find_getpath_callback( global_callbacks.callbacks );
+- if (getpath_cb==NULL) return SASL_BADPARAM;
++ getconfpath_cb=_sasl_find_getconfpath_callback( global_callbacks.callbacks );
++ if (getconfpath_cb==NULL) return SASL_BADPARAM;
+
+- /* getpath_cb->proc MUST be a sasl_getpath_t; if only c had a type
++ /* getconfpath_cb->proc MUST be a sasl_getconfpath_t; if only c had a type
+ system */
+- result = ((sasl_getpath_t *)(getpath_cb->proc))(getpath_cb->context,
++ result = ((sasl_getconfpath_t *)(getconfpath_cb->proc))(getconfpath_cb->context,
+ &path_to_config);
+ if (result!=SASL_OK) goto done;
+ if (path_to_config == NULL) path_to_config = "";
+diff -urN cyrus-sasl-1.5.21.orig/man/sasl_getconfpath_t.3 cyrus-sasl-1.5.21/man/sasl_getconfpath_t.3
+--- cyrus-sasl-1.5.21.orig/man/sasl_getconfpath_t.3 Thu Jan 1 01:00:00 1970
++++ cyrus-sasl-1.5.21/man/sasl_getconfpath_t.3 Thu Jun 1 13:54:07 2000
+@@ -0,0 +1,47 @@
++.\" Hey Emacs! This file is -*- nroff -*- source.
++.\"
++.\" This manpage is Copyright (C) 1999 Tim Martin
++.\"
++.\" Permission is granted to make and distribute verbatim copies of this
++.\" manual provided the copyright notice and this permission notice are
++.\" preserved on all copies.
++.\"
++.\" Permission is granted to copy and distribute modified versions of this
++.\" manual under the conditions for verbatim copying, provided that the
++.\" entire resulting derived work is distributed under the terms of a
++.\" permission notice identical to this one
++.\"
++.\" Formatted or processed versions of this manual, if unaccompanied by
++.\" the source, must acknowledge the copyright and authors of this work.
++.\"
++.\"
++.TH sasl_getpath_t "26 March 2000" SASL "SASL man pages"
++.SH NAME
++sasl_getconfpath_t \- The SASL callback to indicate location of the config files
++
++
++.SH SYNOPSIS
++.nf
++.B #include <sasl.h>
++
++.sp
++.BI "int sasl_getconfpath_t(void " *context ", "
++.BI " char ** " path ")";
++
++.fi
++.SH DESCRIPTION
++
++.B sasl_getconfpath_t
++is used if the application wishes to use a different location for the SASL cofiguration files. If this callback is not used SASL will either use the location in the enviornment variable SASL_CONF_PATH or /etc/sasl by default.
++.PP
++
++.SH "RETURN VALUE"
++
++SASL callback functions should return SASL return codes. See sasl.h for a complete list. SASL_OK indicates success.
++
++.SH "CONFORMING TO"
++RFC 2222
++.SH "SEE ALSO"
++.BR other sasl stuff
++.BR
++.BR
+\ No newline at end of file
+diff -urN cyrus-sasl-1.5.21.orig/win32/include/config.h cyrus-sasl-1.5.21/win32/include/config.h
+--- cyrus-sasl-1.5.21.orig/win32/include/config.h Tue May 9 19:52:53 2000
++++ cyrus-sasl-1.5.21/win32/include/config.h Thu Jun 1 13:07:47 2000
+@@ -72,7 +72,9 @@
+ #define HAVE_MEMCPY 1
+
+ #define SASL_PATH_ENV_VAR "SASL_PATH"
++#define SASL_CONF_PATH_ENV_VAR "SASL_CONF_PATH"
+ #define PLUGINDIR "\\sasl-plugins"
++#define CONFIGDIR "\\sasl-configs"
+
+ /* Windows calls these functions something else
+ */
+
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-saslauthd.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-saslauthd.patch
new file mode 100644
index 000000000000..5282655cf2c9
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-saslauthd.patch
@@ -0,0 +1,199 @@
+--- cyrus-sasl-1.5.27/saslauthd/Makefile.am.wiget Tue Apr 24 18:09:22 2001
++++ cyrus-sasl-1.5.27/saslauthd/Makefile.am Tue Apr 24 18:10:05 2001
+@@ -2,7 +2,7 @@
+ man_MANS = saslauthd.8
+
+ saslauthd_SOURCES = saslauthd.c mechanisms.c globals.h mechanisms.h auth_dce.c auth_dce.h auth_getpwent.c auth_getpwent.h auth_krb4.c auth_krb4.h auth_pam.c auth_pam.h auth_rimap.c auth_rimap.h auth_shadow.c auth_shadow.h auth_sia.c auth_sia.h
+-saslauthd_LDADD = @SASL_KRB_LIB@
++saslauthd_LDADD = @SASL_KRB_LIB@ @LIB_PAM@ @LIB_CRYPT@
+
+ INCLUDES = -I$(top_srcdir)/include
+ EXTRA_DIST = saslauthd.8
+--- cyrus-sasl-1.5.27/saslauthd/saslauthd.8.in.mdk Wed Oct 17 14:35:31 2001
++++ cyrus-sasl-1.5.27/saslauthd/saslauthd.8.in Wed Oct 17 14:35:40 2001
+@@ -1,29 +1,28 @@
+ .\" $Id: cyrus-sasl-saslauthd.patch,v 1.1 2002/02/19 00:36:20 woodchip Exp $
+ .\" Copyright 1997-2000 Messaging Direct Ltd. All rights reserved.
+-.Dt SASLAUTHD 8
+-.Os "CMU-SASL"
+-.Sh NAME
+-.Nm saslauthd
+-.Nd message store authentication server
+-.Sh SYNOPSIS
+-.Nm
++.TH SASLAUTHD 8 "CMU-SASL"
++.B saslauthd saslauthd
++.SH NAME
++saslauthd \- message store authentication server
++.SH SYNOPSIS
++.B saslauthd
+ .Fl a
+ .Ar authmech
+ .Op Fl \&Tv
+ .Op Fl H Ar hostname
+ .Op Fl m Ar mux_path
+-.Sh DESCRIPTION
+-.Nm
++.SH DESCRIPTION
++.B saslauthd
+ is a daemon process that handles plaintext authentication requests
+ on behalf of the SASL library.
+-.Pp
++.PP
+ The server fulfills two roles: it isolates all code requiring superuser
+ privileges into a single process, and it can be used to provide
+ .Em proxy
+ authentication services to clients that do not understand
+ SASL based authentication.
+-.Pp
+-.Nm
++.PP
++.B saslauthd
+ should be
+ started from the system boot scripts when going to
+ multi-user mode. When running against a protected authentication
+@@ -31,7 +30,7 @@
+ .Li shadow
+ mechanism),
+ it must be run as the superuser.
+-.Ss Options
++.Sx Options
+ Options named by lower\-case letters configure the server itself.
+ Upper\-case options control the behavior of specific authentication
+ mechanisms; their applicability to a particular authentication
+@@ -61,14 +60,14 @@
+ mechanisms on standard error, then exit.
+ .El
+ .Ss Logging
+-.Nm
++.B saslauthd
+ logs it's activities via
+-.Nm syslogd
++.B syslogd
+ using the
+ .Dv LOG_AUTH
+ facility.
+-.Sh AUTHENTICATION MECHANISMS
+-.Nm
++.SH AUTHENTICATION MECHANISMS
++.B saslauthd
+ supports one or more
+ .Qq authentication mechanisms ,
+ dependent upon the facilities provided by the underlying operating system.
+@@ -78,17 +77,17 @@
+ .Bl -tag -width "kerberos4"
+ .It Li sasldb
+ .Em (All platforms)
+-.Pp
++.PP
+ Authenticate against the
+ SASL
+ authentication database.
+ .It Li dce
+ .Em (AIX)
+-.Pp
++.PP
+ Authenticate using the DCE authentication environment.
+ .It Li getpwent
+ .Em (All platforms)
+-.Pp
++.PP
+ Authenticate using the
+ .Fn getpwent
+ library function. Typically this authenticates against the
+@@ -97,13 +96,13 @@
+ man page for details.
+ .It Li kerberos4
+ .Em (All platforms)
+-.Pp
++.PP
+ Authenticate against the local Kerberos 4 realm. (See the
+ .Sx NOTES
+ section for caveats about this driver.)
+ .It Li rimap
+ .Em (All platforms)
+-.Pp
++.PP
+ Forward authentication requests to a remote IMAP server. This driver
+ connects to a remote IMAP server, specified using the -H flag,
+ and attempts to login (via an IMAP
+@@ -116,7 +115,7 @@
+ .Ql LOGIN
+ command is received from the remote
+ server.
+-.Pp
++.PP
+ The
+ .Ar hostname
+ parameter to the
+@@ -134,7 +133,7 @@
+ to the
+ .Ar hostname
+ argument.
+-.Pp
++.PP
+ The
+ .Fl H
+ flag and argument are mandatory when using the
+@@ -142,11 +141,11 @@
+ mechanism.
+ .It Li shadow
+ .Em (AIX, Irix, Linux, Solaris)
+-.Pp
++.PP
+ Authenticate against the local
+ .Qq shadow password file .
+ The exact mechanism is system dependent.
+-.Nm
++.B saslauthd
+ currently understands the
+ .Fn getspnam
+ and
+@@ -157,14 +156,14 @@
+ flag.
+ .It Li sia
+ .Em (Digital UNIX)
+-.Pp
++.PP
+ Authenticate using the Digital
+-.Ux
++.UX
+ Security Integration Architecture
+ (a.k.a.
+ .Qq enhanced security ) .
+ .El
+-.Sh NOTES
++.SH NOTES
+ The
+ .Li kerberos4
+ authentication driver consumes considerable resources. To perform an
+@@ -175,20 +174,21 @@
+ local ticket file, on the reasonable assumption that you will want
+ to save the TGT for use by other Kerberos applications. These ticket
+ files are unusable by
++.B saslauthd
+ .Nm No ,
+ however there is no way not to create them. The overhead of creating
+ and removing
+ these ticket files can cause serious performance degradation on busy
+ servers. (Kerberos
+ was never intended to be used in this manner, anyway.)
+-.Sh FILES
++.SH FILES
+ .Bl -tag -compact
+ .It Pa @MAN_PATH_SASLAUTHD_RUNDIR@/mux
+ The default communications socket.
+-.Sh SEE ALSO
+-.Xr passwd 1 ,
+-.Xr getpwent 3 ,
+-.Xr getspnam 3 ,
+-.Xr getuserpw 3 ,
+-.Xr sia_authenticate_user 3 ,
+-.Xr saslpasswd 8
++.SH SEE ALSO
++.BR passwd (1) ,
++.BR getpwent (3) ,
++.BR getspnam (3) ,
++.BR getuserpw (3) ,
++.BR sia_authenticate_user (3) ,
++.BR saslpasswd (8)
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27
new file mode 100644
index 000000000000..477dd8cc141c
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27
@@ -0,0 +1 @@
+MD5 76ea426e2e2da3b8d2e3a43af5488f3b cyrus-sasl-1.5.27.tar.gz 528252
diff --git a/dev-libs/cyrus-sasl/files/pwcheck.rc6 b/dev-libs/cyrus-sasl/files/pwcheck.rc6
new file mode 100644
index 000000000000..887707089a9f
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/pwcheck.rc6
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/files/pwcheck.rc6,v 1.1 2002/02/19 00:36:20 woodchip Exp $
+
+depend() {
+ need localmount
+ use logger
+}
+
+start() {
+ ebegin "Starting sasl pwcheck daemon"
+ start-stop-daemon --start --quiet --oknodo --exec /usr/sbin/pwcheck
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping sasl pwcheck daemon"
+ start-stop-daemon --stop --quiet --oknodo --exec /usr/sbin/pwcheck
+ eend $?
+}
diff --git a/dev-libs/cyrus-sasl/files/saslauthd.confd b/dev-libs/cyrus-sasl/files/saslauthd.confd
new file mode 100644
index 000000000000..c0900d710f8a
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/saslauthd.confd
@@ -0,0 +1,20 @@
+# Config file for /etc/init.d/saslauthd
+
+# Authentications mechanism (for list see saslauthd -v)
+SASL_AUTHMECH=pam
+
+# Hostname for remote IMAP server (if rimap auth mech is used)
+SASL_RIMAP_HOSTNAME=""
+
+# Honour time-of-day login restrictions (if shadow auth mech is used)
+# Make this ="" to turn it off. Putting =no will turn it on!
+SASL_TIME_OF_DAY_LOGIN_RESTRICTIONS=yes
+
+
+# Tack the above options together
+[ -n ${SASL_AUTHMECH} ] && \
+ SASLAUTHD_OPTS="-a ${SASL_AUTHMECH}"
+[ -n ${SASL_RIMAP_HOSTNAME} ] && \
+ SASLAUTHD_OPTS="${SASLAUTHD_OPTS} -H ${SASL_RIMAP_HOSTNAME}"
+[ -n ${SASL_TIME_OF_DAY_LOGIN_RESTRICTIONS} ] && \
+ SASLAUTHD_OPTS="${SASLAUTHD_OPTS} -T"
diff --git a/dev-libs/cyrus-sasl/files/saslauthd.rc6 b/dev-libs/cyrus-sasl/files/saslauthd.rc6
new file mode 100644
index 000000000000..5783e736363a
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/saslauthd.rc6
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/files/saslauthd.rc6,v 1.1 2002/02/19 00:36:20 woodchip Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting saslauthd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/saslauthd \
+ -- ${SASLAUTHD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping saslauthd"
+ start-stop-daemon --stop --quiet --pidfile /var/lib/sasl/mux.pid
+ eend $?
+}