summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-08-23 20:33:35 +0000
committerStefan Jones <cretin@gentoo.org>2003-08-23 20:33:35 +0000
commit00fc2d89964495b1b8339b200bc72fd86e50eb91 (patch)
treef002e1d3da875d2edf3d880a900734bf83ec8236 /dev-libs/elfutils/elfutils-0.84.ebuild
parentNew version of elfutils, prelink tested fine here ( ~x86 ) (diff)
downloadgentoo-2-00fc2d89964495b1b8339b200bc72fd86e50eb91.tar.gz
gentoo-2-00fc2d89964495b1b8339b200bc72fd86e50eb91.tar.bz2
gentoo-2-00fc2d89964495b1b8339b200bc72fd86e50eb91.zip
New version of elfutils, prelink tested fine here ( ~x86 )
Diffstat (limited to 'dev-libs/elfutils/elfutils-0.84.ebuild')
-rw-r--r--dev-libs/elfutils/elfutils-0.84.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/elfutils/elfutils-0.84.ebuild b/dev-libs/elfutils/elfutils-0.84.ebuild
new file mode 100644
index 000000000000..b241d3f9aded
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.84.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.84.ebuild,v 1.1 2003/08/23 20:33:34 cretin Exp $
+
+inherit eutils
+
+IUSE=""
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Libraries and utilities to handle compiled objects.
+This should be a drop in replacement for libelf."
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.redhat.com/"
+
+LICENSE="OpenSoftware"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-3.2.1-r6
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+
+ for x in $(find ${S}/ -name Makefile.in) ; do
+ cp ${x} ${x}.orig
+ sed -e 's:-Werror::g' \
+ ${x}.orig > ${x}
+ done
+}
+
+src_compile() {
+ econf --program-prefix="eu-" \
+ --enable-shared || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Remove stuff we do not use ...
+ rm -f ${D}/usr/bin/eu-ld
+ rm -f ${D}/usr/include/elfutils/lib{asm,dw,dwarf}.h
+ rm -f ${D}/usr/lib/lib{asm,dw}-${PV}.so
+ rm -f ${D}/usr/lib/lib{asm,dw}.so*
+ rm -f ${D}/usr/lib/lib{asm,dw,dwarf}.a
+ rm -rf ${D}/usr/usr
+
+ dodoc AUTHORS COPYING ChangeLog NEWS NOTES README THANKS TODO
+}