summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-21 04:55:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-21 04:55:59 +0000
commitab790ca8c594073b599df12f2b932558a76d1f2f (patch)
tree173fd867e2d9d78fd982a82ce0fa93662dba7ca9 /dev-libs/expat/expat-1.95.8.ebuild
parentRemoving ucd-snmp from the tree as per bug #69451. mask no longer needed (diff)
downloadgentoo-2-ab790ca8c594073b599df12f2b932558a76d1f2f.tar.gz
gentoo-2-ab790ca8c594073b599df12f2b932558a76d1f2f.tar.bz2
gentoo-2-ab790ca8c594073b599df12f2b932558a76d1f2f.zip
ppc stable and make sure that $D is removed from .la files #81568
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-libs/expat/expat-1.95.8.ebuild')
-rw-r--r--dev-libs/expat/expat-1.95.8.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/dev-libs/expat/expat-1.95.8.ebuild b/dev-libs/expat/expat-1.95.8.ebuild
index 4e280a5a358f..486586d9ac13 100644
--- a/dev-libs/expat/expat-1.95.8.ebuild
+++ b/dev-libs/expat/expat-1.95.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.8.ebuild,v 1.13 2005/02/08 18:22:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-1.95.8.ebuild,v 1.14 2005/02/21 04:55:59 vapier Exp $
-inherit gnuconfig libtool
+inherit libtool
DESCRIPTION="XML parsing libraries"
HOMEPAGE="http://expat.sourceforge.net/"
@@ -10,23 +10,31 @@ SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ~ppc ~ppc64 ppc-macos s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos s390 sh sparc x86"
IUSE="test"
DEPEND="virtual/libc
test? ( >=dev-libs/check-0.8 )"
+RDEPEND="virtual/libc"
src_unpack() {
- hasq "test" ${FEATURES} && ! use test && die "You must put test into your USE if you have FEATURES=test"
-
unpack ${A}
cd "${S}"
- gnuconfig_update
uclibctoolize
}
+src_test() {
+ if ! use test && [[ -z $(best_version dev-libs/check) ]] ; then
+ ewarn "You dont have USE=test and dev-libs/check is not installed."
+ ewarn "src_test will be skipped."
+ return 0
+ fi
+ make check || die "make check failed"
+}
+
src_install() {
- einstall man1dir="${D}/usr/share/man/man1" || die
+ einstall man1dir="${D}/usr/share/man/man1" || die "einstall failed"
+ dosed /usr/$(get_libdir)/libexpat.la #81568
dodoc Changes README
- dohtml doc/
+ dohtml doc/*
}