summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-11-13 20:51:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-11-13 20:51:24 +0000
commit6834ed159937452a5708ff05005756865bffff7a (patch)
tree1ba61c99aefe5f0eee5e93b50834ad82169ed386 /dev-libs/geoip/geoip-1.3.14.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6834ed159937452a5708ff05005756865bffff7a.tar.gz
gentoo-2-6834ed159937452a5708ff05005756865bffff7a.tar.bz2
gentoo-2-6834ed159937452a5708ff05005756865bffff7a.zip
version bump. Added -fPIC as per bug #103663
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-libs/geoip/geoip-1.3.14.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.3.14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.3.14.ebuild b/dev-libs/geoip/geoip-1.3.14.ebuild
new file mode 100644
index 000000000000..e649486d5801
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.3.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.3.14.ebuild,v 1.1 2005/11/13 20:51:24 dragonheart Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/geoip/GeoIP}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-libs/zlib"
+
+src_compile() {
+ append-flags -fPIC
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "einstall failed"
+}