summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-26 20:39:10 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-26 20:39:10 +0000
commit950964ffbeabac649f17cb376a3c0e9e18eea786 (patch)
treecfa0210046a2fe0063c24d290f4cc852c76f78d0 /dev-libs/glib
parentInitial version, new dependency of dev-ruby/crack (diff)
downloadgentoo-2-950964ffbeabac649f17cb376a3c0e9e18eea786.tar.gz
gentoo-2-950964ffbeabac649f17cb376a3c0e9e18eea786.tar.bz2
gentoo-2-950964ffbeabac649f17cb376a3c0e9e18eea786.zip
Apply upstream patch reverting a change that could cause problems with some ext3/4 setups, adapt bash-completion dir relying on eclass. Drop old.
(Portage version: 2.1.13/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog10
-rw-r--r--dev-libs/glib/files/glib-2.36.3-revert-ext34.patch37
-rw-r--r--dev-libs/glib/glib-2.36.3-r1.ebuild (renamed from dev-libs/glib/glib-2.36.2.ebuild)46
3 files changed, 63 insertions, 30 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 386164963cec..d32bdc0f6cba 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.564 2013/07/17 04:59:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.565 2013/07/26 20:39:10 pacho Exp $
+
+*glib-2.36.3-r1 (26 Jul 2013)
+
+ 26 Jul 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/glib-2.36.3-revert-ext34.patch, +glib-2.36.3-r1.ebuild,
+ -glib-2.36.2.ebuild:
+ Apply upstream patch reverting a change that could cause problems with some
+ ext3/4 setups, adapt bash-completion dir relying on eclass. Drop old.
17 Jul 2013; Samuli Suominen <ssuominen@gentoo.org> glib-2.36.3.ebuild:
Stop applying glib-2.32.4-bashcomp.patch because the upstream default of
diff --git a/dev-libs/glib/files/glib-2.36.3-revert-ext34.patch b/dev-libs/glib/files/glib-2.36.3-revert-ext34.patch
new file mode 100644
index 000000000000..041419791273
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.36.3-revert-ext34.patch
@@ -0,0 +1,37 @@
+From 05d430065da918051a97e3384c4b2252af47503d Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Thu, 20 Jun 2013 17:13:29 +0000
+Subject: Revert "g_file_set_contents(): don't fsync on ext3/4"
+
+We didn't actually do any real-world testing of this, and
+unsurprisingly it turns out to break in at least one widely-used
+configuration (Fedora 19 x86_64, ext4 on LVM).
+
+This reverts commit 9d0c17b50102267a5029b58b1f44efbad82d8f03.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=701560
+---
+diff --git a/glib/gfileutils.c b/glib/gfileutils.c
+index b6ca3bb..2980098 100644
+--- a/glib/gfileutils.c
++++ b/glib/gfileutils.c
+@@ -1088,16 +1088,9 @@ write_to_temp_file (const gchar *contents,
+ /* On Linux, on btrfs, skip the fsync since rename-over-existing is
+ * guaranteed to be atomic and this is the only case in which we
+ * would fsync() anyway.
+- *
+- * ext3 and ext4 are also safe in this respect under the default
+- * mount options (and if someone picks non-default options to
+- * improve their performance at the cost of reliability, who are we
+- * to argue?)
+- *
+- * Note: EXT[234]_SUPER_MAGIC are equal.
+ */
+
+- if (fstatfs (fd, &buf) == 0 && (buf.f_type == BTRFS_SUPER_MAGIC || buf.f_type == EXT3_SUPER_MAGIC))
++ if (fstatfs (fd, &buf) == 0 && buf.f_type == BTRFS_SUPER_MAGIC)
+ goto no_fsync;
+ }
+ #endif
+--
+cgit v0.9.2
diff --git a/dev-libs/glib/glib-2.36.2.ebuild b/dev-libs/glib/glib-2.36.3-r1.ebuild
index 228dfc57aa1b..77249562ef11 100644
--- a/dev-libs/glib/glib-2.36.2.ebuild
+++ b/dev-libs/glib/glib-2.36.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.36.2.ebuild,v 1.1 2013/05/14 22:15:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.36.3-r1.ebuild,v 1.1 2013/07/26 20:39:10 pacho Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{5,6,7} )
# Avoid runtime dependency on python when USE=test
-inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python-r1 toolchain-funcs virtualx linux-info
+inherit autotools bash-completion-r1 gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python-r1 toolchain-funcs versionator virtualx linux-info
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -40,13 +40,19 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
>=dev-util/gdbus-codegen-${PV}[${PYTHON_USEDEP}]
>=sys-apps/dbus-1.2.14 )
+ !<dev-libs/gobject-introspection-1.$(get_version_component_range 2)
!<dev-util/gtk-doc-1.15-r2
"
+# gobject-introspection blocker to ensure people don't mix
+# different g-i and glib major versions
+
PDEPEND="x11-misc/shared-mime-info
!<gnome-base/gvfs-1.6.4-r990"
# shared-mime-info needed for gio/xdgmime, bug #409481
# Earlier versions of gvfs do not work with glib
+DOCS="AUTHORS ChangeLog* NEWS* README"
+
pkg_setup() {
if use kernel_linux ; then
CONFIG_CHECK="~INOTIFY_USER"
@@ -117,13 +123,17 @@ src_prepare() {
# gdbus-codegen is a separate package
epatch "${FILESDIR}/${PN}-2.35.x-external-gdbus-codegen.patch"
- # bashcomp goes in /usr/share/bash-completion
- epatch "${FILESDIR}/${PN}-2.32.4-bashcomp.patch"
-
# leave python shebang alone
sed -e '/${PYTHON}/d' \
-i glib/Makefile.{am,in} || die
+ # Gentoo handles completions in a different directory
+ sed -i "s|^completiondir =.*|completiondir = $(get_bashcompdir)|" \
+ gio/Makefile.am || die
+
+ # Revert "g_file_set_contents(): don't fsync on ext3/4" (from 2.36 branch)
+ epatch "${FILESDIR}/${P}-revert-ext34.patch"
+
epatch_user
# Needed for the punt-python-check patch, disabling timeout test
@@ -132,7 +142,7 @@ src_prepare() {
eautoreconf
# FIXME: Really needed when running eautoreconf before? bug#????
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
+ #[[ ${CHOST} == *-freebsd* ]] && elibtoolize
epunt_cxx
}
@@ -155,7 +165,6 @@ src_configure() {
# Building with --disable-debug highly unrecommended. It will build glib in
# an unusable form as it disables some commonly used API. Please do not
# convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
use debug && myconf="--enable-debug"
# Always use internal libpcre, bug #254659
@@ -174,7 +183,7 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}"
+ default
if use utils ; then
python_replicate_script "${ED}"/usr/bin/gtester-report
@@ -189,8 +198,6 @@ src_install() {
# Don't install gdb python macros, bug 291328
rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
- dodoc AUTHORS ChangeLog* NEWS* README
-
# Completely useless with or without USE static-libs, people need to use
# pkg-config
prune_libtool_files --modules
@@ -221,26 +228,7 @@ src_test() {
Xemake check
}
-pkg_preinst() {
- # Only give the introspection message if:
- # * The user has gobject-introspection
- # * Has glib already installed
- # * Previous version was different from new version
- # TODO: add a subslotted virtual to trigger this automatically
- if has_version "dev-libs/gobject-introspection" && ! has_version "=${CATEGORY}/${PF}"; then
- ewarn "You must rebuild gobject-introspection so that the installed"
- ewarn "typelibs and girs are regenerated for the new APIs in glib"
- fi
-}
-
pkg_postinst() {
- # Inform users about possible breakage when updating glib and not dbus-glib, bug #297483
- # TODO: add a subslotted virtual to trigger this automatically
- if has_version dev-libs/dbus-glib; then
- ewarn "If you experience a breakage after updating dev-libs/glib try"
- ewarn "rebuilding dev-libs/dbus-glib"
- fi
-
if has_version '<x11-libs/gtk+-3.0.12:3'; then
# To have a clear upgrade path for gtk+-3.0.x users, have to resort to
# a warning instead of a blocker