summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-05 16:35:21 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-05 16:35:21 +0000
commitd5158e5199e0aa3ca84d0c296bb6ce5d8662ffde (patch)
treef99ad515320467ba9fb76f25526fb2381efafbc5 /dev-libs/glib
parentRemoved old. (diff)
downloadgentoo-2-d5158e5199e0aa3ca84d0c296bb6ce5d8662ffde.tar.gz
gentoo-2-d5158e5199e0aa3ca84d0c296bb6ce5d8662ffde.tar.bz2
gentoo-2-d5158e5199e0aa3ca84d0c296bb6ce5d8662ffde.zip
Restore forgotten cross-compile fix from 2.30.x (bug #414761, thanks to Samuli Suominen).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/glib-2.32.1.ebuild10
-rw-r--r--dev-libs/glib/glib-2.32.2.ebuild10
3 files changed, 18 insertions, 9 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index ec1d32258a7c..c6f9fc98d59e 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.522 2012/05/05 14:11:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.523 2012/05/05 16:35:21 tetromino Exp $
+
+ 05 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org> glib-2.32.1.ebuild,
+ glib-2.32.2.ebuild:
+ Restore forgotten cross-compile fix from 2.30.x (bug #414761, thanks to
+ Samuli Suominen).
05 May 2012; Samuli Suominen <ssuominen@gentoo.org> glib-2.30.2.ebuild,
glib-2.30.3.ebuild, glib-2.32.1.ebuild, glib-2.32.2.ebuild:
diff --git a/dev-libs/glib/glib-2.32.1.ebuild b/dev-libs/glib/glib-2.32.1.ebuild
index bd888d1842e4..8355e635ac59 100644
--- a/dev-libs/glib/glib-2.32.1.ebuild
+++ b/dev-libs/glib/glib-2.32.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.8 2012/05/05 14:11:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.1.ebuild,v 1.9 2012/05/05 16:35:21 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
# Avoid runtime dependency on python when USE=test
-inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python virtualx linux-info
+inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python toolchain-funcs virtualx linux-info
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -137,8 +137,10 @@ src_prepare() {
}
src_configure() {
- # Avoid circular depend with dev-util/pkgconfig
- if ! has_version virtual/pkgconfig; then
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! has_version virtual/pkgconfig; then
if has_version sys-apps/dbus; then
export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
export DBUS1_LIBS="-ldbus-1"
diff --git a/dev-libs/glib/glib-2.32.2.ebuild b/dev-libs/glib/glib-2.32.2.ebuild
index 1f07f21cb0f3..f044c8184143 100644
--- a/dev-libs/glib/glib-2.32.2.ebuild
+++ b/dev-libs/glib/glib-2.32.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.2.ebuild,v 1.2 2012/05/05 14:11:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.32.2.ebuild,v 1.3 2012/05/05 16:35:21 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
# Avoid runtime dependency on python when USE=test
-inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python virtualx linux-info
+inherit autotools gnome.org libtool eutils flag-o-matic gnome2-utils multilib pax-utils python toolchain-funcs virtualx linux-info
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -130,8 +130,10 @@ src_prepare() {
}
src_configure() {
- # Avoid circular depend with dev-util/pkgconfig
- if ! has_version virtual/pkgconfig; then
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! has_version virtual/pkgconfig; then
if has_version sys-apps/dbus; then
export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
export DBUS1_LIBS="-ldbus-1"