summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-15 17:15:17 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-15 17:15:17 +0000
commit3ab03c8c7f522b396a5d04da73d631470294c1e9 (patch)
treeb90d3ca2e97859470ad30d2e9e0f251dc8c5a6ca /dev-libs/gmime
parentFixed dep version on ccp4-lib (diff)
downloadgentoo-2-3ab03c8c7f522b396a5d04da73d631470294c1e9.tar.gz
gentoo-2-3ab03c8c7f522b396a5d04da73d631470294c1e9.tar.bz2
gentoo-2-3ab03c8c7f522b396a5d04da73d631470294c1e9.zip
Version bump and remove old testing
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/ChangeLog11
-rw-r--r--dev-libs/gmime/gmime-2.4.17.ebuild (renamed from dev-libs/gmime/gmime-2.2.25.ebuild)36
2 files changed, 29 insertions, 18 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index 0f579eb18feb..4e3ea8bd197e 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.107 2010/04/05 14:54:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.108 2010/06/15 17:15:17 pacho Exp $
+
+*gmime-2.4.17 (15 Jun 2010)
+
+ 15 Jun 2010; Pacho Ramos <pacho@gentoo.org> -gmime-2.2.25.ebuild,
+ +gmime-2.4.17.ebuild:
+ Version bump with bugfixes: preserve MIME-Version headers, don't register
+ an atexit() handler, allow re-initialization, use g_set_error_literal, use
+ glib's printf formatters for gint64 and size_t, added
+ --disable-cryptography configure flag and others. Remove old testing.
05 Apr 2010; Raúl Porcel <armin76@gentoo.org> gmime-2.2.24.ebuild,
gmime-2.2.25.ebuild, gmime-2.2.26.ebuild, gmime-2.4.9.ebuild:
diff --git a/dev-libs/gmime/gmime-2.2.25.ebuild b/dev-libs/gmime/gmime-2.4.17.ebuild
index 1cae1e78cc9a..0cfe66f675b3 100644
--- a/dev-libs/gmime/gmime-2.2.25.ebuild
+++ b/dev-libs/gmime/gmime-2.4.17.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.2.25.ebuild,v 1.2 2010/04/05 14:54:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.17.ebuild,v 1.1 2010/06/15 17:15:17 pacho Exp $
-inherit gnome2 eutils mono libtool autotools
+inherit gnome2 eutils mono libtool
DESCRIPTION="Utilities for creating and parsing messages using MIME"
-#SRC_URI="http://spruce.sourceforge.net/${PN}/sources/v${PV%.*}/${P}.tar.gz"
HOMEPAGE="http://spruce.sourceforge.net/gmime/"
-SLOT="0"
+SLOT="2.4"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc mono"
+IUSE="crypt doc mono"
-RDEPEND=">=dev-libs/glib-2
+RDEPEND=">=dev-libs/glib-2.12
sys-libs/zlib
mono? (
dev-lang/mono
>=dev-dotnet/gtk-sharp-2.4.0 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- dev-util/gtk-doc-am
doc? (
>=dev-util/gtk-doc-1.0
app-text/docbook-sgml-utils )
@@ -31,10 +29,9 @@ DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/gmime-2.2.23-sign-assembly.patch"
- cp "${FILESDIR}/gmime-sharp.snk" mono/
+
if use doc ; then
- #db2html should be docbook2html
+ # db2html should be docbook2html
sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
|| die "sed failed (1)"
@@ -43,17 +40,23 @@ src_unpack() {
gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
fi
- eautoreconf
+ # Use correct libdir for mono assembly
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:^prefix=:exec_prefix=:' \
+ -e 's:prefix)/lib:libdir):' \
+ mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
+
elibtoolize
}
src_compile() {
- econf $(use_enable mono) $(use_enable doc gtk-doc)
- MONO_PATH="${S}" emake || die "make failed"
+ econf $(use_enable mono) $(use_enable doc gtk-doc) $(use_enable crypt cryptography)
+ MONO_PATH="${S}" emake || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "installation failed"
+ emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR="${D}" install || die "installation failed"
if use doc ; then
# we don't use docinto/dodoc, because we don't want html doc gzipped
@@ -63,7 +66,6 @@ src_install() {
# rename these two, so they don't conflict with app-arch/sharutils
# (bug #70392) Ticho, 2004-11-10
- mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode"
- mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode"
- mono_multilib_comply
+ mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
+ mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode-${SLOT}"
}