summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-02-23 22:05:15 +0000
committerAron Griffis <agriffis@gentoo.org>2003-02-23 22:05:15 +0000
commit473cf61f44871008f8481f72776dbf53167d08f2 (patch)
tree11c3a25a4c07dcbe2eb9777e019c4a928b0a7067 /dev-libs/gmp/gmp-4.1.2.ebuild
parentnew package (diff)
downloadgentoo-2-473cf61f44871008f8481f72776dbf53167d08f2.tar.gz
gentoo-2-473cf61f44871008f8481f72776dbf53167d08f2.tar.bz2
gentoo-2-473cf61f44871008f8481f72776dbf53167d08f2.zip
make check only when DEBUG
Diffstat (limited to 'dev-libs/gmp/gmp-4.1.2.ebuild')
-rw-r--r--dev-libs/gmp/gmp-4.1.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/gmp/gmp-4.1.2.ebuild b/dev-libs/gmp/gmp-4.1.2.ebuild
index f418c49efc50..40696aedfba7 100644
--- a/dev-libs/gmp/gmp-4.1.2.ebuild
+++ b/dev-libs/gmp/gmp-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.1 2003/02/22 16:29:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.2 2003/02/23 22:05:15 agriffis Exp $
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
@@ -23,7 +23,13 @@ src_compile() {
${myconf} || die "configure failed"
emake || die "emake failed"
- make check || die "make check failed"
+
+ # It's pretty slow to run all the checks, and not really necessary
+ # on every build of this package. Just run the checks when
+ # debugging is enabled. (23 Feb 2003 agriffis)
+ if [ -n "$DEBUG" ]; then
+ make check || die "make check failed"
+ fi
}
src_install() {