summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:23:41 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:23:41 +0000
commit013509a8a32d84bcc260515899ae46b8015f88b3 (patch)
tree584c5fd86f0adf3f195012f01a06ca1e163f721e /dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-013509a8a32d84bcc260515899ae46b8015f88b3.tar.gz
gentoo-2-013509a8a32d84bcc260515899ae46b8015f88b3.tar.bz2
gentoo-2-013509a8a32d84bcc260515899ae46b8015f88b3.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild')
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild
new file mode 100644
index 000000000000..a651a014e138
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection-common/gobject-introspection-common-1.32.1.ebuild,v 1.1 2012/04/20 06:23:41 tetromino Exp $
+
+EAPI="4"
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !<dev-libs/gobject-introspection-1.32.0"
+# Before 1.32.0, ${PN} was part of gobject-introspection
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/aclocal
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ dodir /usr/share/gobject-introspection-1.0
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}