summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2007-06-22 19:33:26 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2007-06-22 19:33:26 +0000
commitb80cbfd112f93810ecdcddb84a96af4cab969dc7 (patch)
tree22c48b100a0ccd5133f256f9b73e93f8bf60dff1 /dev-libs/ibpp/ibpp-2.5.3.1.ebuild
parentSign Manfiest (diff)
downloadgentoo-2-b80cbfd112f93810ecdcddb84a96af4cab969dc7.tar.gz
gentoo-2-b80cbfd112f93810ecdcddb84a96af4cab969dc7.tar.bz2
gentoo-2-b80cbfd112f93810ecdcddb84a96af4cab969dc7.zip
Version bump, bug #106206
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'dev-libs/ibpp/ibpp-2.5.3.1.ebuild')
-rw-r--r--dev-libs/ibpp/ibpp-2.5.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/ibpp/ibpp-2.5.3.1.ebuild b/dev-libs/ibpp/ibpp-2.5.3.1.ebuild
new file mode 100644
index 000000000000..67db23b6698a
--- /dev/null
+++ b/dev-libs/ibpp/ibpp-2.5.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ibpp/ibpp-2.5.3.1.ebuild,v 1.1 2007/06/22 19:33:25 sekretarz Exp $
+
+inherit eutils
+
+MY_P=${P//./-}-src
+
+DESCRIPTION="IBPP, a C++ client API for firebird 1.0"
+HOMEPAGE="http://www.ibpp.org/"
+SRC_URI="mirror://sourceforge/ibpp/${MY_P}.zip"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-db/firebird-1.5.1"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ mkdir ${P}
+ cd ${P}
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ sh autogen.sh
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+}