summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:34:11 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:34:11 +0000
commit1b506013c05e817dea4c7e44d27281e38e7da709 (patch)
tree7044eaaf768b00db5ae7ec25518a8d6cf9b54b41 /dev-libs/icu/icu-3.8.1.ebuild
parentVersion bump from project overlay (diff)
downloadgentoo-2-1b506013c05e817dea4c7e44d27281e38e7da709.tar.gz
gentoo-2-1b506013c05e817dea4c7e44d27281e38e7da709.tar.bz2
gentoo-2-1b506013c05e817dea4c7e44d27281e38e7da709.zip
Version bump from project overlay
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-libs/icu/icu-3.8.1.ebuild')
-rw-r--r--dev-libs/icu/icu-3.8.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/icu/icu-3.8.1.ebuild b/dev-libs/icu/icu-3.8.1.ebuild
new file mode 100644
index 000000000000..2bee14d98e49
--- /dev/null
+++ b/dev-libs/icu/icu-3.8.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-3.8.1.ebuild,v 1.1 2008/01/04 13:34:10 jokey Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
+
+BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
+DOCS_PV="$(get_version_component_range 1-2)"
+DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
+DOCS_PV="${DOCS_PV/./_}"
+SRCPKG="${PN}4c-${PV//./_}-src.tgz"
+USERGUIDE="${PN}-${DOCS_PV}-userguide.zip"
+APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
+
+SRC_URI="${BASEURI}/${SRCPKG}
+ doc? ( ${DOCS_BASEURI}/${USERGUIDE}
+ ${DOCS_BASEURI}/${APIDOCS} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}/source
+
+src_unpack() {
+ unpack ${SRCPKG}
+ if use doc ; then
+ mkdir userguide
+ pushd ./userguide > /dev/null
+ unpack ${USERGUIDE}
+ popd
+
+ mkdir apidocs
+ pushd ./apidocs > /dev/null
+ unpack ${APIDOCS}
+ popd
+ fi
+
+ # See http://qa.openoffice.org/issues/show_bug.cgi?id=83146
+ # and http://bugs.icu-project.org/trac/ticket/5498 for details
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.8-setBreakType-public.diff
+
+ # do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # http://bugs.icu-project.org/trac/ticket/6102
+ for x in CFLAGS CXXFLAGS CPPFLAGS LDFLAGS ; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_compile() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html/userguide
+ doins -r "${WORKDIR}"/userguide/*
+
+ insinto /usr/share/doc/${PF}/html/apidocs
+ doins -r "${WORKDIR}"/apidocs/*
+ fi
+}