summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 15:50:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-07 15:50:54 +0000
commit1620c86b400c55fd87a047d7dcb7109fa755c711 (patch)
tree10cdd10a9ac66ed55c7c0bc3bd35bea34c0d9869 /dev-libs/icu
parentMerge updates from autoconf-wrapper to get POSIX-only code. (diff)
downloadgentoo-2-1620c86b400c55fd87a047d7dcb7109fa755c711.tar.gz
gentoo-2-1620c86b400c55fd87a047d7dcb7109fa755c711.tar.bz2
gentoo-2-1620c86b400c55fd87a047d7dcb7109fa755c711.zip
Version bump.
(Portage version: 15754-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog10
-rw-r--r--dev-libs/icu/icu-4.4_rc1.ebuild80
2 files changed, 88 insertions, 2 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 350c8262088f..10c2263f32a9 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.103 2009/12/14 18:33:14 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.104 2010/03/07 15:50:54 arfrever Exp $
+
+*icu-4.4_rc1 (07 Mar 2010)
+
+ 07 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.4_rc1.ebuild:
+ Version bump.
14 Dec 2009; Raúl Porcel <armin76@gentoo.org> icu-4.2.1.ebuild:
arm/ia64/sparc stable wrt #281267
diff --git a/dev-libs/icu/icu-4.4_rc1.ebuild b/dev-libs/icu/icu-4.4_rc1.ebuild
new file mode 100644
index 000000000000..07084859e1b7
--- /dev/null
+++ b/dev-libs/icu/icu-4.4_rc1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.4_rc1.ebuild,v 1.1 2010/03/07 15:50:54 arfrever Exp $
+
+EAPI="2"
+
+inherit flag-o-matic versionator
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
+
+BASEURI="http://download.icu-project.org/files/${PN}4c/${PV/_/}"
+DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${PV/_/}"
+DOCS_PV="${DOCS_PV/./_}"
+SRCPKG="${PN}4c-${PV//./_}-src.tgz"
+APIDOCS="${PN}4c-${PV//./_}-docs.zip"
+
+SRC_URI="${BASEURI}/${SRCPKG}
+ doc? ( ${DOCS_BASEURI}/${APIDOCS} )"
+
+LICENSE="BSD"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS=""
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+pkg_setup() {
+ # ICU fails to build with enabled optimizations (bug #296901).
+ if use arm || use ia64 || use sparc; then
+ filter-flags -O*
+ fi
+}
+
+src_unpack() {
+ unpack ${SRCPKG}
+ if use doc; then
+ mkdir apidocs
+ pushd apidocs > /dev/null
+ unpack ${APIDOCS}
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # https://bugs.icu-project.org/trac/ticket/6102
+ for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
+ done
+
+# epatch "${FILESDIR}/${PN}-4.2.1-pkgdata-build_data_without_assembly.patch"
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_test() {
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/apidocs
+ doins -r "${WORKDIR}"/apidocs/*
+ fi
+}