summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2011-11-20 19:30:06 +0000
committerJory Pratt <anarchy@gentoo.org>2011-11-20 19:30:06 +0000
commitb204c864cd43b2b20ee8602ec5c404f230eb1c47 (patch)
tree30aa067960f58b1efd64f89a2b303729f9163cc4 /dev-libs/jemalloc
parentRemove old (diff)
downloadgentoo-2-b204c864cd43b2b20ee8602ec5c404f230eb1c47.tar.gz
gentoo-2-b204c864cd43b2b20ee8602ec5c404f230eb1c47.tar.bz2
gentoo-2-b204c864cd43b2b20ee8602ec5c404f230eb1c47.zip
Fix huge_ralloc() race when using mremap(2), version bump
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog7
-rw-r--r--dev-libs/jemalloc/jemalloc-2.2.5.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
index 379dd78dadf2..9c69ae42d34b 100644
--- a/dev-libs/jemalloc/ChangeLog
+++ b/dev-libs/jemalloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jemalloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.7 2011/11/09 19:53:21 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.8 2011/11/20 19:30:06 anarchy Exp $
+
+*jemalloc-2.2.5 (20 Nov 2011)
+
+ 20 Nov 2011; Jory A. Pratt <anarchy@gentoo.org> +jemalloc-2.2.5.ebuild:
+ Fix huge_ralloc() race when using mremap(2), version bump
09 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org> jemalloc-2.2.3.ebuild:
Marked ~ppc/~ppc64 at the request of Tomáš Chvátal <scarabeus@gentoo.org>
diff --git a/dev-libs/jemalloc/jemalloc-2.2.5.ebuild b/dev-libs/jemalloc/jemalloc-2.2.5.ebuild
new file mode 100644
index 000000000000..b2d9a600e9b8
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-2.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.2.5.ebuild,v 1.1 2011/11/20 19:30:06 anarchy Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+IUSE="debug stats"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-strip-optimization.patch" \
+ "${FILESDIR}/${PN}-2.2.1-no-pprof.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-jemalloc-prefix=j \
+ $(use_enable debug) \
+ $(use_enable stats)
+}