summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-03 09:19:23 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-03 09:19:23 +0000
commit1c254f83eb4fb08d8cab0e9d814dd994d875eec4 (patch)
treecea63faf2856aeffc245237256ec34e8b3a6232d /dev-libs/libelf/libelf-0.8.6.ebuild
parentInitial port. Ebuild contributed by Matthew Kennedy. (diff)
downloadgentoo-2-1c254f83eb4fb08d8cab0e9d814dd994d875eec4.tar.gz
gentoo-2-1c254f83eb4fb08d8cab0e9d814dd994d875eec4.tar.bz2
gentoo-2-1c254f83eb4fb08d8cab0e9d814dd994d875eec4.zip
version bump. homepage/src_uri change
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/libelf/libelf-0.8.6.ebuild')
-rw-r--r--dev-libs/libelf/libelf-0.8.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libelf/libelf-0.8.6.ebuild b/dev-libs/libelf/libelf-0.8.6.ebuild
new file mode 100644
index 000000000000..f949dd2cdd8c
--- /dev/null
+++ b/dev-libs/libelf/libelf-0.8.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.6.ebuild,v 1.1 2005/09/03 09:19:23 dragonheart Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="A ELF object file access library"
+HOMEPAGE="http://www.mr511.de/software/"
+SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="!dev-libs/elfutils
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-parallelmakefix.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --enable-shared \
+ || die
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ libdir=${D}usr/$(get_libdir) \
+ includedir=${D}usr/include \
+ install \
+ install-compat || die
+ dodoc ChangeLog VERSION README
+}