summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-19 17:34:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-19 17:34:06 +0000
commit44320b69fd62a64f16f290ddc9cf662d22d55889 (patch)
tree88c31772cb8b146070926d01d83abf5eb792752b /dev-libs/libgweather
parentIO-Compress replaces Compress-Zlib (diff)
downloadgentoo-2-44320b69fd62a64f16f290ddc9cf662d22d55889.tar.gz
gentoo-2-44320b69fd62a64f16f290ddc9cf662d22d55889.tar.bz2
gentoo-2-44320b69fd62a64f16f290ddc9cf662d22d55889.zip
Version bump. Translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog8
-rw-r--r--dev-libs/libgweather/libgweather-2.26.2.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 828078ca25d3..8ad1c87019be 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.35 2009/06/11 17:44:17 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.36 2009/07/19 17:34:06 eva Exp $
+
+*libgweather-2.26.2.1 (19 Jul 2009)
+
+ 19 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgweather-2.26.2.1.ebuild:
+ Version bump. Translation updates.
11 Jun 2009; Tobias Klausmann <klausman@gentoo.org> ChangeLog:
Keyworded on alpha, bug #269298
diff --git a/dev-libs/libgweather/libgweather-2.26.2.1.ebuild b/dev-libs/libgweather/libgweather-2.26.2.1.ebuild
new file mode 100644
index 000000000000..469f5081206d
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-2.26.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.26.2.1.ebuild,v 1.1 2009/07/19 17:34:06 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="python doc"
+
+RDEPEND=">=x11-libs/gtk+-2.11
+ >=dev-libs/glib-2.13
+ >=gnome-base/gconf-2.8
+ >=net-libs/libsoup-2.25.1:2.4[gnome]
+ >=dev-libs/libxml2-2.6.0
+ python? (
+ >=dev-python/pygobject-2
+ >=dev-python/pygtk-2 )
+ !<gnome-base/gnome-applets-2.22.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.3
+ >=dev-util/pkgconfig-0.19
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-all-translations-in-one-xml
+ --disable-static
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: tarball generated with broken gtk-doc, revisit me.
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ AT_M4DIR="m4" eautoreconf
+}