summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-10 20:05:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-10 20:05:21 +0000
commit5ddbfcfd494504358095bdb7f979e1d985e3b9fb (patch)
treeb0f18094bf1f2b52b2750fe420bcb20cc15a1685 /dev-libs/libiconv
parentamd64/x86 stable, bug #272874 (diff)
downloadgentoo-2-5ddbfcfd494504358095bdb7f979e1d985e3b9fb.tar.gz
gentoo-2-5ddbfcfd494504358095bdb7f979e1d985e3b9fb.tar.bz2
gentoo-2-5ddbfcfd494504358095bdb7f979e1d985e3b9fb.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libiconv')
-rw-r--r--dev-libs/libiconv/ChangeLog9
-rw-r--r--dev-libs/libiconv/libiconv-1.13.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-libs/libiconv/ChangeLog b/dev-libs/libiconv/ChangeLog
index 65c07b9b4384..8f8f0b0095db 100644
--- a/dev-libs/libiconv/ChangeLog
+++ b/dev-libs/libiconv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libiconv
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.32 2008/12/07 06:01:23 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.33 2009/06/10 20:05:21 aballier Exp $
+
+*libiconv-1.13 (10 Jun 2009)
+
+ 10 Jun 2009; Alexis Ballier <aballier@gentoo.org> +libiconv-1.13.ebuild:
+ version bump
07 Dec 2008; Mike Frysinger <vapier@gentoo.org> libiconv-1.11.ebuild:
Remove pointless USE=build support.
diff --git a/dev-libs/libiconv/libiconv-1.13.ebuild b/dev-libs/libiconv/libiconv-1.13.ebuild
new file mode 100644
index 000000000000..ce73842d53b0
--- /dev/null
+++ b/dev-libs/libiconv/libiconv-1.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.13.ebuild,v 1.1 2009/06/10 20:05:21 aballier Exp $
+
+inherit eutils multilib flag-o-matic libtool toolchain-funcs
+
+DESCRIPTION="GNU charset conversion library for libc which doesn't implement it"
+HOMEPAGE="http://www.gnu.org/software/libiconv/"
+SRC_URI="mirror://gnu/libiconv/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="!sys-libs/glibc
+ !sys-apps/man-pages"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # This patch is needed as libiconv 1.10 provides (and uses) new functions
+ # and they are not present in the old libiconv.so, and this breaks the
+ # ${DESTDIR} != ${prefix} that we use. It's a problem for Solaris, but we
+ # don't have to deal with it for now.
+ #epatch "${FILESDIR}"/${PN}-1.10-link.patch
+
+ # Make sure that libtool support is updated to link "the linux way" on
+ # FreeBSD.
+ elibtoolize
+}
+
+src_compile() {
+ # Install in /lib as utils installed in /lib like gnutar
+ # can depend on this
+
+ # Disable NLS support because that creates a circular dependency
+ # between libiconv and gettext
+
+ econf \
+ --disable-nls \
+ --enable-shared \
+ --enable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
+
+ # Move static libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib{iconv,charset}*$(get_libname)* "${D}/$(get_libdir)" || die
+ gen_usr_ldscript libiconv$(get_libname)
+ gen_usr_ldscript libcharset$(get_libname)
+}