summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-16 08:17:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-16 08:17:49 +0000
commit3856352b2324a24716b6d329c11fb90fee549886 (patch)
tree5109033c436369b5bd06f8a5666347b32035a488 /dev-libs/libmemcached
parenthttp://my.opera.com/desktopteam/blog/2012/11/15/opera-12-11-rc1 (diff)
downloadgentoo-2-3856352b2324a24716b6d329c11fb90fee549886.tar.gz
gentoo-2-3856352b2324a24716b6d329c11fb90fee549886.tar.bz2
gentoo-2-3856352b2324a24716b6d329c11fb90fee549886.zip
Bump for #443056
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libmemcached')
-rw-r--r--dev-libs/libmemcached/ChangeLog7
-rw-r--r--dev-libs/libmemcached/libmemcached-1.0.14.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-libs/libmemcached/ChangeLog b/dev-libs/libmemcached/ChangeLog
index d0aed3ab74d7..17425bbd353a 100644
--- a/dev-libs/libmemcached/ChangeLog
+++ b/dev-libs/libmemcached/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libmemcached
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.43 2012/10/09 08:43:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.44 2012/11/16 08:17:49 patrick Exp $
+
+*libmemcached-1.0.14 (16 Nov 2012)
+
+ 16 Nov 2012; Patrick Lauer <patrick@gentoo.org> +libmemcached-1.0.14.ebuild:
+ Bump for #443056
*libmemcached-1.0.11 (09 Oct 2012)
diff --git a/dev-libs/libmemcached/libmemcached-1.0.14.ebuild b/dev-libs/libmemcached/libmemcached-1.0.14.ebuild
new file mode 100644
index 000000000000..cb362ba3a463
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-1.0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.14.ebuild,v 1.1 2012/11/16 08:17:49 patrick Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://libmemcached.org/libMemcached.html"
+SRC_URI="http://launchpad.net/${PN}/1.0/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug hsieh +libevent static-libs"
+
+DEPEND="net-misc/memcached
+ dev-libs/cyrus-sasl
+ libevent? ( dev-libs/libevent )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+ if use debug; then
+ myconf="--enable-debug --enable-assert"
+ fi
+ if use hsieh; then
+ myconf+=" --enable-hsieh_hash"
+ fi
+
+ econf \
+ --disable-dtrace \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ # remove manpage to avoid collision, see bug #299330
+ rm -f "${D}"/usr/share/man/man1/memdump.*
+ newman man/memdump.1 memcached_memdump.1
+}