summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-12-26 16:43:33 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-12-26 16:43:33 +0000
commit639e11e109b74af3ca450eed2bddbad1f3d9b0d1 (patch)
tree58116389c6391bec138f5f330cb1e5ac5faeb14d /dev-libs/libpqxx/libpqxx-2.4.2.ebuild
parentVersion bumped (Manifest recommit) (diff)
downloadgentoo-2-639e11e109b74af3ca450eed2bddbad1f3d9b0d1.tar.gz
gentoo-2-639e11e109b74af3ca450eed2bddbad1f3d9b0d1.tar.bz2
gentoo-2-639e11e109b74af3ca450eed2bddbad1f3d9b0d1.zip
Version bump.
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-2.4.2.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-2.4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/libpqxx-2.4.2.ebuild b/dev-libs/libpqxx/libpqxx-2.4.2.ebuild
new file mode 100644
index 000000000000..c8a3b2c77450
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-2.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-2.4.2.ebuild,v 1.1 2004/12/26 16:43:33 jhhudso Exp $
+
+IUSE=""
+DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
+SRC_URI="ftp://gborg.postgresql.org/pub/libpqxx/stable/${P}.tar.gz"
+HOMEPAGE="http://pqxx.tk/"
+
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+DEPEND="dev-db/postgresql"
+
+src_compile() {
+ econf --enable-shared || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README* TODO
+ dohtml -r doc/html/*
+}